Plasma 5, Intel Graphics, Leap 42.3

In my Leap 42.2 installation, I added

Section "Device"
   Identifier  "Intel Graphics"
   Driver        "intel"
   Option      "AccelMethod"  "uxa"

to /etc/X11/xorg.conf.d/ as 20-intel.conf. Is this still recommended for Leap 42.3?


i cant answer your question directly regards requirement for uxa on intel, but to point out (since you do not provide context) that the default on recent cpus is modesetting, so the act of specifying any intel parameter will prevent this AFAIK. [im on skylake and modesetting is trouble free, though perhaps lower performance if that was required]

There is (was?) a bug in the Intel driver stack that causes (caused?) Plasma 5 to crash occasionally. See, plasmashell occasionally crashes on the KDE bug list. Adding that 20-intel.conf file /etc/X11/xorg.conf.d/ is a workaround. See Screen Freeze on Leap 42.2 only option is rebootin these forums. I’m asking if this is still recommended.

yes i know about the problem and for the intel driver i dont know the answer. My point was that you should check if you are using the modesetting or intel driver, since if your on modesetting and you implement the uxa directive you will end up on the intel driver (they are both reported as i915). [im totally confused over which is the default in opensuse]

Thanks for replying. I’ll just wing it sans the 20-intel file and see what happens. Once again, thanks.

I also solved this problem in this way in 42.2

My system - Celeron J1900, Intel integrated video.

In 42.3, clear install, video works without freezing, but with tear.

I found that the driver xf86-video-intel is NOT installed at all!

Installed drivers is: xf86-video-fbdev & xf86-video-vesa.
I did not check which driver was used - vesa or modesetting… Sorry.
I just installed xf86-video-intel, libva, vaapi, intel-gpu-tools…

And add to 50-device.conf:

 Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "TearFree"    "true"

I did not specify AccelMethod, therefore I get SNA after reboot.
But all Ok!
System works 50 hours without freezing (I hold my fingers…)
SMPlayer, Chrome, Kodi with VDPAU, VAAPI…
glxgears 2000

After a clean install of 42.3, I experienced a similar set of problems with Intel HD graphics. No “tear” was seen, in fact the only problem was openGL. I found the aboe post, and discovered that xf86-video-intel, libva, vaapi, intel-gpu-tools were NOT installed (in spite of the clean install!).

After install of xf86-video-intel (which brought in the rest), the openGL-related problems were resolved.

BTW: the ugly symptom of the problem was that in LibreOffice Calc, the selected cell(s) were NOT highlighted or bordered. Annoying enough to peel the onion, and find a missing driver!.

I have the same problem with periodic irrecoverable freezes in 42.3 with Intel graphics and Plasma 5. I tried the solution mentioned in this thread (adding the uxa option as described in /etc/X11/xorg.conf.d) but that resulted in X failing to start and just left with a terminal log-on screen. Since I had a terminal, I could rename the 20-intel.conf file to something else - when I did, the boot immediately restarted and the GUI logon appeared. So it seems the boot didn’t fail, it just stalled at that file.

Not sure now what to do next, but it does seem that for some reason with my system I can’t use that workaround. Any suggestions please?

That only works if xf86-video-intel is installed and supports your GPU.
Nowadays it isn’t installed by default in favor of using the generic “modesetting” driver (exactly because of the many problems with the intel driver).

And if it is not installed, explicitly setting it in 20-intel.conf or similar will make X fail to start.
But if it isn’t installed, switching its acceleration method from “sna” to “uxa” is pointless anyway. :wink:

You can try to install xf86-video-intel though, maybe it would work better with your chip (try without that 20-intel.conf first, if you still have problem try with it too).

Another thing that should be tried (in addition) is uninstalling drm-kmp-default (or installing it if it isn’t installed for some reason), that contains updated modules from kernel 4.9 that may work better or worse depending on the GPU in use.

Ah, wish I’d known that, I have an AMD processor and video card. (AMD Ryzen 5 1400, AMD Radeon RX 580.
I already uninstalled drm-kmp-default because of an earlier, more severe graphics problem. Other than that, it’s whatever the Suse installer opted for, new install.

So where does that leave me?

Well, the title does say “Intel Graphics”, and the name 20-intel.conf probably should have given a hint as well…

In that case the mentioned acceleration method change doesn’t apply to you at all, as both SNA and UXA acceleration are specific to intel.

I already uninstalled drm-kmp-default because of an earlier, more severe graphics problem.

There have been updates though, so you may try to install the latest version again.

So where does that leave me?

Well, I have no idea what drivers support this card, nor whether your problems would really be related to the GPU. (Ryzen is quite new and has its own share of problems anyway AFAIK)

You could e.g. try the latest kernel (from Kernel:stable repo), or upgrade to Leap 15.0 (which is to be released in less than 3 weeks but should be basically finished already anyway). Maybe the amdgpu pro driver would be worth a try as well.

In any case, better open a new thread about your problem for further help, this one is explicitly about intel graphics.

Touché. >:( I did a search for problem and landed at the tail end of a thread. Must pay more attention.

Thanks once again Wolfi. In view of what you say is upcoming, I can wait until the new major version is released (the problem only shows after a day or so of running). I expect that’s rolling out a later kernel.