Plasma 5 Install Issues

I installed Plasma 5 using the instruction from this thread: and I get the error message: Could not start kdeinit5. Check your installation.

I verified I am using the correct repos from wolfie: (rpm -qi plasma5-session plasma5-workspace). Any suggestions are appreciated. Thanks!

By the way, I ran Ran /opt/kf5/bin/startkf5 In ICEWM and got:

/opt/kf5/bin/startkf5startkde: Startingup...
usr/bin/kdeinit5;symbollookup error: /usr/lib/lib64/libKF5Crash.so5: undefined symbol:_ZN6QDebugD1Ev
startkde: could notstart kdeinit5.  Check your installation.

Here is my repo list:

1 | Bumblebee                     | Bumblebee                          | Yes     | Yes     |   99     | rpm-md |                             |         2 | KDE:Frameworks5               | KDE:Frameworks5                    | Yes     | Yes     |   99     | rpm-md |                            |        
 3 | KDE_Framework                 | KDE Framework                      | Yes     | Yes     |   99     | rpm-md |                           |        
 4 | Packman Repository            | Packman Repository                 | Yes     | Yes     |   99     | rpm-md |                                            |        
 5 | QT5                           | QT5                                | Yes     | Yes     |   99     | rpm-md |                                   |        
 6 | Wolfie                        | Wolfie                             | Yes     | Yes     |   95     | rpm-md | |        
 7 | | Main Repository (NON-OSS)          | Yes     | Yes     |   99     | yast2  |                                        |        
 8 |     | Main Repository (OSS)              | Yes     | Yes     |   99     | yast2  |                                            |        
 9 |  | Main Update Repository             | Yes     | Yes     |   99     | rpm-md |                                                           |        
10 | google-chrome                 | google-chrome                      | Yes     | Yes     |   99     | rpm-md |                                                 |        
11 | libdvdcss repository          | libdvdcss repository               | Yes     | Yes     |   99     | rpm-md |                                                                |        
12 | openSUSE-13.2-0               | openSUSE-13.2-0                    | Yes     | No      |   99     | yast2  | cd:///?devices=/dev/disk/by-id/ata-PLDS_DVD+_-RW_DH-16AES_FY13D7363948J53EVA00                      |        
13 | packman                       | packman                            | Yes     | Yes     |   99     | rpm-md |                                                         |        
14 | packman-essentials            | packman-essentials                 | Yes     | Yes     |   99     | rpm-md |                                              |        
15 | packman-multimedia            | packman-multimedia                 | Yes     | Yes     |   99     | rpm-md |                                              |        
16 | repo-debug                    | openSUSE-13.2-Debug                | No      | Yes     |   99     | NONE   |                                      |        
17 | repo-debug-update             | openSUSE-13.2-Update-Debug         | No      | Yes     |   99     | NONE   |                                                     |        
18 | repo-debug-update-non-oss     | openSUSE-13.2-Update-Debug-Non-Oss | No      | Yes     |   99     | NONE   |                                             |        
19 | repo-source                   | openSUSE-13.2-Source               | No      | Yes     |   99     | NONE   |                                     |        

20 | repo-update-non-oss           | openSUSE-13.2-Update-Non-Oss       | Yes     | Yes     |   99     | rpm-md |      

Reminds me of a different thread actually… :wink:

Your libKF5Crash5 doesn’t match the installed libQt5.

Make sure libKF5Crash5 comes from KDE:Frameworks5 and all libQt5 packages come from KDE:Qt5 i.e. are version 5.4.0.

Maybe use YaST’s “Versions” tab for that, and/or click on “Switch all system packages to the versions from this repo” above the package list in the repository view for all 3 repos (KDE:Qt5, KDE:Frameworks5, Wolfie). But if you do that for the KDE:Frameworks5 repo, it will want to remove KDE4. Do the same for my repo afterwards to rectify this, KDE4 should stay installed then.

Or run this to make sure everything’s from the extra repos: (13.2 already comes with older versions of everything)

sudo zypper dup --from 2 --from 5 --from 6

Btw, you have KDE:Frameworks5 twice (#2 and #3), you could remove one instance. But do that only after you ran the “zypper dup” above, or you’ll have to adapt the numbers…
And you could also remove the packman-essentials and packman-multimedia repos. You have the full Packman repo too, which contains everything that’s in those two repos anyway. And you have the full Packman repo even twice as well (#4 and #13). Here you could remove one instance as well.

Thank you. Works great!

I am checking it out now. I do notice systemsettings crashing quite often. It seems sharp looking when it isn’t crashing. Still investigating…

Hm, I don’t see such crashes here…

Is it crashing in certain modules only? When you do certain things maybe?

Could you post a backtrace maybe?

But then, to be honest, I’m not really motivated to hunt down and probably fix every single bug in Plasma5 there might be.
You should better report them upstream if you find some, please. :wink:

If it’s a problem specific to my packages, I’ll try to investigate of course though… (but that’s also difficult if I cannot reproduce it)

The issues I have from my end are with System Settings. Change anything and there is an error message and the my computer freezes. Perhaps I have not reported something correctly or made a mistake along the way. Changing Themes, for example causes a freeze. Give me a way to do a backtrace and I would be glad to provide you with it.

Does the Nvidia driver have anything to do with it? I am more comfortable with ATI drivers (with slow updates), but my new computer comes with an Nvidia card. Linux is not a friend to Linux, as far as I can tell…

always best to give the error message other wise people must guess.

Well, a freeze is not the same as a crash.
In the case of a crash, you should get a crash reporter window which would allow you to inspect the backtrace.
In this case you probably could run it in gdb, then interrupt it when it is frozen, and run “bt” to see where it hangs. But you should better install the appropriate -debuginfo packages first.

But, as gogalthorp wrote, please post the exact error message.
I haven’t ever seen anything like this here, but maybe the message will give a clue.
Also, try to run systemsettings5 in a Konsole and have a look (or post) the last lines of output when it freezes.

Does the Nvidia driver have anything to do with it? I am more comfortable with ATI drivers (with slow updates), but my new computer comes with an Nvidia card. Linux is not a friend to Linux, as far as I can tell…

Well, this doesn’t really sound like it would be related to the video driver. But still, try to disable desktop effects or switch to XRender to see if it helps. Also try "recovery mode).
Video driver issues can cause the most interesting problems… :wink:

I had basically these same issues. I can get plasma working but plasma5 freezes my machine.

Please be more specific.

And the OP’s problem was that systemsettings5 froze after changing settings, not that “plasma5 freezes the machine”, IIUIC. Not really the same I would say.

Anyway, try booting to recovery mode and/or switch the Qt graphics system to XRender in Systemsettings5->Compositor.
Does that help?

[QUOTE=wolfi323;2688754]Please be more specific.

I quess I was just jumping in incase somehad some questions for me.

I noticed a problem that under xfce desktop manager their was two versions of the plasma and plasma5 systemsettings, one would work one would crash. I think these were the same ones that appear under kde plasma and kde plasma5

Plasmashell under plasma5 would crash every time I logged in. Not so in plasma.

My experience with plasma5 was plasmashell crashing each login and you’d get the crash dialouge box.

I had tried recovery mode but no joy.

Now that I’m running stable again I think I’ll watch from the cheap seats foe awhile.


Yes. “systemsettings” is KDE4’s configuration program (should be shown as “KDE4 Systemsettings” in XFCE I think), “systemsettings5” is Plasma 5’s.

So it appears that basically all KF5/Qt5 applications crash, right? Could affect YaST as well btw.
Try running systemsettings5 in a terminal window (in XFCE, KDE4, or whatever) and post the output.

Plasmashell under plasma5 would crash every time I logged in. Not so in plasma.

So KDE4 works, but Plasma5 crashes?
Well, they are completely independent. The one is based on Qt4 and kdelibs4, the other uses Qt5 and KDE Frameworks5. They even use different config files.
That fact doesn’t give any clue at all to the cause of the problem though.
That’s just like saying GNOME crashes while XFCE works fine.

I had tried recovery mode but no joy.

Well, if every KF5/Qt5 application is crashing, it’s probably not graphics driver related.

That’s why I wanted to know further details.
The information you gave now is something completely different than “plasma5 freezes my machine”, isn’t it?