Plasma 5 frustrations runnenth over

What config directory or file(s) do I need to wipe with Plasma 5 in order to get a stock/default desktop settings and start over.

I don’t have time to track down all the individual problems that have arisen since drawing in the 5.4 updates about a month or so ago … its funny because prior to that Plasma 5 was really stable, so I never understood the widespread complaints one can find against it … Now, my long-standing run with a desktop that is conducive to my workflow has hit a real rough patch. Say it ain’t over baby, say it ain’t so. Come back to me KDE rotfl!..

In brief, here are some of the highly annoying things I’m now encountering and which are really affecting my workflow

  • I leave dolphin open all the time, with multiple tabs (some of which are splits (i.e. F3)) for quick/easy access to the varying stuff I need to work with on a daily basis. Now on boot up into KDE, I frequently find that it (dolphin) is not open, requiring it to be reopened and everything (my tabs and splits) reset again… sometimes on shutting down the system or logging out of KDE I get messages that I have multiple tabs open and asks if I’m sure I want to quit … if I say quit (because you can’t log out otherwise … it just hangs forever), it sometimes means that dolphin was exited and on other occasions it is still open as I desire.
  • the application dashboard frequently opens on the wrong monitor (monitor number 2)
  • applications frequently open on the wrong monitor (monitor number 2)
  • firefox opens in a application window the size of about 320x240 … requiring manual resizing
  • the logout/shutdown window (boxes) opens on the wrong monitor (monitor number 4)
  • in logging into KDE, there is now usually about a 40 second delay before the desktop becomes usable
  • … others that I can’t think of right now

You can rename the directories .config, .kde4 and .kde. These should be enough to reset Kde configuration.
But there are some real bugs that won’t be fixed by reseting the configuration files.
For instance, I can confirm the dolphin bug on not reopening the tabs :frowning:

Confirmed. Some complained of a minute delay. I haven’t timed it, but it’s significant and irritating. Desktop appears quickly but totally unfurnished. After long delay all furniture appears instantly and usable. Factory ML is aware and IIRC bug report mentioned. Recent snapshot(s) didn’t fix it, and a previous one caused it.

Thanks. Yeah, the taskbar delay problem is indeed recent. I timed it a couple of times and it was ~40s for me on those occasions (and generally seems to be the case for me), but there have been a few times in which case where the delay was significantly longer, or, rarer, only about 20s.

Thanks … the dolphin bug is the most annoying for me … (its completely disruptive to a smooth work experience)

Hi! I have the same problem. I tried to rename the folders mentioned, but the problem still is there! The past week I didn’t had this problem!rotfl!
I hope that with the upgrade to plasma 5.4.3 this problem will be solved;)

Just to add some info:

Sometimes it restores Dolphin session on log in. But that does not happen very often.

Another issue I found on some machines is that sometimes the knetwork manager icon (or widget, I’m not sure) does not show in the task bar, but it still works.

What problem do you mean?
That dolphin (and other KF5 applications) are often not restored on login by the session management?

No, that’s definitely not fixed in Plasma 5.4.3, I’m afraid.

Actually it is not a problem with Plasma5’s session management, but rather with Qt5. Qt5 unexpectedly quits the application right after it has stored the state, so the session management doesn’t see it as running any more (although if you are lucky it is still running at that point) and doesn’t save it for being restored at login.
Apparently they are currently working on a fix though, at least somebody analyzed the problem and explained what happens here yesterday:
https://bugs.kde.org/show_bug.cgi?id=354724

As a workaround, you could switch to “Start with a previously saved session” in the session management settings, and then choose “Save Session” in “Session/Powermanagement” in the application menu before you logout. A manually saved session should properly be restored on login.

For making dolphin not ask for confirmation on logout when multiple tabs are open, just activate the “Do not ask again” checkbox or change that in Dolphin’s settings.

Another known problem, currently being investigated (seems to be a bug in Qt5 though):
https://bugs.kde.org/show_bug.cgi?id=352580
https://bugs.kde.org/show_bug.cgi?id=352055

You should be able to make it appear by opening the “System Tray Settings” and disabling the “Miscellaneous” category, pressing “Apply” and enabling it again. Or disable/enable the network manager icon itself there.

To most of the other points mentioned here I cannot say much because I only have one monitor.

The Firefox issue I do not see here. Maybe some setting in Firefox?
You should be able to create a window rule to force a suitable size though (right-click on the window title bar and select “More Actions”->“Special Settings for this Window”).

in logging into KDE, there is now usually about a 40 second delay before the desktop becomes usable

I have recently experienced this same behavior so I did some digging in various KDE forums. It seems to be some issue relating to bluetooth.
Since I do not need bluetooth capabilities on my desktop, all I did was remove the following packages to make this delay issue go away…
BLUEZ, BLUEDEVIL, and GNOME-BLUETOOTH

Hope this helps…:wink:

I am currently running Tumbleweed openSUSE 20151118 with KDE 5.4.2

On Tue, 24 Nov 2015 21:56:02 GMT
wolfi323 <wolfi323@no-mx.forums.microfocus.com> wrote:

> For making dolphin not ask for confirmation on logout when multiple
> tabs are open, just activate the “Do not ask again” checkbox or
> change that in Dolphin’s settings.

Unfortunately, that will mean that the warning isn’t there when you
need it, like when you’ve hit the “x” by accident.

I reported this bug a few weeks ago:
https://bugs.kde.org/show_bug.cgi?id=354800


Graham P Davis, Bracknell, Berks.
openSUSE 13.2 (64-bit); KDE 4.14.9; AMD Phenom II X2 550 Processor;
Kernel: 4.3.0; Video: nVidia GeForce 210 (Driver: nouveau);
Sound: ATI SBx00 Azalia (Intel HDA)

Yes.

I reported this bug a few weeks ago:
https://bugs.kde.org/show_bug.cgi?id=354800

Ok, but the title of that bug report is about dolphin not restoring on login.
Those two “problems” are totally independent of each other.

A bug report about this particular behaviour is here though:
https://bugs.kde.org/show_bug.cgi?id=353548
The dolphin maintainer seems to have the opinion that this is actually the correct way.

On Thu, 26 Nov 2015 13:06:03 GMT
wolfi323 <wolfi323@no-mx.forums.microfocus.com> wrote:

>
> Cloddy;2739662 Wrote:
> > On Tue, 24 Nov 2015 21:56:02 GMT
> > wolfi323 <wolfi323@no-mx.forums.microfocus.com> wrote:
> >
> > > For making dolphin not ask for confirmation on logout when
> > > multiple tabs are open, just activate the “Do not ask again”
> > > checkbox or change that in Dolphin’s settings.
> >
> > Unfortunately, that will mean that the warning isn’t there when you
> > need it, like when you’ve hit the “x” by accident.
> Yes.
>
> >
> > I reported this bug a few weeks ago:
> > https://bugs.kde.org/show_bug.cgi?id=354800
> >
> Ok, but the title of that bug report is about dolphin not restoring on
> login.
> Those two “problems” are totally independent of each other.

No, they are the same problem. Dolphin will not restore on login
because of the prompt insisting that all tabs be closed. I admit the
title gives the wrong impression and perhaps should have read “windows
WITH tabs” instead of “windows and tabs”.

>
> A bug report about this particular behaviour is here though:
> https://bugs.kde.org/show_bug.cgi?id=353548
> The dolphin maintainer seems to have the opinion that this is actually
> the correct way.
>

Yes, but as I’ve now commented in the report, I believe him to be
mistaken.

Thanks for pointing out that bug report for me.


Graham P Davis, Bracknell, Berks.
openSUSE 13.2 (64-bit); KDE 4.14.9; AMD Phenom II X2 550 Processor;
Kernel: 4.3.0; Video: nVidia GeForce 210 (Driver: nouveau);
Sound: ATI SBx00 Azalia (Intel HDA)

No, that’s not true.

Dolphin does correctly save its state (including all tabs, split views and displayed folders) despite of this warning dialog.
If dolphin is restored on login by the session management, it will also restore the tabs, split view, and displayed folders.

The problem is that often (or depending on your system sometimes or even always) dolphin (or any other Qt5 application) is not restored.
If you start it manually afterwards, it will not restore the saved state, as this is only for session management (it cannot even know which state file it should load).

If you rely on session management, you could set “Start with a manually saved session”, and save the session manually before logging out as workaround (until this is fixed), as I already told you.
You will see then that dolphin is indeed correctly restored on login.

On Sat, 28 Nov 2015 23:36:01 GMT
wolfi323 <wolfi323@no-mx.forums.microfocus.com> wrote:

>
> Cloddy;2740144 Wrote:
> > No, they are the same problem. Dolphin will not restore on login
> > because of the prompt insisting that all tabs be closed.
> No, that’s not true.

Oh yes it is.

Well, pantomime season is coming up. :wink:

> Dolphin does correctly save its state (including all tabs, split views
> and displayed folders) despite of this warning dialog.
> If dolphin is restored on login by the session management, it will
> also restore the tabs, split view, and displayed folders.

But as you have to close down all tabs before you can logout, there are
no tabs to restore! At least, I haven’t been able to find a way of
getting it to work. Perhaps you can suggest a way?

“Cancel” is a really great option; all I can do after selecting that is
to hit the reset button in order to end the session - everything else is
locked up.

> The problem is that often (or depending on your system sometimes or
> even always) dolphin (or any other Qt5 application) is not restored.
> If you start it manually afterwards, it will not restore the saved
> state, as this is only for session management (it cannot even know
> which state file it should load).
>
> If you rely on session management, you could set “Start with a
> manually saved session”, and save the session manually before logging
> out as workaround (until this is fixed), as I already told you.
> You will see then that dolphin is indeed correctly restored on login.

I know all that but it’s not what I want and is not how I’ve been
working with KDE for well over a decade. I know I will sometimes forget
to save the session before logging out; it happened the other day when
trying to get my Leap session back into a semi-usable state (and failing
miserably).

Perhaps, if what has been broken in KDE cannot - or will not? - be
fixed, the logout prompt should issue a reminder before it takes any
other action saying “do you want to save your session?”


Graham P Davis, Bracknell, Berks.
openSUSE 13.2 (64-bit); KDE 4.14.9; AMD Phenom II X2 550 Processor;
Kernel: 4.3.0; Video: nVidia GeForce 210 (Driver: nouveau);
Sound: ATI SBx00 Azalia (Intel HDA)

No, it isn’t. I already explained why.

> Dolphin does correctly save its state (including all tabs, split views
> and displayed folders) despite of this warning dialog.
> If dolphin is restored on login by the session management, it will
> also restore the tabs, split view, and displayed folders.

But as you have to close down all tabs before you can logout, there are
no tabs to restore!

Wrong.
The tabs are saved before dolphin is closed down and that confirmation dialog appears.

Try this, maybe you’ll believe me then:

  • remove the folder ~/.config/session/ (that’s where applications store their state on logout), to remove all the left-over application states from previous logouts
  • logout, with dolphin (with multiple tabs) being open, and choose “Quit” in the confirmation dialog
  • login again
  • if you are lucky dolphin will be restored with all tabs, if not:
    have a look into the folder ~/.config/session/, there will be a file named like dolphin_10c26d6967000144863321600000078510013_1448633342_982752
    Start dolphin like this:
dolphin --session 10c26d6967000144863321600000078510013_1448633342_982752

(the numbers are the parts of the file name after “dolphin_”)
That’s how the session management would start dolphin when it is properly registered as still running on logout

Dolphin will start with all tabs from the previous session then.

“Cancel” is a really great option; all I can do after selecting that is
to hit the reset button in order to end the session - everything else is
locked up.

If krunner is still there, you can restart plasmashell manually.

But yes, that’s a bug (or unfortunate behaviour) too:
https://bugs.kde.org/show_bug.cgi?id=349805

> The problem is that often (or depending on your system sometimes or
> even always) dolphin (or any other Qt5 application) is not restored.
> If you start it manually afterwards, it will not restore the saved
> state, as this is only for session management (it cannot even know
> which state file it should load).
>
> If you rely on session management, you could set “Start with a
> manually saved session”, and save the session manually before logging
> out as workaround (until this is fixed), as I already told you.
> You will see then that dolphin is indeed correctly restored on login.

I know all that but it’s not what I want and is not how I’ve been
working with KDE for well over a decade. I know I will sometimes forget
to save the session before logging out; it happened the other day when
trying to get my Leap session back into a semi-usable state (and failing
miserably).

But it would be a workaround until the Qt5 bug is fixed (or workarounded in Plasma5’s session management).

Perhaps, if what has been broken in KDE cannot - or will not? - be
fixed, the logout prompt should issue a reminder before it takes any
other action saying “do you want to save your session?”

Nothing is to be fixed in KDE. The same would happen in KDE4 e.g. or any other desktop that supports session management.
Again, it’s a bug (or wrong behaviour) in Qt5. The applications are quit right after the state is saved and so are not seen as running any more by the session management.

Non-Qt5 applications that support session management (e.g. KDE3, KDE4 and GTK apps) will be restored properly and reliably, even by Plasma5.
Another indication that there’s no problem with Plasma5’s session management.

PS: given that the actual problem has been thoroughly analyzed meanwhile, and it’s known now what exactly goes wrong, I’m sure there will be a fix available soon.
See also here for a discussion:
http://marc.info/?l=kde-core-devel&m=144832700109449&w=1

BTW, the unusable desktop/screwy taskbar for ~40s (or so) issue got resolved with the last batch of updates (5.4.3 IIRC) that got drawn in a day or so ago.

A few more that I remember off the top of my head:

  • lost event notifications sounds (such as emptying trash, etc) … have seen others report the same
  • Login box (sddm) appears on all four monitors, yet typing in password is inputed into the login box on monitor 2 … manually clicking in the login box on monitor 1 (or any other for that matter) changes the focus of where the password is entered
  • emptying the trash in dolphin works the first time (files/directories that you’re nuking disappear). But if you I then delete more files, while they appear in the trash folder, selecting empty trash (right click > empty trash … either on the trash icon or from within a tab browsing the trash) does not appear to remove the files. Though if you log out and then back in, it appears that they were deleted. … Interestingly, after this has occurred, I’ve run into cases where upon attempting to delete another file becomes impossible (IIRC, dolphin is simply frozen up)
  • Thunderbird is now behaving like how Firefox is for me (opens in small windows … compose messages, read messages, … everything!) … the small windows don’t reliably open in the same position either. … This unwelcome behaviour occurred out of the blue (just like it originally did when Firefox started messing up)

That’s probably related to the gstreamer problems many people have at the moment, not to Plasma 5 nor Leap 42.1.

Deleting the gstreamer cache might help, and/or doing a full switch to Packman to avoid incompatible packages.

emptying the trash in dolphin works the first time (files/directories that you’re nuking disappear). But if you I then delete more files, while they appear in the trash folder, selecting empty trash (right click > empty trash … either on the trash icon or from within a tab browsing the trash) does not appear to remove the files. Though if you log out and then back in, it appears that they were deleted. … Interestingly, after this has occurred, I’ve run into cases where upon attempting to delete another file becomes impossible (IIRC, dolphin is simply frozen up)

Hm, haven’t noticed something like that yet.
Try to delete the Trash folder (~/.local/share/Trash/) completely, maybe the info file is broken. I have heard from people having problems with that in KDE4 already.

Thunderbird is now behaving like how Firefox is for me

Well, this wouldn’t really surprise me.
After all, Firefox and Thunderbird do use the same toolkit and the same KDE integration.

As I wrote already, you might be able to workaround it by creating window rules.

PS, @Cloddy (mainly, but not exclusively):
I patched Qt5 to not close the application windows after saving the state as an experiment/proof of concept.
Packages are available here:
http://download.opensuse.org/repositories/home:/wolfi323:/branches:/KDE:/Qt5/
(I think you only need libQt5Core5, if that doesn’t have any effect do a full switch though)

This should fix all your session management problems AFAICT from my tests (including the desktop disappearing if you/an application abort the logout).
Be aware though, that this will remove all confirmation dialogs from Qt5/KF5 applications on logout too (but not if you close the apps manually).
You might prefer that for dolphin, but also kwrite e.g. won’t ask any more if there are unsaved changes.

An interesting detail I noticed while testing this: gedit doesn’t ask about unsaved changes on logout either, the KDE4 based kwrite does though.

Yes, it brought back event sound notifications … though it may be working only intermittently … (have to pay more attention and investigate further)

Hm, haven’t noticed something like that yet.
Try to delete the Trash folder (~/.local/share/Trash/) completely, maybe the info file is broken. I have heard from people having problems with that in KDE4 already.
I had a similar problem back in KDE 4.1-3 days IIRC … I will look to see if there is any connection here again

Well, this wouldn’t really surprise me.
After all, Firefox and Thunderbird do use the same toolkit and the same KDE integration.
I’ve isolated something with Firefox that leads to correct behaviour occurring . [Though, taking a similar step with Thunderbird was unsuccessful, so don’t know what is going on with its case]. On the surface, the Firefox issue is likely not related to Plasma

I’ve described it in a new thead here: https://forums.opensuse.org/showthread.php/511774-Firefox-opening-in-very-small-window-and-forgets-on-which-monitor-it-last-resided?p=2742487#post2742487

As I wrote already, you might be able to workaround it by creating window rules.
There would be too many of them (i.e. PITA)