plasma 5 freezing / nouveau vs official nvidia drivers

There seems to be an issue with the nouveau drivers and Plasma 5.
The desktop environment will become frozen within 10 minutes of use;
yet, the mouse cursor is still movable.

I installed Xfce and noticed that it does not suffer from the freezing.
It does however suffer from tearing.
I tried various things to solve that,
including installing the official nvidia drivers.
The problem was not solved;
however, when I switched back to Plasma 5,
I noticed that the freezing is gone,
and there is no tearing. :-]

My steps for installing the driver:

  • downloaded the driver from the nvidia website
  • used the sh command on the downloaded driver
  • quit the installation after it talks about blacklisting nouveau
  • ran the mkinitrd command
  • rebooted
  • sudo zypper install gcc
  • sudo zypper install make
  • su -c “zypper in -t pattern devel_kernel”
  • used the sh command on the downloaded driver

I see now this is mostly the same as

Hopefully someone can figure out why the freezing happens;
“Joe Average” is going to be discouraged by this bug,
which is unfortunate.

I’m liking openSUSE & Plasma!

For your post info to be helpful to others, they need to know your GPU hardware.

The following should display your nvidia hardware info



this is nothing new nouveau never worked with plasma 5, this is a known bug that has been passed around between kde and noveau at freedesktop

if you don’t mind recompiling there is a patch in freedesktop’s git

or just use nvidia’s driver, one of the reason I prefer LEAP is the stable driver you can get from nvidia

@tsu2: GTX 750

@I_A: Thanks.

It seems like this was fixed on tumbleweed. :cool:

More specifically… the freezing with plasma / nouveau has been eliminated.

Thanks heroes! :cool: