Plasma 5 default applications

After upgrading to Plasma5 I seem to have quite a few problems with it - however no answers from the forum here so far. This problem I have reported on my Tumbleweed computer as well but it was not solved at the time (approx half a year ago). It seems if you have LXDE (or PCMan FM File Manager) installed (as I have on these older machines) this will be the default file manager in Plasma5 and you cannot change it. You can go to System Settings -> Default Applications -> File Manager and set it to Dolphin and click Apply. The save window comes up but if you open the File Manager after plugging in a USB stick it is PCMan FM again and if you go into this window (System Settings -> Default Applications -> File Manager) later it is back to PCMan FM as well. Has anyone else experienced this and a bug report is needed or is it just in my Plasma5 install?
I really would appreciate some comments from some of you knowledgeable people in this forum.

No answers?
IIRC, you did get quite a few answers back then.

That nothing helped for you is a different story though…

Has anyone else experienced this and a bug report is needed or is it just in my Plasma5 install?

I still haven’t experienced that, and I cannot reproduce it either.

But then, I don’t have PCManFM installed.

It seems to be something specific this is doing, i.e. it seems to overwrite Plasma’s default file associations.
I don’t see anything in the pcmanfm package though that might cause this.

Just one thought: check in “Configure Desktop”->“Applications”->“Filetype Associations” what application is at the top of the list for “inode/directory”. Set it to dolphin there, and see whether it sticks then.

And I think you already did try a fresh user account, right?
It might be caused by some stray file in ~/.local/share/ or ~/.config/ …

Yes, wolfi323, when I had the problem with Tumbleweed I received quite a few answers but nothing helped - nevertheless I appreciate that you (and others) did their best to help me. But I wrote when I upgraded this computer I didn’t receive any answers and I referred to the post “Plasma5 needs copy command twice - wifi is dropping out” which I started 3 days ago and where I received no answers.
But on both computers I have LXDE installed as these are old 586 computers and if (when) the resources are too much for KDE I use the LXDE desktop. That is why PCManFM is installed and I would have thought this is a common enough problem and someone else might have the same problem.
FIrstly - yes it is the same problem with other accounts. And I looked through all kind of files in ~/.local/share/ and ~/.config/ hoping to find somewhere where I could set the file manager manually to Dolphin in a config file but I didn’t find anything. If I would find the config file for this application the problem might be solved. I even tried to open systemsettings as root from command line and change the file association there with the same result.

“Configure Desktop”->“Applications”->“Filetype Associations” what application is at the top of the list for “inode/directory”

Now where do I find the “Configure Desktop”? I couldn’t find it in systemsettings or systemsettings5 - I set the file association for file manager to Dolphin in both of them.

There is no particular config file to set the file manager.

And yes, the file associations are stored in ~/.local/share/applications/ and ~/.config/.
In particular ~/.local/share/applications/mimeapps.list and ~/.local/share/applications/defaults.list, but there are/can be others.
But IIRC we’ve already been through this.

I even tried to open systemsettings as root from command line and change the file association there with the same result.

Running it as root would only change root’s file associations of course. Not the system-wide ones if you may expect that…

Now where do I find the “Configure Desktop”? I couldn’t find it in systemsettings or systemsettings5 - I set the file association for file manager to Dolphin in both of them.

“Configure Desktop” is systemsettings/systemsettings5. But it’s displayed as “Configure Desktop” in KDE’s application menu.
So you changed the association in “File Associations”? (not in “Default Applications”)
And you don’t have to do that in both. There is only one set of file associations. Both change the same, and most other desktops should use/change the same as well.

Btw, have you ever tried to use LXDE’s settings to change the default file manager?

And since there was a similar, but general problem in Tumbleweed recently (see [opensuse-factory] Why did GwenView become the default file manager on my computer? - openSUSE Factory - openSUSE Mailing Lists), I have another idea:
try to rename /usr/share/applications/defaults.list to something else.
Maybe PCManFM is specified as default file manager there (system-wide) and overrides the desktop specific settings.
Although in mine there’s only Nautilus listed in there for directories, still dolphin is the default file manager in both KDE4 and Plasma5.

If you have a /usr/share/applications/mimeapps.list, try to move that as well. I don’t have that on my 13.2 system at all though.

Hi wolfi323,
Yes, I was typing without looking at the menu - it was default applications not file associations. I tried setting Dolphin to the top with file associations - inode - directory. After apply the save dialog box was there but at the end it was back to PCManFM at the top and selected as default file manager. Only after logging out and logging into LXDE and doing the same there was Dolphin at the top and selected. So that worked but strangely only after changing it in LXDE first. Anyway I will change it at my Tumbleweed computer the same way - thank you. Nevertheless it is strange that I had to do it in LXDE first.
BTW I have no /usr/share/applications/mimeapps.list - only /usr/share/applications/mimeinfo.cache file.
One item solved - thanks again
Uli

It probably might be interesting then what exact file LXDE wrote.
As indicated, KDE’s systemsettings(5) write ~/.local/share/applications/mimeapps.list, but KDE does respect other files as well (for compatibility reasons and per the specs)

Apparently LXDE creates a different file, that takes precedence.

BTW I have no /usr/share/applications/mimeapps.list - only /usr/share/applications/mimeinfo.cache file.

Yes, as I wrote I don’t have it here on 13.2 either. It was a recent change in Tumbleweed that this file is created by the system instead of default.list (with wrong content originally, i.e. GNOME’s file associations that should rather be in gnome-mimeapps.list, which caused problems for Plasma5).

But if you would have had it for some reasons, it would have explained your problem. It is respected/used by Plasma5 if it is there.

Hi wolfi323
I found that on my Tumbleweed computer I could not reset Dolphin as default file manager even in LXDE - it always went back to PFManFM (by moving Dolphin to the top position as described before).

In that quote you were talking about /usr/share/applications/mimeapps.list and that gave me the idea - there is the mimeapps.list in ~/.config. I had a look and is was:

uli@linux-dfsr:~/.config> cat mimeapps.list 
[Default Applications]
inode/directory=pcmanfm.desktop

[Added Associations]
uli@linux-dfsr:~/.config>

After changing that to:

uli@linux-dfsr:~/.config> cat mimeapps.list 
[Default Applications]
inode/directory=dolphin.desktop

[Added Associations]
uli@linux-dfsr:~/.config>

it seems to be OK now.
CHeers
Uli

Ah yes.

Actually ~/.local/share/applications/ should override /usr/share/applications/.
But the current specifications say that ~/.config/mimeapps.list (or /etc/xdg/mimeapps.list for the system defaults) should be used for the file associations.

KDE still writes the “old” ~/.local/share/applications/mimeapps.list as mentioned, but respects more than that as it follows the specs. And ~/.config/mimeapps.list seems to have precedence.

In case you’re interested, the latest specification is here, and includes a list of all files that should be respected for filetype associations:
https://specifications.freedesktop.org/mime-apps-spec/mime-apps-spec-latest.html($XDG_CONFIG_HOME is ~/.config/, $XDG_CONFIG_DIRS is /etc/xdg/ on openSUSE, similar for $XDG_DATA_(HOME|DIRS) which refers to …/share/)