Plasma 5: Cannot login to KDE since update

Hello,

i’m here on OS 13.2 and use the 13.2 repositories of Qt5 and KDE Framework 5.

Everything was ok since one of the last updates of one of this two repos (i think Friday two weeks ago).
Since then everytime i put in my username and password, the progress bar gets stuck at 2/3 and it doesn’t reach the KDE desktop.
However i can login to iceWM and using it instead now, but i would like to switch back to Plasma 5 again.

Any help would be appreciated. Thank you.

Use icewm to progresss updates and apply switches on those repos
I’m not sure you even need the qt5 repo

Thank you for your answer. I will go on and progress updates.
i just hoped to be not the only one with this nuisance and started to get sceptical as the subsequent updates didn’t solve this problem.

So you are just experimenting ? Or you plan to use this as daily?

JMO: But if 5 were ready, I’d be using it. I’m not.

Well it began as experiment, but since the first tryout (i started with 13.1), working with Plasma 5 was so smooth that i use it everyday now. That’s why i call this problem a nuisance.

Sure Plasma 5 is in early stage, but all i need is already there, so there’s no reason for me the stick with KDE 4. Give it a try! (…and while you’re at it please help me with this problem :wink: …)

zypper lr -d
zypper ve

Results of both


utgard@linux-k32u:~> zypper lr -d
#  | Alias                         | Name                               | Aktiviert | Aktualisieren | Priorität | Typ    | URI                                                                        | Dienst
---+-------------------------------+------------------------------------+-----------+---------------+-----------+--------+----------------------------------------------------------------------------+-------
 1 | Kernel                        | Kernel                             | Ja        | Ja            |   99      | rpm-md | http://download.opensuse.org/repositories/Kernel:/stable/standard/         |       
 2 | OBS_Frameworks_5_Plasma_5     | OBS Frameworks 5 Plasma 5          | Ja        | Ja            |   99      | rpm-md | http://download.opensuse.org/repositories/KDE:/Frameworks5/openSUSE_13.2/  |       
 3 | OBS_LibreOffice               | OBS LibreOffice                    | Ja        | Ja            |   99      | rpm-md | http://download.opensuse.org/repositories/LibreOffice:/4.3/openSUSE_13.2   |       
 4 | OBS_Qt5                       | OBS Qt5                            | Ja        | Ja            |   99      | rpm-md | http://download.opensuse.org/repositories/KDE:/Qt5/openSUSE_13.2/          |       
 5 | download.opensuse.org-mozilla | openSUSE BuildService - Mozilla    | Ja        | Ja            |   99      | rpm-md | http://download.opensuse.org/repositories/mozilla/openSUSE_13.2/           |       
 6 | download.opensuse.org-non-oss | Main Repository (NON-OSS)          | Ja        | Ja            |   99      | yast2  | http://download.opensuse.org/distribution/13.2/repo/non-oss/               |       
 7 | download.opensuse.org-oss     | Main Repository (OSS)              | Ja        | Ja            |   99      | yast2  | http://download.opensuse.org/distribution/13.2/repo/oss/                   |       
 8 | ftp.gwdg.de-suse              | Packman Repository                 | Ja        | Ja            |   99      | rpm-md | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_13.2/                   |       
 9 | home:ecsos                    | home:ecsos                         | Ja        | Ja            |   99      | rpm-md | http://download.opensuse.org/repositories/home:/ecsos/openSUSE_13.2/       |       
10 | network:chromium              | network:chromium                   | Ja        | Ja            |   99      | rpm-md | http://download.opensuse.org/repositories/network:/chromium/openSUSE_13.2/ |       
11 | repo-debug                    | openSUSE-13.2-Debug                | Nein      | Nein          |   99      | NONE   | http://download.opensuse.org/debug/distribution/13.2/repo/oss/             |       
12 | repo-debug-update             | openSUSE-13.2-Update-Debug         | Nein      | Nein          |   99      | NONE   | http://download.opensuse.org/debug/update/13.2/                            |       
13 | repo-debug-update-non-oss     | openSUSE-13.2-Update-Debug-Non-Oss | Nein      | Nein          |   99      | NONE   | http://download.opensuse.org/debug/update/13.2-non-oss/                    |       
14 | repo-source                   | openSUSE-13.2-Source               | Nein      | Nein          |   99      | NONE   | http://download.opensuse.org/source/distribution/13.2/repo/oss/            |       
15 | repo-update                   | openSUSE-13.2-Update               | Ja        | Ja            |   99      | rpm-md | http://download.opensuse.org/update/13.2/                                  |       
16 | repo-update-non-oss           | openSUSE-13.2-Update-Non-Oss       | Ja        | Ja            |   99      | rpm-md | http://download.opensuse.org/update/13.2-non-oss/                          |       


utgard@linux-k32u:~> zypper ve
Daten des Repositories laden ...
Installierte Pakete lesen ...


Problem: appdata(firefox.appdata.xml), benötigt von application:Firefox-.noarch, wird von keinem Repository angeboten
Lösung 1: Deinstallation von application:Firefox-.noarch
Lösung 2: application:Firefox-.noarch beschädigen durch Ignorieren einiger Abhängigkeiten


Wählen Sie aus den obigen Lösungen mittels Nummer oder brechen Sie a(b). [1/2/b] (b): 1
Abhängigkeiten auflösen ...


Die folgende Anwendung wird GELÖSCHT werden:
  Firefox 


Kein zusätzlicher Speicherplatz wird nach dieser Operation belegt oder freigegeben.
Abhängigkeiten aller installierten Pakete sind erfüllt.

Thanks caf4926!

Presumably you are not using a proprietary GPU like nvidia?
I suppose I would login with icWM and switch on the qt and plasma 5 repos and try again

You’re right. i don’t have installed any proprietary graphic driver. I use the build-in intel gpu. Although this computer would have a discrete nvidia gpu.

I suppose I would login with icWM and switch on the qt and plasma 5 repos and try again

ok. I’ll do as suggested

I assume you understand what switch means
This is an old image, just to illustrate switching to a particular repo
https://dl.dropboxusercontent.com/u/10573557/Switcher%20Pics/kde48_switch.jpeg

I assume you understand what switch means

Thank you caf4926, i got it.

Even more, you gave me the idea how to solve this issue.
I disabled the two mentioned repos and learned that in the standard opensuse repos there are also plasma 5 packages. A little bit older. So i downgraded all plasma 5 packages and … voila the progress bar doesn’t get stuck at 2/3 anymore. Problem solved!

Thanks for your patience!

That’s good news
Well done

I am also struck on the iceVM thing.
I installed open suse 13.2 dual boot with windows. then installed plasma5-session package.
I dont know what to do now
please help

You can use iceWM to manage your system
You need to decide if you want to try and use plasma5 or roll back

Did you add the additional repos for plasma5? There are

http://download.opensuse.org/repositories/KDE:/Frameworks5/openSUSE_13.2/

and

http://download.opensuse.org/repositories/home:/wolfi323:/branches:/KDE:/Frameworks5/openSUSE_13.2/

and

http://download.opensuse.org/repositories/KDE:/Qt5/openSUSE_13.2/

Once added
switch on them