Plasma 5.17 Kickoff Error

I’ve been holding off, watching the forums to see if this issue is reported by others - hard to believe I’m the only one.

After update to 20191014 snapshot, including Plasma 5.17, two of three system (Ryzen 5 laptop and AMD A6-3600 desktop; AMD FX-8310 works fine) have Kickoff errors: failure to display Kickoff menu with accompanying dialog…

Error loading QML file: file:///usr/share/plasma/plasmoids/org.kde.plasma.kickoff/contents/ui/Kickoff.qml:31:1 module “org.kde.plasma.private.kicker” is not installed.

Rolled both offending systems back to 20191009 snapshot, but tried updating the laptop to 20191016 again this morning. Issue still exists.

How did you update?

Well as that’s the default application launcher for plasma 5 I guess there’d be a lot of people shouting if it was a widespread bug…

As @Knurpht wrote, how did you “update”

If any other way than “zypper dup” you may have created problems for yourself, also, any possibility you’ve “mixed” repositories?

zypper lr -d

If you’re satisfied all is correct then you could try a forced reinstall of the “plasma5-desktop” package.

As instructed many moons ago, i only use…

zypper dup --no-allow-vendor-change

All plasma-related upgrades in the 20191014 snapshot came from Main Repository (OSS) [].

I was beginning to suspect that I should try the forced reinstall of the plasma5-desktop, assuming no one had any contradictory ideas.

Same problem here. My laptop was up-to-date with patches and I used “zypper dup” to bring my Dell Inspiron 1545 (32-bit, of course) to “20191016”. No reboot was supposed to be necessary. After zypper was done, I started getting odd messages (regarding “mc” and “ml” errors) upon launching Konsole windows. Then I noticed that the main KDE application launcher would fail with a small red background error message displaying the “org…kicker” error message. Thinking my panel had become corrupted, I created a fresh one and saw the same problem when trying to open the application menu. Following reboot, the problem persisted along with my now being unable to access the local WiFi service. Great… no way to retrieve any new patches.

I’ve since downloaded 20191016 to a DVD and reinstalled (after backing up /home, and few other important filesystem trees) the application launcher is working but still cannot get the WiFi connection to work. I’ve encountered the WiFi problem before and while it’s a doable fix it shouldn’t have been necessary. And more difficult than it should be as I cannot find any of the previously-available syslog packages (Rely on journald? Uh, no.) to watch what’s going on as I am working on getting the WiFi access back. (And I have critical reporting functions running on other TW-based systems that will break should syslog not be available anymore.)

This was NOT a clean upgrade to 20191016. >:(

There were all sorts of stability issues on the arrival of KDE 5.17, but not the Kmenu. Things have come down since then and KDE 5.17 is stable now 20191016.

rpm -qa | grep -i kde-agent 

For the WIFi issue, this quick method works for me: Yast>System>Network Settings>Global Options>Network Setup Method>Switch to Wicked Service>Click OK. Re-open Network Settings and switch back to NetworkManager Service> Click OK.
This action wakes-up WIFI or wired network here. It is also possible to do the same if the start menu does not open. Use Tab and arrows to do so:

sudo yast

Re, Ryzen 5 laptop…

Updated to 20191018 snapshot - no resolution, error still exists.

Used zypper to force install plasma5-desktop - no resolution, error still exists.

I normally use the alternative Application Menu rather than Application Launcher, and my TW machines are not Ryzen based. However, I’ve just tried switching one of those to use the Application Launcher I don’t have any issues.

I would suggest you file a bug report over at KDE

As a temporary workaround you could perhaps switch to using the Application Menu instead on that machine.

Nothing wrong with today’s updates here on our Ryzen motherboard.

Try this: In Yast, open Software Management and search for plasma5> Mark them all (19) to << update unconditionally >>,apply changes or accept. Reboot and see if it works.

Installation Log

Downloading libKF5Plasma5 (download size 389.1 KiB)
Downloading plasma5-integration-plugin (download size 142.6 KiB)
Downloading plasma5-pa (download size 172.9 KiB)
Downloading plasma5-pk-updates (download size 66 KiB)
Downloading plasma5-theme-openSUSE (download size 1.62 MiB)
Downloading plasma5-addons (download size 660.4 KiB)
Downloading plasma5-integration-plugin-lang (download size 46.5 KiB)
Downloading plasma5-pa-lang (download size 134.6 KiB)
Downloading plasma5-pk-updates-lang (download size 150.8 KiB)
Downloading plasma5-defaults-openSUSE (download size 28.8 KiB)
Downloading plasma5-addons-lang (download size 491.5 KiB)
Downloading plasma5-workspace-libs (download size 485 KiB)
Downloading plasma5-workspace (download size 4.87 MiB)
Downloading plasma5-workspace-lang (download size 1.86 MiB)
Downloading plasma5-workspace-branding-openSUSE (download size 24.6 KiB)
Downloading plasma5-desktop (download size 4.63 MiB)
Downloading plasma5-desktop-lang (download size 7.37 MiB)
Downloading plasma5-session (download size 97.5 KiB)
Downloading plasma5-session-wayland (download size 95.8 KiB)
Installing libKF5Plasma5-5.63.0-1.1.x86_64.rpm (installed size 1.20 MiB)
Installing plasma5-integration-plugin-5.17.0-1.1.x86_64.rpm (installed size 439.9 KiB)
Installing plasma5-pa-5.17.0-1.1.x86_64.rpm (installed size 626.7 KiB)
Installing plasma5-pk-updates-0.3.2-7.1.x86_64.rpm (installed size 180.6 KiB)
Installing plasma5-theme-openSUSE-84.87~git20190606T185118~3d37a0c-7.1.noarch.rpm (installed size 4.04 MiB)
Installing plasma5-addons-5.17.0-1.1.x86_64.rpm (installed size 3.28 MiB)
Installing plasma5-integration-plugin-lang-5.17.0-1.1.noarch.rpm (installed size 72.8 KiB)
Installing plasma5-pa-lang-5.17.0-1.1.noarch.rpm (installed size 360.1 KiB)
Installing plasma5-pk-updates-lang-0.3.2-7.1.noarch.rpm (installed size 1.08 MiB)
Installing plasma5-defaults-openSUSE-84.87~git20190606T185118~3d37a0c-7.1.noarch.rpm (installed size 5.3 KiB)
Installing plasma5-addons-lang-5.17.0-1.1.noarch.rpm (installed size 1.95 MiB)
Installing plasma5-workspace-libs-5.17.0-4.1.x86_64.rpm (installed size 1.91 MiB)
Installing plasma5-workspace-5.17.0-4.1.x86_64.rpm (installed size 16.36 MiB)
Installing plasma5-workspace-lang-5.17.0-4.1.noarch.rpm (installed size 10.93 MiB)
Installing plasma5-workspace-branding-openSUSE-84.87~git20190606T185118~3d37a0c-7.1.noarch.rpm (installed size 1.6 KiB)
Installing plasma5-desktop-5.17.0-1.1.x86_64.rpm (installed size 13.86 MiB)
Installing plasma5-desktop-lang-5.17.0-1.1.noarch.rpm (installed size 20.00 MiB)
Installing plasma5-session-5.17.0-4.1.noarch.rpm (installed size 66 KiB)
Installing plasma5-session-wayland-5.17.0-4.1.noarch.rpm (installed size 66.8 KiB)

If you have a missing package(s), try sudo zypper in


sudo zypper in plasma5-integration-plugin


Thanks, Mike. Did the <<update unconditionally>> for all 19 plasma5 packages on the Ryzen 5 laptop, and after reboot all appears to be well. Will update to 20191018 on the A6-3600 desktop and do the same plasma5 unconditional update. Updating plasma5-desktop by itself just wasn’t sufficient.

Thanks for your help.

I have the same issue as OP following update with “zypper dup”.
Like you, I use Application Menu also, not AL. Have also tried creating new widgets for AL and AM - I get this error regardless of which is used so that does not appear to be the cause.

To follow up, the “update unconditionally” route for all installed plasma5* packages worked for me also.

It would be interesting to know why both yourself and the OP had a package (or packages) missing.

As far as I can tell this doesn’t seem to be a widespread problem. Neither of my own two TW systems exhibited the problem. I also have “solver.onlyRequires = true” in “zypp.conf”, so it’s not a case of a missing recommended package… strange…

It sounds more like they had a corrupt package(s) that was introduce by KDE new version.

Could “no vendor change” be the issue?
Seems to me “update unconditionally” would over-ride.
Might also be why not reported widespread because I imagine most people upgrade without that flag.


If it was a corrupt package then perhaps related to specific mirror(s)…

It’s my understanding, the “update unconditionally” option within (YaST’s) Software Management simply forces a reinstall if the available version is equal to the currently installed version, ie, reinstall even though it’s not an actual update. I don’t believe it will override the vendor unless one specifically chose a different vendor from the “Versions” tab, (in which case the version would likely be different anyway and one wouldn’t be using “update unconditionally”…)

Just for info:

  • Same issue with 20191104.
  • Something must have gone amiss during zypper dup because I noticed an error along the lines of “failed to update rpm database” at the end of the process. Two different builds of the package libgdm_compat4 were reported as installed, which I had to solve via rpm -e libgdbm_compat4-1.18.1-1.1.x86_64
  • Force updating just plasma5-desktop did not work.
  • Force updating all installed plasma5-* packages as mentioned above DID work.

Hi Mike
I upgraded from Opensuse 15.1 to 15.2 and had the same issue (no starter available on desktop anymore in KDE).
After following your instructions (force reinstall of all plasma5) it worked again.
Many thanks for your tipp.
Best regards Philippe