Plasma 4.7.1 crashes before it is loaded; unable to enter it

Just to be clear: I am pretty sure this has nothing to do with a similar problem that occured about a week ago to many 4.7.1 users due to a faulty libqt4 package. This problem seems to be fixed now and I have slightly different symptoms. For instance, my problem is not related to desktop effects.

This morning my desktop was working ok, but it hasn’t loaded into plasma-desktop 4.7.1 ever since I rebooted after a few updates (some where KDE related). When I log in, KDE takes a long time to load. When the bar is at about 85%, an actual KWin window with DrKonqi pops up, informing me of the crash of kdeinit4 with the signal: Bus error (7). I can’t save the backtrace (that will lead to a DrKonqi crash). I am able to access my desktop through IceWM, but I have not succeeded to start and KDE-specific software through it (Yast-qt was no problem). I never get to see my plasma desktop.

There are no broken package dependencies. My packages should be up-to-date. The Qt 4.7.4 and KDE 4.7.1 that I use come from KDE 4.7 Release.

Create a new user and test it

Very interesting lead. A new user as well as root can log in. I also found out that the fault lies not with my .kde4 folder. But now I’m at loss what else to try.

Thank you for your help so far! :slight_smile:

Backup all your user files in the problem account.
Login to the test account and delete your normal user, including the /home
Now recreate that normal account.
Logout of test and in to new normal and move all your files back. You will need to adjust your look and feel to your liking

P.S. Take care. You may want to backup hidden files too, before deleting your normal account

Ok, I guess I’m going to have to do that, thanks. I was hoping there might be a slightly more subtle method… :expressionless:

Never, ever login as root on a desktop environment. The forums are loaded with threads on the reasons why.

If a new user can login without any errors, and your account suffers from plasma crashes, there is no other place where the origin of the crashes lies but in ~/.kde4, since the plasma config files causing the crash are living there. Could you please explain how you know the fault is not in your ~/.kde4 ? It’s the place where everything concerning your KDE lives, BTW

I know about the dangers of logging in as root. It was just for test reasons. It can also be convenient to do this when you want to change the appearence of root applications.

I know it’s not .kde4 for the simple reason that I renamed .kde4 while logged into a different user. The problem didn’t go away. This is the standard procedure for finding out whether a specific folder is responsible for a user-specific problem…

I’m going to check different other files and folders from my home folder tomorrow to see if I can find the culprit. If not, it’s going to be the sledge hammer. :wink:

Thanks a lot so far! :slight_smile:

This is the way you should do it:


kdesu systemsettings
kdesu qtconfig

it does exactly what it should do. Logging in as root on a desktop environment most of the time causes trouble, and makes it hard to detect where the origin of the trouble lies.

Could you login to the “faulty” user account, let it crash plasma, then kill the X-server by Ctrl-Alt-Backspace, login as the new “ok” user, and take a look at the .xsession-errors with


su "faulty username" (enter the user's password)
tail -20 ~/.xsession-errors

and post output here ?

I always use kdesu unless I run into problems with kate. It happens a lot that I can’t open text files from superuser dolphin (kate problems). At some point, it becomes more convenient to log in as root. But anyway. :slight_smile:

To my utter amazement, I was able to log into my system again. I did not make any changes to it except for replacing ~/.kde4 twice (I’m back with my original folder), and so I really don’t know what happened. I have to say though that desktop effects are disabled and even manual enabling doesn’t work (they were enabled and working the last time I used this account in KDE). Maybe the .xsession-errors will help with whatever happened here? I promise all I did this morning was pull in some package updates.

tail -20 ~/.xsession-errors
forums.opensuse.org: 4: (r, c) = (94, 69)
forums.opensuse.org: 4: (i) = (0)
forums.opensuse.org: 4: (l) = (0)
OpenGL vendor string:                   Tungsten Graphics, Inc
OpenGL renderer string:                 Mesa DRI Intel(R) 945GM x86/MMX/SSE2
OpenGL version string:                  1.4 Mesa 7.11
Driver:                                 Intel
GPU class:                              i915/i945
OpenGL version:                         1.4
Mesa version:                           7.11
X server version:                       1.9.3
Linux kernel version:                   2.6.37
Direct rendering:                       yes
Requires strict binding:                yes
GLSL shaders:                           no
Texture NPOT support:                   yes
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 20 (X_GetProperty)
  Resource id:  0x1e000c9
plasma-desktop(30177)/plasma StatusNotifierItemSource::refreshCallback: DBusMenu disabled for this application 

This output will be from the start that worked again, hm? But I have no reason to complain.

Thanks a lot!

Ok, desktop effects are working as well now. Can be closed. No idea what went wrong and what eventually solved it, but thanks anyways! :slight_smile: