Planning 10.3 to 11 upgrade -Keep /home?


I’m thinking I might keep my /home on this upgrade.
In the past I have always done a complete new install and transfered settings from a backup.
Currently 10.3 is running so well and I’m now only using kde4, which I’m amazed by because when it first arrived it was so rough I kept moving back to kde3.

I’m just after some feedback on the idea of keeping /home, I know it’s OK, but I’m not sure how successful it will be. In the past, certain settings from backups don’t work (ie; firefox extensions) and you end up just doing it all over again anyway.

Also, has anyone run the nvidia installer yet, I don’t mean from the repo, I mean the installer.?

keeping /home should keep all your kde4 settings like you said. as long as you make a back up just in case it will be fine…and whats the worst that could happen? having to do a clean install? not much lost really is it…

but yes, keeping /home should keep all user settings, i installed 11.0rc1 aside 10.3 but kept the same /home and all settings were the same for both, but under kde 3.5.9

For someone going from 10.3 KDE-3.5.7 to 11.0 KDE-3.5.9 I would DEFINITELY recommend one keep their /home. I have done that with the 11.0 Beta and RC (coming from 10.2 KDE-3.5.5) and it worked fine.

I also think there will be no problems keeping /home when going from 10.3 KDE-4.x.x to 11.0 KDE-4.x.x.

Also, despite the BIG difference between 3.5.x and 4.0.4, I don’t believe that would cause major hiccups if one kept /home. I suspect the file naming convention between 3.5.x and 4.x in the hidden file area under /home/ones-user-name is sufficiently different that one will not have 3.5.x configurations messing up 4.0.4.

Still having speculated on that, for going from 10.3 KDE-3.5.x to 11.0 KDE-4.0.4, I have not tried using 4.0.4, so someone with experience on that should really chime in, to provide a more conclusive assessment.

I have not.

Thanks for the advice friends. Stig: I guess you are quite correct - no harm in trying it. Just have a back up too.

I have had one or two conflicts with packages in kde3.5.9 and the progressive kde4.0…
And I expect that will continue as I may well install kde3 in 11 after getting it going.

Oldcpu: You do lots of multi-media (I do too) are you finding all the packages you need in 11? I realize some will come along if they are not there already.
Can’t wait for tomorrow now.

I’m carrying my /home with me from harddisk to harddisk since SuSE-Linux 4.2 - from upgrade to upgrade - and I believe, that’s the best way, because the software can easier upgrade, knowing your settings from an earlier version.

But I still recommend, making a backup for the case of all cases, e.g. harddiskcrash while upgrading from 10.3 to 11.0 - or whatever.

The same thing I’m doing with /usr/local, so that all selfcompiled software will still be there, after a new system is up.

Setting up a system time after time and then bringing back the home-directory later, that must - for my understanding - have not so sideeffects, because there is no update-process - which actualizes your setting-files.

That’s just my opinion, have fun!


Most the multimedia applications that I use have already been packaged by Packman packagers for 11.0, but not all of the packages … For example, I use “dvbcut” heavily, and it has not yet been packaged by the Packman packagers. I’ll wait a month after the 11.0 GM goes public, and if “dvbcut” is not yet out, I’ll send the packager a polite request to package it. This won’t be the first time I had to send a request to move dvdbcut up in the priority list of packages, after a new openSUSE release.

Another example, tovid, while packaged for 11.0 by Packman, would not install on my 11.0 because the dependency “normalize” was missing. I could not find an rpm for normalize, so I compiled it myself on 11.0, using “checkinstall” after running “make install”. This created a custom rpm of “normalize” that I installed, updating the rpm database. At that point, when I tried again, tovid installed with no problems.

But its not just multimedia … my favourite editor “leafpad” has not been packaged yet by yaloki (now a Packman packager), so I went and compiled it myself (again using checkinstall to create a custom rpm).

But overall, I’m very pleased.

The biggest problem I have with 11.0 is it won’t boot on my test PC in 9-out-of-10 boot attempts. … I have a blocking bug report on this. … And this weekend (or next) I am going to swap out the hard drive on my test PC, putting another drive in place, and then re-install 11.0 on that drive. I want to see if this “bug” is in fact not the fault of openSUSE, but instead a failing hard drive with an intermittent problem in the MBR area of the drive.

Some nice and helpful info there oldcpu

Bit worrying that boot problem

I had 11rc2 running in VBox fine.

I have always in the past kept my home partition.

So I would be doing that with this upgrade to 11.0 when I do it.

but this time I will be doing a fresh install, but only for the reason that my hard drive in my laptop is starting to go, and an upgrade is a good time to pick for getting a new larger drive anyways

I wouldn’t worry about it … I’m very suspicious about my hard drive.

My boot problem is solved. It was a bad hard drive. I swapped out the “failing” 80GB drive with an older spare 40GByte drive, installed 11.0 GM, and everything works fine. I did 10 out 10 reboots successfully. Thankfully 11.0 installs very fast and reboots relatively fast. So it meant this test (swapping hard drives, re-installing opensuse, trying various reboots) only took me 2 hours to setup and perform.

Now if I can only find all the threads where I mentioned my boot problem, to note that it is solved. …

The nvidia repo wasn’t properly working for me(x86_64), so I used the installer, might try the repo again later (after everything calms down ;))