pkcon internal-error : Repo exception


I have fresh install of opensuse 11, yesterday I have installed opera rpm and everything was fine. Later I started install of flash player, but my g/f came and I needed to leave :wink: So I switched the computer off during the installation (using menu copmuter/shutdown) and now i have the repo exception :frowning: I should have tried the cancel button first, but too late now :frowning:

user@linux-9qup:~/Desktop> pkcon install flash-plugin-
Error: internal-error : Repo exception
install-files runtime was 0.1 seconds

I have two questions:

  • how do I repair the damaged repo
  • how do I safely cancel package installation process to avoid happening of this again?

It would be perhaps faster to reinstall the whole suse, but I want to learn to solve problems, because it looks great - just installed on a new computer and all drivers are working out of the box :slight_smile: The computer came with preinstalled vista, but after my month experience with that OS I found out, that windows are going wrong way… :wink:

I’m a suse newbie, so please be patient with me :wink: I had only some experiences with debian (just command line, without x or gnome), but debian installation failed on my new computer, so I’m trying luck with suse :slight_smile:

Thank you for help.

pkcon? - Wrong.

su -c “zypper in flash-player” - Right.

Installing directly from RPMs - Wrong.
Adding the proper repositories - in this case OSS & Non-OSS - Right.

YAST -> Software Repositories -> Add -> Community Repositories, click on OSS & non-OSS, perhaps Packman as well. OK. Finish.

Wow, what a fast reply :slight_smile: Thank you. This worked. But…

…it does not solve my problem though - rightclick on any rpm I donwload from internet and choose “open with package installer” causes the same repo exception :frowning: Pkcon worked fine before I messed it up with shutdown.