Pithos Missing Plugin in Plasma 5 42.1

I have successfully installed Pithos in 42.1 before. But, now, trying to do a fresh install on a new SSD, can’t get Pithos working. I’m missing a codec of some sort, it doesn’t specifically say. I have read the install log, and the github listing, but can’t see what is missing. I do not know if what order I installed it on the good drive, but somehow, I think that maybe another multimedia app might be overwriting it (?). I usually use VLC, Clementine and radiotray. I have also Adobe flash player installed. I have uninstalled, installed and redid all my gstreamers and reformated the whole drive. It happens both in Leap and Tumbleweed. Any ideas anyone? Thank you all.

When you installed, did it pull in the following packages?

libkeybinder-3_0-0 python3-pylast python3-six python3-xdg typelib-1_0-Keybinder-3_0

Did you try cleaning the gstreamer cache;

rm .cache/gstreamer-1.0/*

Let me check. Thanks for the quick reply.

Yes, I checked install log and those items were downloaded. I also copied and pasted the CL for cleaning the gstreamer cache.
the only error which I have tried to research on the web is gst-stream-error-quark: gstreamer encountered a general stream error. I have tried to load some other plugins and or other gstreamers, without success. Thats for all your help.

I’m guessing your using packman for all your codecs?

Follow the guide here and ensure everything is switched properly;

Try after getting the following plugins packman and check