"Pithos, Client for Pandora Radio?"

I LOVE LIFE FOREVER. Sorry I’m excited. Installed and everything works. openSUSE 12.1 x86_64

  • Ran the install using yast2.
  • Listed dependencies (python, etc) and clicked accept.
  • Pithos appears in the applications menu under “audio player”.
  • Notification icon appears in the taskbar as it should and pithos minimizes to taskbar when you click the close button (as it should).
  • The “Love” button appears as an “i” in a blue circle instead of a heart like it should but I think it’s the icon theme.

This was the only reason I “missed” ubuntu. Very grateful this is now available on openSUSE and you’ve done a lot for the suse community by making this rpm available. Props to you.

Hi
And here it is running (albeit on SLED 11 SP2…)
http://paste.opensuse.org/50579982


Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 3.0.13-0.27-default
up 22:33, 2 users, load average: 0.11, 0.07, 0.06
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

Hi
And to test out the new OBS integration, here is the download…:wink:

<iframe src=“http://software.opensuse.org/download/package.iframe?project=home:malcolmlewis:Gnome&package=pithos”></iframe>

One-Click Install works perfect. openSUSE 12.1 64-bit.

Pithos does not integrate with music navigation hotkeys. HP Pavilion laptop. (Play/Pause, Skip, etc)

Not working for me (running KDE) installed thru one click, opens and logs into Pandora and I see my channel and see songs and album covers but no sound. Right clicking works fine

errors RROR:root:Gstreamer error: Resource not found., gstsouphttpsrc.c(924): gst_soup_ - Pastebin.com

thanks,

I’m going to say this is a codec issue. Do you have all the gstreamer plugins? (good, bad, ugly) Also, when you open Pithos, go to settings and check which audio format is selected. If your system normally is able to run mp3’s try choosing mp3 or mp3-hifi instead of the default (aacplus). I’m able to run every format but I have all the codecs installed (and then some).

First go here: http://forums.opensuse.org/english/get-technical-help-here/multimedia/452884-multimedia-one-click.html

You could also check this: http://forums.opensuse.org/english/get-technical-help-here/how-faq-forums/new-user-how-faq-read-only/407184-multi-media-restricted-format-installation-guide.html

Then for good measure try:

zypper in libdvdcss2 vlc libxine1-codecs k3b-codecs ffmpeg lame gstreamer-0_10-ffmpeg gstreamer-0_10-plugins-bad gstreamer-0_10-plugins-ugly gstreamer-0_10-plugins-ugly-orig-addon totem-browser-plugin w32codes-all MPlayer smplayer gstreamer-0_10-plugins-good libxine1 libdvdplay0 libdvdread4 libdvdnav4 xine-ui libmad0 ffmpeg sox libxvidcore4 xvidcore libavcodec52 libavdevice52 libvlccore4 libvlc5 totem totem-plugin-upnp totem-plugins nautilus-totem lsb pullin-flash-player flash-player gstreamer-0_10-ffmpeg gstreamer-0_10-fluendo-mp3 gstreamer-0_10-fluendo-mpegdemux gstreamer-0_10-fluendo-mpegmux gstreamer-0_10-plugins-base gstreamer-0_10-plugins-good-extra k3b libquicktime0 

Let us know how it goes.

I tried it on openSUSE 12.1 KDE and it installed fine and came right up when I clicked to open it.

It took my credentials, but came up with a Network Error. So ran it in the terminal and this is the output.

drew@Treant:~> pithos
** Message: pygobject_register_sinkfunc is deprecated (GstObject)
/usr/bin/pithos:792: GtkWarning: Ignoring the separator setting
  builder.add_from_file(ui_filename)
ERROR:root:Could not bind media keys
ERROR:root:Network error: <urlopen error [Errno -2] Name or service not known>

Just to make sure, I am playing Pandora from the browser with no issue (other than my slow bandwidth).

Hope this helps.

When I run “pithos” in terminal I receive the following output:

joshua@linux-v6o1:~> pithos
** Message: pygobject_register_sinkfunc is deprecated (GstObject)
/usr/bin/pithos:792: GtkWarning: Ignoring the separator setting
  builder.add_from_file(ui_filename)
ERROR:root:Could not bind media keys
/usr/bin/pithos:818: GtkWarning: Theme directory 64x64/status of theme Hycons has no size field

  window.show()
/usr/bin/pithos:818: GtkWarning: Theme directory 128x128/status of theme Hycons has no size field

  window.show()
/usr/bin/pithos:818: GtkWarning: Theme directory 256x256/actions of theme Hycons has no size field

  window.show()
/usr/bin/pithos:818: GtkWarning: Theme directory 256x256/places of theme Hycons has no size field

  window.show()
/usr/bin/pithos:818: GtkWarning: Theme directory 256x256/status of theme Hycons has no size field

  window.show()
/usr/bin/pithos:818: GtkWarning: Theme directory 512x512/apps of theme Hycons has no size field

  window.show()
/usr/bin/pithos:818: GtkWarning: Theme directory 512x512/status of theme Hycons has no size field

  window.show()
^CTraceback (most recent call last):
  File "/usr/bin/pithos", line 819, in <module>
    gtk.main()

My Pithos works perfectly even with these errors. The only unique error you have compared to my output is:

ERROR:root:Network error: <urlopen error [Errno -2] Name or service not known>

So this has something to do with your network connectivity… that’s about all I know from here. Make sure your NetworkManager is updated and other connectivity packages are all updated. This might be why your bandwith is so slow too. Just a guess?

Found it, was not codec but proxy setting in Gnome. I installed Gnome-control-center and changed proxy setting from manual to none and Pithos works fine (solution found here Question #122670 “Pithos could not determine type of stream” : Questions : Pithos)

Only startup messages I now get are:

** Message: pygobject_register_sinkfunc is deprecated (GstObject)

(pithos:5593): Gtk-WARNING **: Ignoring the separator setting

(pithos:5593): Gtk-WARNING **: Ignoring the separator setting
ERROR:root:Could not bind media keys

malcolmlewis - thanks for your work,

Hi
There are debug and other options from the command line, run;


pithos --help-all


Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 3.0.13-0.27-default
up 1 day 18:30, 2 users, load average: 0.00, 0.03, 0.05
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

I know Pithos allows for proxy setting, but there is a proxy setting elsewhere?

I’ll check this out when I am home, as well as the debug options.

dragonbite - revisited my problem and for what ever reason my manual proxy in Gnome-control-center was set to 127.0.0.1:8118 which would be Privoxy’s default (no idea when it was set, maybe long ago but I no longer use nor start it up and do not use any Gnome net accessing apps) so that was the cause of my problem. Appears Pithos uses the Gnome default proxy when leaving their field blank

Is there a way to edit this via command line?

Hi
Just to update this thread to say I’ve pushed pithos to GNOME:Apps, so
it will probably disappear from my home repository and appear in the
new repository. It may also get pushed into 12.2 as well…


Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 3.0.13-0.27-default
up 0:46, 2 users, load average: 0.01, 0.06, 0.05
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

So I’m trying to use Pithos today and I’m receiving a message box saying: “Pithos need to be updated for compatibility for Pandora’s latest changes.”

I tried updating through GNOME:Apps but I’ll guess it’s time to update again.

Hi
It’s just been accepted into GNOME:Apps in the last 20 minutes or so :wink:

It’s still waiting to build;
https://build.opensuse.org/package/show?package=pithos&project=GNOME%3AApps

Keep an eye out for the build to finish and pushed out to the mirrors, it’s also the latest version 0.3.16.

Ah ok, please let me know when it’s ready. Thank you. :slight_smile:

Hi
It’s in the GNOME:Apps repository for 12.1 now :wink:
http://download.opensuse.org/repositories/GNOME:/Apps/openSUSE_12.1/noarch/


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.1 (x86_64) Kernel 3.1.10-1.9-desktop
up 2 days 3:39, 3 users, load average: 0.06, 0.04, 0.05
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU