Pipewire-alsa-0.3.70-1.1.x86_64 conflicts with 'alsa-plugins-pulse'

Getting the following error when I try to update today (Tumbleweed, pretty much only standard repos enabled).

Problem: the to be installed pipewire-alsa-0.3.70-1.1.x86_64 conflicts with 'alsa-plugins-pulse' provided by the installed alsa-plugins-pulse-
 Solution 1: deinstallation of alsa-plugins-pulse-
 Solution 2: deinstallation of pipewire-alsa-0.3.69-2.1.x86_64
 Solution 3: keep obsolete pipewire-alsa-0.3.69-2.1.x86_64


1 Like

Found this at New Tumbleweed snapshot 20230512 released! - openSUSE Factory - openSUSE Mailing Lists

- Make pipewire-alsa conflict with alsa-plugins-pulse as both
  provide /etc/alsa/conf.d/99-*-default.conf

Does this mean that Solution 1 can be used? (Solution 1: deinstallation of alsa-plugins-pulse-

@Rob_Dean yes Solution 1 :wink:

1 Like

On a single core Pentium 32bit TW I just started to upgrade minutes ago, with none of pipewire or wireplumber installed, no similar conflict appeared.

How long ago was your last upgrade? IMO it depends whether yours is currently more dependent on pipewire or on pulseaudio. The following is from a TW upgrade on Intel Haswell to 20230511 where pulseaudio is not in use, or even installed:

# pinxi -Aaz --vs --zl --hostname
pinxi 3.3.27-01 (2023-05-07)
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio
    vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus-ID: 00:03.0
    chip-ID: 8086:0c0c class-ID: 0403
  Device-2: Intel 8 Series/C220 Series High Definition Audio
    vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
    chip-ID: 8086:8c20 class-ID: 0403
  API: ALSA v: k6.2.12-1-default status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: aRts v: 1.5.10 status: off with: artswrapper status: off
    tools: artsdsp
  Server-2: PipeWire v: 0.3.69 status: off with: wireplumber status: off
    tools: pw-cat,pw-cli,wpctl
# aplay /usr/share/sounds/alsa/test.wav # analog audio works normally
Playing WAVE '/usr/share/sounds/alsa/test.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo
# rpm -qa | grep -E 'alsa|arts|gstr|jack|mix|pavu|puls|sof-f|wire' | sort
# systemctl --global --user status pipewire.{service,socket}
* pipewire.service - PipeWire Multimedia Service
     Loaded: loaded (/usr/lib/systemd/user/pipewire.service; disabled; preset: disabled)
     Active: inactive (dead)
TriggeredBy: * pipewire.socket

* pipewire.socket - PipeWire Multimedia System Socket
     Loaded: loaded (/usr/lib/systemd/user/pipewire.socket; enabled; preset: enabled)
     Active: active (listening) since Fri 2023-05-12 19:12:42 EDT; 6min ago
   Triggers: * pipewire.service
     Listen: /run/user/0/pipewire-0 (Stream)
     CGroup: /user.slice/user-0.slice/user@0.service/app.slice/pipewire.socket

Last update was yesterday or the day before. I’ve no idea if my system is more dependent on pipewire or pulse audio. My (very, very limited) understanding was that pipewire is slowly replacing pulse audio?

➜  ~ inxi -Aaz --vs --zl --hostname 

inxi 3.3.23-00 (2022-10-31)
  Device-1: AMD SBx00 Azalia vendor: Micro-Star MSI driver: snd_hda_intel
    v: kernel bus-ID: 00:14.2 chip-ID: 1002:4383 class-ID: 0403
  Device-2: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
    vendor: Micro-Star MSI driver: snd_hda_intel v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 16 link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.1
    chip-ID: 1002:aaf0 class-ID: 0403
  Sound API: ALSA v: k6.3.1-1-default running: yes
  Sound Server-1: PulseAudio v: 16.1 running: yes
  Sound Server-2: PipeWire v: 0.3.70 running: yes


I’ve just had the same issue. I had a look around in yast, and it seems that in my system there are lots of connections to alsa-pulse, and none to pipewire - so I uninstalled pipewire - I assume that’ll be the path of least resistance…

I hope that helps (someone)

Why is solution 1 best?

@rokejulianlockhart read the changelog (As a Tumbleweed user you should follow the Development Mailing List) a conflict was created to replace alsa-plugins-pulse.

1 Like

I had the same issue as you updating Tumbleweed and I chose option 1 which seemed to work fine.

I believe pipewire is slowly replacing pulse audio.

1 Like

Would you mind elaborating a little on why you choose not to install pipewire and wireplumber? :slight_smile:

That was a week ago. I’ve rotated through several PCs since then. It looks to me like what is not installed is *pulse*.

Which option to choose may depend on whether you prefer pulse over pipewire. I had switched TW to pipewire, but after experiencing sound glitches in the form of dropouts, I switched back to pulse (after extensive searches and experimentation to try and resolve the issue). So I figured option 2 might suit me better.

@mchnz, PulseAudio also works when the user is logged-in as root, whereas PipeWire doesn’t (Please allow invocation by the superuser. (#2244) · Issues · PipeWire / pipewire · GitLab) so yeah, there’s the occasional use for PulseAudio.