Pi 3 Stuck on Scanning bus 0 for devices

I’m using Raspberry Pi 3 Model B

So far I have tried the following images:

In both cases, the Pi gets stuck on the black screen at
“Scanning bus 0 for devices…”

It does not proceed. What is the issue here?

Hi and welcome to the Forum :slight_smile:
How did you add the image to the SD card?

Do you have a serial connection available to follow bootup before grub?

I used a card reader, used the following command to write image on it:

xzcat [image].raw.xz | dd bs=4M of=/dev/sdX iflag=fullblock oflag=direct; sync

I am directly powering the Pi from an adapter. Do I need to do something else? Does it need ethernet for first boot or something?

And you check the image checksum, eg;

sha256sum -c openSUSE-Leap42.3-ARM-XFCE-raspberrypi3.aarch64-2017.07.26-Build1.1.raw.xz.sha256

openSUSE-Leap42.3-ARM-XFCE-raspberrypi3.aarch64-2017.07.26-Build1.1.raw.xz: OK
sha256sum: WARNING: 14 lines are improperly formatted

From a serial connection I see (on a fresh 42.3 XFCE image);

Welcome to minicom 2.7

Port /dev/ttyUSB0, 07:18:12

Press CTRL-A Z for help on special keys

U-Boot 2017.05 (May 08 2017 - 15:27:50 +0000)

DRAM:  880 MiB
RPI 3 Model B (0xa02082)
MMC:   bcm2835_sdhci: 0
reading uboot.env

** Unable to read "uboot.env" from mmc0:1 **
Using default environment

In:    serial
Out:   lcd
Err:   lcd
Net:   Net Initialization Skipped
No ethernet found.
starting USB...
USB0:   Core Release: 2.80a
scanning bus 0 for devices... 4 USB Device(s) found
       scanning usb for storage devices... 0 Storage Device(s) found
       scanning usb for ethernet devices... 1 Ethernet Device(s) found
Hit any key to stop autoboot:  0 
switch to partitions #0, OK
mmc0 is current device
Scanning mmc 0:1...
14974 bytes read in 150 ms (96.7 KiB/s)
Found EFI removable media binary efi/boot/bootaa64.efi
reading efi/boot/bootaa64.efi
576512 bytes read in 57 ms (9.6 MiB/s)
## Starting EFI application at 01000000 ...
Scanning disks on usb...
Scanning disks on mmc...
MMC Device 1 not found
MMC Device 2 not found
MMC Device 3 not found
Found 5 disks
Welcome to GRUB!

error: terminal `gfxterm' isn't found.
EFI stub: Booting Linux Kernel...
EFI stub: UEFI Secure Boot is enabled.
EFI stub: Using DTB from configuration table
EFI stub: Exiting boot services and installing virtual address map...

Welcome to openSUSE Leap 42.3 - Kernel 4.4.76-1-default (ttyS0).

linux login: root
Have a lot of fun...
linux:~ # 

On the HDMI output it expands the image and fires up to the login screen.

What size SD card (I use 16GB ones), does your card reader handle your sd card ok as in you can read info after it’s ejected and inserted?

I have previously used Ubuntu 16.04 MATE, with similar procedure. The card reader wrote fine.

On boot (ubuntu MATE), it expanded the file system, then rebooted again, and worked properly.

I’m using 8GB card.

Can I establish serial connection of the micro USB port itself? (The one for power)

I don’t have a serial connection as of now, but the HDMI output remains on

scanning bus 0 for devices... 

How much time does it take to proceed from here?

I have definitely waited more than 10 mins. Do you think I should wait more?

No, you need to connect a serial cable (I use PL2303HX USB To TTL To UART COM ones) to the 40 pin header (6-gnd, 8-Rx and 10-Tx) to see what else is happening.

So you get to grub and able to select install? I should take 4-5 minutes to get to the login screen.

Maybe the SD card failing? Can you check the image checksum, I would look at wiping the sd card (eg via wipefs -a) and re-imaging and see how it goes.

Also how good is the power supply voltage wise? I only see the scanning bus 0 for devices at first boot, so I’m guessing your not even seeing grub?

No, I’m not even seeing the grub. Like I said, its just stuck on scanning bus 0.

I dont think its an image writing issue, because I tried 2 images, wrote the card 3 times.

And that procedure has worked for raspbian, ubuntu and now today for pi64. So its not SD card or reader issue.

Regarding power, yes I do get the lightning bolt on MATE indicating its insufficient. Though it hasn’t affected the working so far.

I dont think I’ll be able to setup the serial connection anytime soon.

Do you have another SD card to try? I wonder if openSUSE u-boot etc requires more power? If not getting to grub, it would seem to me it’s a hardware issue, power/sd card.

If you pull the SD card and boot, do you see the same?

Is the system tweaked for USB boot, if so wonder if a USB device and Tumbleweed may work…

Also try booting without the keyboard or mouse connected as well…