i have installed phpmyadmin from repository and when i try to connect i get the message:

Access denied
error 403

i don’t know what to do

thanks for your help


is it a problem with a non loaded apache module?

Should work out of the box if you got the package from Check that you have the right package:

rpm -q phpMyAdmin

Check that you are using the right URL:


Show us the full error message. Also look in /var/log/apache2/error_log for any clues.

I haven’t tried phpmyadmin. but i think its related to your mysql conf, mean username/password.

You can use, works far better than phpmyadmin:
Mysql Query Browser
Mysql Administrator

You can search it in software management:

It’s a front end tools for MySQL, and works better than other softwares.

rpm -q phpMyAdmin : phpMyAdmin-3.2.0-1.1
the message is : you don’t have access to this directory; either there is no index.html either the directory is protected

thanks for your help


Did you install these packages?


and probably more needed. You also need to enable php5 in /etc/sysconfig/apache2, variable APACHE_MODULES, you should add php5 to that string and restart apache.

i had all these packages installed and i add php5 to MODUELS in sysconfig .I restarted apache but it does’nt work!!

what can i do?

First test a simple PHP script to make sure that system works. Put this in /srv/www/htdocs/phpinfo.php:


Then go to http://localhost/phpinfo.php. If you don’t get a page telling you all about PHP, your PHP setup isn’t working.

i tried your test and it does’nt work!!


AFAICS you don’t have apache running. Start Yast - System - Runlevel editor, and make sure apache starts at boot.
Then in Yast - Network Services - HTTP configuration check the settings.

does phpmyadmin use a virtual host?

No, not requred.

trazomtg wrote:

> does phpmyadmin use a virtual host?
Did you check the permissions on /srv/www/htdocs/phpmyadmin/
should be 664, used to setup by default as 644. Also did you set the
parameters in correctly?

Hope this helps.

Russ [openSUSE 11.1 ( [x86_64]) KDE 4.3.0 release 158,
Intel DX48BT2 Core 2 Dual E7200. 4 GB DDR III GeForce 8400 GS, 320GB Disc