Perplexing problem
I have just installed openSuSe 11.1 and the relevant LAMP stack using yast2. It is a little different to the Red Hat and Solaris environments I am used to, however, with some effort got a good deal of the way. Apache2 works just fine, the PHP and extensions seem to be working OK, and MySQL is up and running. I installed phpMyAdmin (I am used to this tool) and it is behaving quite oddly.

When it first started I was logging in as root, and it gave me a big red no privileges message under Create Database. Very odd. I thought it might be complaining about root coming in over a socket so I popped into the mysql client

mysql -user root mysql -p

Password: *********************
mysql> grant all on . to addinall identified by ‘anewpass’;
mysql> OK, 0 rows effected, 0.12sec
mysql> flush tables;
mysql> OK
mysql> quit

Fine, I restarted Apache and mySQL to be on the safe side and fired up http://localhost/phpMyAdmin

And I get the login prompt, enter the user name and the password and it takes me to the home screen. STILL with a big red No Privileges messages. If I select the database mysql and the table user I see myself inside with.

localhost addinall *93A0F1FAE05D991E9C59D67650486E1D59A53A9F Y Y Y Y Y Y Y Y Y Y N Y Y

All privileges except GRANT. I can’t seem to find a way around this. Anyone else seen it?


Hmmmm, even more of a worry… It came good after a reboot…?


If you look at the MySQL documentation you will see that ALL is shorthand for all simple privileges except GRANT OPTION. So GRANT itself has to be explicitly granted. But this is not relevant to CREATE which is what you want. Perhaps phpMyAdmin was caching cookies and you needed to logout to get the true status.

That’s the good thing about this forum: Above posts give me a solution to a problem I don’t even have yet, but was described to me by a friend as something I would definitely hit. Cheers to all of you