phpMyAdmin not found by browser

Completed the LAMP stack installation on a fresh install of Leap 15.4
Apache2, MariaDB, PHP7 installed and tested OK
Performed zypper in phpMyAdmin OK
Logged into MariaDB and created pmauser@localhost
All seems ok.
Clicked on the link in the installation instructions: http://localhost/phpMyAdmin
and get a 404 error

Object not found!

The requested URL was not found on this server. If you entered the URL manually please check your spelling and try again.

If you think this is a server error, please contact the webmaster.

Error 404

To be sure, tried http://localhost/phpmyadmin as well. Same result.
I suspect a server configuration file alias error, but all looks OK.
Any ideas?
Much Appreciated.
Have fun,

In testing this myself, I would suggest a couple things:

  1. Ensure that you’re not being redirected to https://localhost/phpMyAdmin/ (Firefox did this to me for some reason when Apache wasn’t running).
  2. Try restarting Apache (sudo systemctl restart apache2)

You may also want to run a zypper up to make sure the system is updated.

Once I ensured that Apache was running, I was able to connect to phpMyAdmin (and that path is case-sensitive).

Something else I just noticed - there is a training / on the URL - you might try http://localhost/phpMyAdmin/ and see if that works for you.

Thank you, hendersj.
All good ideas, tried them all, no joy.
Apache2 is running OK.
I suspect something with

Alias /phpMyAdmin /usr/share/phpMyAdmin

in the phpMyAdmin.conf file
Trouble is, I have not found the .conf file that contains the Include statement to include the phpMyAdmin.conf file.
Lots of places to look, but I’ll keep at it.

I appreciate your ideas.
Have fun,

I went through all the .conf files and mapped all Include and IncludeOptional statements.
Made no changes (that I know of).

restarted Apache2 and pointed the browser to localhost/phpMyAdmin and…Bingo it works.
Do not know what I did . Oh well.

Glad to hear it’s working for you now. :smiley:

Progress is slow…
Now, when I login to phpMyAdmin i get this error
!Failed to set session cookie. Maybe you are
using HTTP instead of HTTPS to access phpMyAdmin.

Well, yes, I am.

Do I need to make self signed certificate with openssl.
Or, can it get Apache to set the session cookie?
Could anyone point me to a guide? If not Let’s Encript has some information I have used in the past on Windows. This is my first time setting up a certificate on SuSe.

Help is appreciated!
Have fun,

Got a solution…
Installed Chrome. Works fine!

Have fun,

1 Like