PHPDoc -i parameter is ignored?

Guess I’d be better off on the phpdoc forum, but it seems to be rather inactive.

Anyways… I run the following command to create my documentation:
**sudo phpdoc -t /srv/www/htdocs/doc/ -o HTML:default:default -d /srv/www/htdocs/src/ **
Problem is that it also creates documentation out of the /srv/www/htdocs/src/libs/adodb_lite/ directory… which has its own documentation elsewhere and I don’t want showing up in my own documention.

According to the manual “-i --ignore file(s) that will be ignored, multiple separated by ‘,’. Wildcards * and ? are ok”

So I tried appending -i /srv/www/htdocs/src/libs/adodb_lite/* to the end of the command and it does absolutely nothing.
Am I to blame for making some kind of mistake here or should I point my finger at phpdoc?

Well phpdoc, if it’s the one I’m thinking of, is written in PHP, so you can dig into the source code and see what it’s doing with the -i argument.

You are right, but me being as lazy as I am I the backup plan was to simply work around it by moving the directory before executing the command as that’s no doubt a lot faster to do then figuring out what’s going on in the source code of PHPDoc. (though I’m sure it’s well documented ;))

I’ll have to do some custom scripting anyways to clear the output directory before using it to remove any unnecessarily files from it along with adding a link to the main menu to the ‘original’ adodb documentation. Might have to add JSD (javascript doc) into the routine as well if PHPDoc itself doesn’t handle javascript files… didn’t test that yet :slight_smile:

Noticed that adodb_lite seems like a poor choice on my part as well… last update is too long ago for me to have trust in it so I’ll just stick to the ‘original’ adodb.