php5-imagick; cant install on OpenSuse 13.2

i try to install php5-imagick from repo:

Unfortunately Yast reported the following error:

YaST2 conflicts list - generated 2014-12-12 15:26:54, benötigt von php5-imagick-3.1.2-1.4.x86_64, wird von keinem Repository angeboten

 ] php5-imagick-3.1.2-1.4.x86_64 nicht installieren

 ] php5-imagick-3.1.2-1.4.x86_64 beschädigen durch Ignorieren einiger Abhängigkeiten

YaST2 conflicts list END

Where could i download the missing libmagickcore?

Any clues?


you can find your rpm here:

pls notice that it is build for 13.1
kind regards

Thank you for the fast reply!

Do i understand correctly:
The php5-imagick build inside a repository for 13.2 depends on a libMagicCore version for 13.1?
Im quit sure, that this is not recommended :\ If so, why isnt this version available inside the 13.2 repo?
If not, why is this php-imagick version available without the depending libMagicCore version?
I think this is a little bit confusing…

PS: I can`t install your version, because yast replies about the lower magiccore version 6.8 -> 6.9



php5-imagick-3.1.2-1.4.x86_64 depends on libMagicCore version, what seems to be version 6.9
and that version is not provided.

what you can do is build the rpm by yourself
but you need a lot of development packages

You might want to submit a bug in bugzilla.

Not that long ago I created a bug that imagemagick was completely missing in Apache (wasn’t just an openSUSE issue).
It may be that someone implemented a fix based on the bug I submitted but needs to be updated to 13.2 requirements.
If you submit a bug, hopefully it’ll be assigned to whoever did the work to build what exists and update easily.

At least you have a starting point for what might be possible…
When I submitted my bug, I spent quite a bit of time trying to find a satisfactory solution but kept running into major obstacles.