php does not display pages

I searched for the answer to this question, it appears here

But that was never resolved, I was wondering if in the interim a solution has been found, because I find myself with the same problem.

I have tried these without success

a2enmod -l

I got the same answer as the op in the above, the op who was giving the example.

a2enmod php7

Running this command showed nothing

Also they talked about this being present

AddHandler application/x-httpd-php-soucese

it is in my php7.conf

Thank you

That command enables the module, have you checked it’s active and restarted the apache2 service?

apache2ctl -M

Yes I restarted apache2.service
This command output

apache2ctl -M


DellLaptop:~ # apache2ctl -M
Loaded Modules:
 core_module (static)
 so_module (static)
 http_module (static)
 mpm_prefork_module (static)
 unixd_module (static)
 systemd_module (static)
 actions_module (shared)
 alias_module (shared)
 auth_basic_module (shared)
 authn_core_module (shared)
 authn_file_module (shared)
 authz_host_module (shared)
 authz_groupfile_module (shared)
 authz_core_module (shared)
 authz_user_module (shared)
 autoindex_module (shared)
 cgi_module (shared)
 dir_module (shared)
 env_module (shared)
 expires_module (shared)
 include_module (shared)
 log_config_module (shared)
 mime_module (shared)
 negotiation_module (shared)
 setenvif_module (shared)
 ssl_module (shared)
 socache_shmcb_module (shared)
 userdir_module (shared)
 reqtimeout_module (shared)
 php7_module (shared)
DellLaptop:~ # systemctl restart apache2

Unfortunatley, did not fix the problem.
It does not work with phpinfo(); either

Thank you

Just a guess, but on 15.0 you may still need

a2enmod php

I have discovered the problem but not the solution. Some of the sites work and some do not for example, say I have 3 dirs in my DocumentRoot say, users, vids and stuff, each with an index.php file. When I type “localhost/users/index.php” in the brower it wants to download the index.php file
and others work as expected. I have tried samething on another computer and it(the user) work.

Any suggestions as to what might be the problem?

Thank you