PHP 5.3 on SLES 11

Hi everyone,

we are running multiple SLES 11 boxes with PHP 5.2.6 and we are interested on upgrading to PHP 5.3.
I found openSuse 5.3 RPMs in this repository
Index of /repositories/server:/php/openSUSE_11.1

I tried the packages and everything works just fine on SLES 11.
Later i found a specific SLES repository at Index of /repositories/server:/php/server_apache_SLE_10
which offers PHP 5.3 packages too and iam now wondering if this repo is the better choice for us, even its for SLES 10 and not SLES 11.

Any ideas!?

Many thanks.
Philipp

cornettonuss wrote:
> we are running multiple SLES 11
> Any ideas!?

this is openSUSE, you are welcome to hang in here and see if someone
can help you…but the support you deserve is over on the commercial
side at http//:forums.novell.com

your log in credentials here work there too…i think if you don’t log
out here you will arrive there all ready to go…


palladium

I think asking a question about openSuse RPMs in the novell forum will result in the same problem :wink:
And afaik there is no and there won’t be any (even commercial) support for PHP 5.3 on SLES 11.

Thanks.
Philipp

I’m the type of person if it isn’t broke don’t fix it. :wink:

As for which is better not sure either is, but I would of thought ideally a rebuild(rpmbuild --rebuild some-sle_10.src.rpm) of sle_10 would be the best, then it would be built for sle_11.

I could continue with unsupported but I get the impression it would be like teaching my grandma to suck eggs.

cornettonuss wrote:
> I think asking a question about openSuse RPMs in the novell forum will
> result in the same problem :wink:

yep, you are definitely on your own if you are buying support for your
SLES…on the other hand if you have a support contract i think they
will/should/could give you the best answer they can…

well…as said, you are very welcome hang around here…there are a
few folks here who have actually used SLEx—i’ve never seen one
running…heck, i’ve never seen an install disk…

seems you are between that well known rock and hard place…
maybe what you need is a nice sandbox and give all the possible
permutations a whirl…

on the other hand your “I tried the packages and everything works just
fine on SLES 11.” falls into my Grand Unified Rule One:

If it ain’t broke, don’t fix it.

unless of course you are driven by the well known Rule Two:

It it ain’t broke, fix it until it is…and then: Have a lot of fun!


palladium

Addendum suddenly thought about the build service now I have to admit to being a little naive to its exact workings but if I understand this correctly(Presuming you can see it)

https://build.opensuse.org/package/show?package=php5&project=server:php this is showing sle_11 being built at the moment it is failing whether this will change I can only speculate that it will eventually be built.

Well its broke. Moodle 2.2 requires php 5.3.2 or higher, so anyone running a SLES 11 server looking to upgrade to Moodle 2.2 will need to upgrade php or pick another distro to use as their server.

Am 06.02.2012 00:06, schrieb Stephor:
>
> FeatherMonkey;2149611 Wrote:
>> I’m the type of person if it isn’t broke don’t fix it. ;)Well its broke. Moodle 2.2 requires php 5.3.2 or higher, so anyone
> running a SLES 11 server looking to upgrade to Moodle 2.2 will need to
> upgrade php or pick another distro to use as their server.
>
>
From what I see php 5.3.10 for SLES 11 is available from here (if you
have service pack 1)
http://download.opensuse.org/repositories/server:/php/SLE_11/

But you are on the wrong forum, this is for openSUSE not for SLES.


PC: oS 11.4 (dual boot 12.1) 64 bit | Intel Core i7-2600@3.40GHz | KDE
4.6.0 | GeForce GT 420 | 16GB Ram
Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.8.0 |
nVidia ION | 3GB Ram

Thanks, That worked well with SLES 11. Better that the php53 in SP3.

If you are looking for PHP 5.3 for SLES 11, I’m on SP2 it’s right in the repositories. Just use Yast Software to select the new packages and it’ll will prompt to remove the old and install the new.

I too am putting on Moodle 2.4.