Phonon problem - need to revert

Hi all,

I installed the wrong phon xine backend thingy and need a n00b friendly solution if its available.

Dimble:
“i upgraded my 11.0 to 4.1, and it now says on boot-up; “failed to enable Phonon, reverting to previous method”.
sound works ok, so it isn’t really a problem, just mentioning it.”

Snakeyes:
“Hi, install a package called phonon-backend-xine”

Dimble:
“having done that, i now get the following knotify error message after login:
Unable to use Xine Multimedia Backend:
The plugin ‘phonon_xine’ uses an incompatible KDE library (4.1.60 (KDE 4.1.60 (KDE 4.2 >= 20080709)) “release 43.4”).
sound still works, but i am about to give this laptop to my non-techy sister who will not like error messages popping up for no good reason.
anyone know what the problem is; and how a non-technical sort like myself might fix it?”

Slammer64:
“Dimble, it looks like you are using the Unstable repo rather than Factory, could you verify that please?”

Dimble:
“hi there, i am indeed, any ideas on how i might rectify matters?”

Many thanks for any assistance rendered.

Dimble

I replaced my 11.0 KDE4 install with 11.1 alpha2 and those problems went away:)

I’ve done 3 updates using the factory repos & alls well; sure there are some nit-noids & part of that is the learning process.

is it possible to do an easy upgrade from 11.0 to 11.1 A2 or is it a straight re-install over the top?

cheers.

Don’t switch to 11.1. Your sister is gonna have an even worse time with an alpha OS. What you should do is enable factory repo and reinstall KDE 4 entirely by using the patterns in yast. I’ve had no trouble with factory packages so far. You should also think about deleting the .kde4 directory in your home folder.

sounds promising, could you give me any more pointers on how i reinstall KDE using patterns?

will i then have to reinstall 4.1?

and will i still have the original problem on phonon not being used?

is it not simply possible to revert to a pre xine-patch state, a glorified “undo” if you will…?

cheers

Well the problem is that using unstable repo for kde 4.1 is a really dangerous move and can sometimes lead to an unbootable kde. Reverting to factory repos is basically uninstalling and reinstalling anyway.

But here’s how to do it. This method is not using patterns because there’s some really weird bugs in yast patterns management. In the end its the same thing.

1.)Go to yast->software repositories and remove the unstable kde 4.1 repo

2.)Go to yast->addon products->community repositories and enable the KDE 4.1 Factory repo.

3.)Go to yast->software management, select the Repositories Filter. Select the KDE factory repository. Right click inside the package list->all in this list->update unconditionally.

This should revert all packages back to factory and you should have a stable kde install. Remove .kde4 from your home directory after install.

cheers, sounds do-able. :slight_smile:

re. 2.) i don’t have a 4.1 factory repo listed… :frowning:

do you mean: KDE4:Factory:Desktop

because having used the one click link for what i think is 4.1 factory i still have nothing labelled as such…

having selected Filter:Repositories in software management it won’t bring up any sybmenu when i right click on KDE4…

Yes I meant the KDE4 Factory Desktop repository.

You have to select the repository in the filter list, then right click in the list of packages on the right. A menu should pop-up and allow you to update unconditionally.

this has turned, quite frankly, into a disaster.

i managed to get the kde4 repo to update the system having removed unstable from the list of repo’s, (tho i never found a right-click option to update unconditionally), only to get a black screen.*

i used the install disk to attempt a system repair, only to get a black screen.*

i used the install disk to reinstall the system, using default settings all the way, to recieve a bizarre desktop with no taskbaron the bottom.

i used the install disk to attempt a repair of the reinstall to get the black screen again.*

This is a celeron/915/acer laptop, the most generic and supported hardware in the effing world, what is wrong with the **** thing?!?!?

  • video output works fine; green splash on boot and screen prompt on Ctl+Alt+Del, but black & blank desktop otherwise.

in fact, let me be more clear: this stupid problem is one giant heap of unnecessary &0ll0x!

this is what happens if i press Ctl+Alt+Del after the system has booted up, the blank screen behind is all i see until i press Ctl+Alt+Del:
http://nexusnet.18.forumer.com/uploads/nexusnet/post-2-1220348316.jpg

this is GODS default linux laptop, that has run countless distro’s flawlessly including suse 11.0 until recently.

why can it not correctly display the desktop?

> why can it not correctly display the desktop?

it seems apparent that you cannot ‘hack’ your way though to happiness
with KDE4.x, so i quote “mingus725” who wrote the following (much
better than i could ever) on 13 Aug 2008:

“KDE 4 is still very young. It is recommended only for experienced
users who can hack their way around problems. If you have not
upgraded from the installed 4.0 to 4.1, you can try that; 4.1 is much
better. But still, it is undergoing active development and at times
things don’t work right. You would just have to see. The better bet
would be to install KDE 3.5.9; you can do that and leave KDE 4.1
installed, too. KDE 3.5.9 is very mature and stable. You could then
use 3.5.9 as your primary gui, and occasionally update your 4.1 and
check it out; when your 4.1 is stable, you can switch to it as your
primary. Many very experienced openSUSE users are sticking with 3.5.9
until 4.x has had time to mature.”

perhaps you should go back to the root problem, which imo is KDE4,
despite written warnings otherwise (see http://tinyurl.com/3vwrzl
paragraph 7) you elected to install it anyway…

my own personal opinion is the best way out of the mess you are in is
probably to begin again, and this time install either KDE3.5.9 or
Gnome…

and reading that page top to bottom, and all the posts in that thread…

i guess you will have much better luck…


see caveat: http://tinyurl.com/6aagco
DenverD (Linux Counter 282315) via NNTP, Thunderbird 2.0.0.14, KDE
3.5.7, SUSE Linux 10.3, 2.6.22.18-0.2-default #1 SMP i686 athlon

@DenverD: Asking Dimble_ThriceFoon to downgrade to KDE 3 is not a solution to his problem, especially when KDE 4 has worked well before on his computer. Telling him to shy away from KDE 4 is depriving him of the learning experience and wasting the time he used to post on this forum. Not to mention it also makes it harder for the devs to find out bugs.

@Dimble_ThriceFoon

Do not use the repair option anymore. I fixed my black screen KDE problem by deleting both .kde and .kde4 folders in my home directory. If this does not work for you, you probably have some KDE packages that are not from the same version (e.g. 4.0 packages mixed with 4.1 packages). You can either

1.) Connect your computer to an ethernet cable and do a clean reinstall of the system with the factory repository enabled. There is an addon products option available.

2.) Log into KDE and meet the black screen. Then press Alt-F2 and type yast. Now enable KDE 4 factory repo and filter the list by repository so that only KDE 4 factory packages are shown as before. If right click is not working for you, click Packages on the top menu bar->All in this list->Update unconditionally. After you finish installing KDE 4.1, go back to the list, and sort by installed packages. Briefly go down the list to make sure there aren’t any packages with version 4.0.4. After that delete .kde and .kde4.

cheers for the continued advice both. :slight_smile:

i have done a reinstall from the disk twice, and both times tried to repair it when i still got the back screen.

i cannot find the .kde folder nor too the .kde4 follder , so i am attempting to muck about with the repositories as advised.

this is getting silly.

the uncoditional update achieved nothing.

deleting kde and kde4 in the home folder has given me a white screen.

can someone tell me why an install over the top has not given me a clean system please?

Is it because the installer preserves the home folder, and and if so how do i disable this ‘helpful’ feature?

Having done this can i reasonably expect to have a clean, working, functional, and non-irritating opensuse 11.0 installation?

Many thanks

i have managed to get a clean install by formatting all linux partitions.

so wehay!

cheers guys. :slight_smile:

And you got KDE 4.1 working as well?

used the KDE4 Factory Desktop one-click repo to install 4.1.1 yesterday, works a treat.

bets of all there is no phonon xine problem this time around.