Philosophical Question about YaST in LEAP 15

In LEAP 15, YaST does not have available as a default the option to configure a DHCP server. As far back as I can remember SUSE has always had the dhcp-server installed as a default and access to it in the YaST Control Center. 15 is the first version of LEAP that I have had to use zypper to actually install dhcp-server. Has SUSE had a change of thinking about where LEAP is going?

Just interested.
Thanks
Bob

I notice that it is possible to install both “dhcp-server” and “yast2-dhcp-server”. I assume that if you install “yast2-dhcp-server” then Yast will have the ability to setup the dhcp server for you.

And yes, I’m aware that Yast crashed when you tried to install “dhcp-server” (your other thread). I’m still not sure why that happened.

As for whether this is a change – I simply don’t know. I have never noticed whether “yast2-dhcp-server” was installed by default on earlier systems, because I have never needed to use it.

I find this story a bit confusing. I have read nrickert’s comment above and understand you had problems installing the DHCP server software using YaST. That knowledge may make it a bit more understandable, but you did not mention it.

You say that they were installed by default earlier. I have an openSUSE 13.1 here and they are NOT installed there. I can assure you that I did not remove them (or prevented them from installing at system installation). Thus they weren’t installed by default in 13.1.
You say you could install them using zypper. That is fine, and it would imply you can install them using YaST > Software Management because these two tools are interfaces to the same installation software zypplib. Apparently you had a problem with that, but I can only interprete that as some strange glitch (and seems to be the subject of another thread) and not as a policy about where “LEAP 15 is going”.
Another package that I would install with the DHCP server software is the YaST package that plugs-in into YaST and will offer a configuration tool for the DHCP server. Not illogical, that is not installed with the default installation in my13.1.

So, I do not know how far “As far back as I can remember SUSE has always …” is, but 13.1. is not too far IMHO. Also we talk here about openSUSE not SUSE, so that indeed may be different.