perl install Archive::Zip like going down a rabbit hole

I am configuring a new install of LEAP 42.1 to act as a backup server using the backuppc software. Since I couldn’t find backuppc in the repos, I downloaded the source code, and am installing the perl modules to make it work.

I used “YAST 2” to make sure that I am up to date. After verifying that perl is installed, I setup my system to use “cpan” to download, compile and test perl modules. I was able to install “Compress::lib” and “File::RsyncP” without problem, so I have some degree of certainty that things are running OK.

Then I tried to install “Archive::zip” and it seems to be a cascading rabbit hole of errors. “Archive::zip” requires “Test::MockModule”, “Test::MockModule” requires “SUPER”, SUPER requires “Algorithm::Diff” and so on for “Spiffy”, Text::Diff and Algorithm::Diff. At this point, I stopped to ask for advice. Am I missing something in my basic perl install, or should I keep on going “down this rabbit hole”?

I tried to include the output from trying to install Archive:Zip (it is too long for the forum. )

Many thanks,

Why not just zypper in perl-Archive-Zip…? In openSUSE we add perl-some-perl-module, so a zypper se should help.

Else if can’t find one, it may be easier to add the perl development repo and install as there are more here (plus later versions) than in the distribution…

zypper ar -f devel:languages:perl
zypper ref

Else you need to continue down the rabbit hole with cpan…

Sorry folks:
The forum software interprets “::” followed by a “Z” as an emoticon and “::” followed by “D” as a different emoticon. I didn’t fix the errors in time, so I’m posting this to help explain the strange looking text.


Thank you. That solved the problem. <whew!> I’ve got to spend some time learning zypper.

Posting computer text between CODE tags will help. It is the # button in the tool bar of the post editor.

Text::Diff and Algorithm::Diff