Perfect Suspend to RAM on Gateway LT3114u Netbook

Hello All,

If you are as frustrated as I was with the suspend to RAM not working on my Gateway LT3114u netbook with openSuse 11.2, you’re in luck. I just fixed it and it was pretty easy. I found that from a terminal or console, this command suspended to RAM and woke back up flawlessly, everytime:
#s2ram -f -a 3

so then I made that what happens when the power management profiles have the “Suspend to RAM” action chosen by editing:

/usr/lib/hal/scripts/linux/hal-system-power-suspend-linux

comment this section out:

We only support pm-utils

#if -x “/usr/sbin/pm-suspend” ] ; then

export NUM_SECONDS_TO_SLEEP=$seconds_to_sleep

/usr/sbin/pm-suspend $QUIRKS

RET=$?

#else

# TODO: add support

unsupported

#fi

and add our working command below it:

/usr/sbin/s2ram -f -a 3

edited file looks like this:

We only support pm-utils

#if -x “/usr/sbin/pm-suspend” ] ; then

export NUM_SECONDS_TO_SLEEP=$seconds_to_sleep

/usr/sbin/pm-suspend $QUIRKS

RET=$?

#else

# TODO: add support

unsupported

#fi
/usr/sbin/s2ram -f -a 3

Voila! :slight_smile: I can only take credit for all of the googling!

I hope this saves someone from spending all of the time I spent getting this working flawlessly!

Thank you, that sure helped me!With opensuse 11.2 KDE4 and a Nvidia graphics card, it’s apperently not enough to add " Option “NvAGP” “1” to /etc/X11/xorg.conf in the device section (after " Vendor name “Nvidia”).

I had to make a small alteration, though. The first time I tried with your solution all set, it also locked my system before suspending. When resuming, all went well, but after the sleeping penguin splash, I got a locked screen with an active screensaver. The unlock window did not appear when I hovered the mouse, and the screen went black. After pressing a few times ctr-alt-backspace I got the graphical login.
As a solution, in powermanagement I switched off the option " lock screen on resume" and now resume is acually working:O.

That said, I have now a working hibernate function that is not very save. Every member of my family switching power on, can access my user profile, my porn collection, star trek episodes and even worse: my tax forms. :sarcastic:

Is there a solution for this security issue, other then not using suspend and resume?

Mine is still set to require a password and it works fine, but my screensaver is the plain black screen. You may need to play around with the switches for the s2ram command to find one that works for your set up.