Peculiar GNOME / display resolution issue 13.1 upgrade


Acer Aspire 5536, 4GB RAM, 320 GB hard disk, AMD Athlon X2 64, ATI Radeon graphics.

Did a live upgrade from 12.3 to 13.1 by opting for Download first and then upgrade. Took me nearly 12 hours.

After that, GRUB option 1, i.e., standard 13.1, does not boot fully. It goes to a white screen with a sad face saying something like "something went wrong, sorry’. However, GRUB2 boots only with the Enlightenment Desktop. If I try GNOME in GRUB2, again I get the same sad face.

I notice that while Enlightenment runs under 1366X768 res, GNOME (as in option 1 of GRUB or under GRUB2) tries to boot only with 1024X768 res. I tried to change the resolution as SU in Enlightenment (for GNOME booting) to the right values (1366X768). However, when it comes to re-start, that resolution is not recognised and I have to change it to some other resolution. The machine then boots in an ungainly fashion.

There are no other issues - no loss of anything and I’m able to carry out my routine activities - albeit with an ugly desktop - without any hiccups.

While I am a long time user of SUSE, I’m still not confident enough to tinker with the boot loader in YAST.

I wonder whether I’m doomed to continue like this until the next release comes along.

Help from you smart people out there would be greatly appreciated.


And what exact gfx chip does this have?

/sbin/lspci | grep VGA

If supported (HD5xxx and up) you should try to install the fglrx driver:
openSUSE Lizards

You’re mixing things up:
GRUB1 does not exist, the entry is openSUSE 13.1
GRUB2 does exist, it’s the bootloader itself. What you’re calling GRUB2 is the openSUSE 12.3 entry, which boots OK.