PEAP Connection - Working but just barely

I’m connected to a PEAP wireless network and although it’s working it’s just barely.

I seem to be getting disconnected like every minute… most pages are very slow to load.

Trying to ping google only gives me

PING ( 56(84) bytes of data

and then it hangs.

traceroute to (, 30 hops max, 40 byte packets using UDP
 1 (  4.046 ms   1.418 ms   1.404 ms
 2 (  1.419 ms   1.417 ms   1.469 ms
 3-30  * * *

There really shouldn’t be a problem with the speed as it’s a fast network and there should be a zillion accesspoints in range. (or at least when I had WICD working it showed me like 20 of them).
I’m using openSUSE 11.1 x86_64 with KDE4.2 and the KDE3 network manager.
I’ve compat-wireless-kmp-default installed along with wpa_supplicant (wouldn’t get a connection without it I guess). Using and intel 4965AGN with the drivers.
Everything is working (at normal speeds) under Vista and my home WPA network is working flawlessly.

iwlist wlan0 scan
wlan0     Scan completed :
          Cell 01 - Address: 00:1B:8F:88:DF:B0
                    Frequency:2.412 GHz (Channel 1)
                    Quality=97/100  Signal level:-55 dBm  Noise level=-94 dBm
                    Encryption key:on
                    IE: Unknown: 0006736178696F6E
                    IE: Unknown: 01079618243048606C
                    IE: Unknown: 030101
                    IE: Unknown: 07064E4C20010D17
                    IE: Unknown: 2A0106
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : 802.1x
                    IE: Unknown: 9606004096000B00
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (1) : TKIP
                        Authentication Suites (1) : 802.1x
                    IE: Unknown: DD06004096010104
                    IE: Unknown: DD050040960305
                    IE: Unknown: DD050040960B09
                    IE: Unknown: DD050040961401
                    Bit Rates:11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                              48 Mb/s; 54 Mb/s
                    Extra: Last beacon: 76ms ago

Any additional commands I can run to provide more useful information? I’ll be using the same network again tomorrow.

Well still got the problem, tried it via LEAP as well… same result.
Connection works, but it drops out quite often and connection speed is like 5.6KB/s.