PDFs will only print one page.

My wife’s computer will only print the last page of any PDF. This is consistent across programs. I’ve tried Okular, Foxit, LibreOffice Draw, and qpdfview. This has occurred with the stock KDE version and the updates for KDE from the KDE repositories. I have the same configuration and printer drivers on my computer, and pdfs print correctly. Everything else on her computer prints correctly. I’ve disabled IPV6 as in someone’s post that was the issue, but this did not help. Does anyone have any idea why this would be happening?

Try printing to file first. Does opening the new PDF show the complete document? Does the resulting PDF file print completely as expected?

It might be interesting to examine the metadata for a couple of given ‘problematic’ PDF files…

pdfinfo /path/to/foo.pdf

The print to file was successful. All four pages were there. When I went to print the resulting file, it still printed only one page of the four. As it happens, I did make a mistake in my first post. It is not the last page that prints, but the second page. Nothing prints if the pdf is only one page.

Here is the pdfinfo from a representative file – the one I printed to file in fact. I did copy it to my computer and it printed fine. On my wife’s computer, as I said, it only printed page 2. I’m wondering if it isn’t a network issue? The printer is accessed through my network and is accessed through wifi. Both of our computers are connected by ethernet, but my wife’s computer has a wifi card and my computer does not. I do use network manager and wifi is not enabled on her computer.

Title:           bStatement - retrieveDocumentBytes.go.pdf
Producer:        GPL Ghostscript 9.52
CreationDate:    Thu Apr 14 19:54:32 2022 PDT
ModDate:         Thu Apr 14 19:54:32 2022 PDT
Custom Metadata: no
Metadata Stream: yes
Tagged:          no
UserProperties:  no
Suspects:        no
Form:            none
JavaScript:      no
Pages:           4
Encrypted:       no
Page size:       595 x 842 pts (A4)
Page rot:        0
File size:       648376 bytes
Optimized:       no
PDF version:     1.4

Can you share the printer details including the configured driver?

lpstat -t
sudo egrep -i "name|filter" /etc/cups/ppd/*

If it’s consistent across programs, couldn’t it be related to the KDE printing dialog? I assume you have checked the settings there? What if you try to choose a specific page in that dialog, or all “specifically”, i.e. “1,2,3,4”?
And, BTW, it really only happens with pdf files? Did you try other file types?

I tried this. I’ve tried to select all specifically, I’ve tried to select specific pages, etc. No luck. I get only the second page of a multipage pdf and nothing for a one page pdf.

Here are the details:


scheduler is runningno system default destination
device for Canon_MF642C_643C_644C_UFR_II: socket://
Canon_MF642C_643C_644C_UFR_II accepting requests since Fri 15 Apr 2022 11:07:47 AM PDT
printer Canon_MF642C_643C_644C_UFR_II is idle.  enabled since Fri 15 Apr 2022 11:07:47 AM PDT


/etc/cups/ppd/Canon-MF642C-643C-644C-UFR-II.ppd:*PCFileName: "CNM642ZS.PPD"/etc/cups/ppd/Canon-MF642C-643C-644C-UFR-II.ppd:*cupsFilter: "application/vnd.cups-raster 0 rastertoufr2"
/etc/cups/ppd/Canon-MF642C-643C-644C-UFR-II.ppd:*ModelName: "Canon MF642C/643C/644C UFR II"
/etc/cups/ppd/Canon-MF642C-643C-644C-UFR-II.ppd:*ShortNickName: "MF642C/643C/644C"
/etc/cups/ppd/Canon-MF642C-643C-644C-UFR-II.ppd:*NickName: "Canon MF642C/643C/644C UFR II"
/etc/cups/ppd/Canon-MF642C-643C-644C-UFR-II.ppd:*%CNGPLPLIBNAMER: "uictlufr2r"
/etc/cups/ppd/Canon-MF642C-643C-644C-UFR-II.ppd:*%CNGPLPLIBNAMERVER: "1.0.0"
/etc/cups/ppd/Canon-MF642C-643C-644C-UFR-II.ppd:*CNOEFLibName: "ufr2filterr"
/etc/cups/ppd/Canon-MF642C-643C-644C-UFR-II.ppd:*CNPrinterName: "Canon MF642C/643C/644C UFR II"
/etc/cups/ppd/Canon-MF642C-643C-644C-UFR-II.ppd:*CNGenericDatName: "Canon Generic Plus BDL CL3"
/etc/cups/ppd/Canon_MF642C_643C_644C_UFR_II.ppd:*PCFileName: "CNM642ZS.PPD"
/etc/cups/ppd/Canon_MF642C_643C_644C_UFR_II.ppd:*cupsFilter: "application/vnd.cups-raster 0 rastertoufr2"
/etc/cups/ppd/Canon_MF642C_643C_644C_UFR_II.ppd:*ModelName: "Canon MF642C/643C/644C UFR II"
/etc/cups/ppd/Canon_MF642C_643C_644C_UFR_II.ppd:*ShortNickName: "MF642C/643C/644C"
/etc/cups/ppd/Canon_MF642C_643C_644C_UFR_II.ppd:*NickName: "Canon MF642C/643C/644C UFR II"
/etc/cups/ppd/Canon_MF642C_643C_644C_UFR_II.ppd:*%CNGPLPLIBNAMER: "uictlufr2r"
/etc/cups/ppd/Canon_MF642C_643C_644C_UFR_II.ppd:*%CNGPLPLIBNAMERVER: "1.0.0"
/etc/cups/ppd/Canon_MF642C_643C_644C_UFR_II.ppd:*CNOEFLibName: "ufr2filterr"
/etc/cups/ppd/Canon_MF642C_643C_644C_UFR_II.ppd:*CNPrinterName: "Canon MF642C/643C/644C UFR II"
/etc/cups/ppd/Canon_MF642C_643C_644C_UFR_II.ppd:*CNGenericDatName: "Canon Generic Plus BDL CL3"

The above checks out ok. I’m not sure what would cause the printing to behave in the way you’re describing. I assume that it would behave the same even when USB-connected?

Any differences between the two computers (with respect to configured printer options)? Run the lpoptions command on both…

lpoptions -p Canon_MF642C_643C_644C_UFR_II -l

Check for differences in printers.conf options perhaps…

sudo cat /etc/cups/printers.conf