PDF files print tiny from Okular

Letter size and 11x17 inch files opened in Okular 0.21.3 look fine on openSuse 13.2. Printing to a Brother HL3170CDW produces really small images: 1/3 to 1/4 of desired size. Have installed the Brother driver, with CUPS.
Can’t find the “scaling” command in CUPS, Desktop Configuration/Printer, or the web interface on the printer. Found a reference to scaling among the command line options for “lp” function, but the option that stipulates the file (-t filename) just froze when I used either just the file name or the full path to the PDF file. The place to choose the printer language (PS1, PS2, PDF, etc.) also seems to have vanished.
Any suggestions on getting PDF files to print -o fit-to-page from?? After importing into GIMP the file printed to fill the page.
Just FYI: I and probably many others would appreciate a reminder of the required form to use when entering “filename” or other parameters in a command. So when you rewrite the FAQ/man page/etc. please give examples.

Check the pdf “page size” in Okular file>properties menu. My accountant always send me a site-generated pdf that, although showing correctly on screen, prints scaled down, because the paper size is larger than the printer paper. I believe this is due to an error in the way the pdf is generated, as this problem only happens with this specific government site generated pdfs, others are OK.

The only way I found to get around this is by importing the pdf into GIMP, as you did.

I was having the same problem until I found that a more easy and satisfactory way was to use the “print to file” option and print the document as a PDF, making sure the output options and paper sizes are all A4 or letter (whichever you may require). That file would then print out on a machine correctly. I think its a lot quicker than using GIMP.

I had a similar problem but “okular” print is too big (in spite it was corrected selected A4 page) and the first rows are lost, printing with “document viewer” print is ok.

Great tip, thanks!