PDF driver for printing refuses to print landscape properly

OpenSUSE 11.4 x64 with all the cups, proppler and pdf applications and libraries from OpenSUSE and OpenSUSE update repo. I have got following bug: Anytime I have tried to print a landscape from any application with the pdf driver chosen I received a portrait printed paper, it looks like printer has tried to prints a landscape on portrait orientated paper . If I chose any of the postscript drivers from printer dialog I get properly printed landscape on the paper. I tried with three different printers - the same result. So obviously there is some problem with the pdf driver. The pdf driver is by default printing driver and it prints far more quickly then the postscript ones. If anyone have idea how to fix the pdf landscape printing problem, please share. :\

I’m guessing this is about a HP printer, since I’ve met this problem last week too. No solution found yet, actually currently looking for one. The postscript drivers work OK, don’t they.

On the post itself: if I would not have met this problem myself, I would never have guessed. Please teach yourself to give as much info as you can: printer brand, model, driver+version used etc.

I’m having trouble with the forum today; hope this isn’t a double post.

I had the same problem with 12.1 and an HP Officejet. However, I was trying to print from the web. I downloaded the pdf to save it until I could fix the problem. When I opened it locally, it printed properly. Okular is my default pdf reader.

olegue wrote:

>
> OpenSUSE 11.4 x64 with all the cups, proppler and pdf applications and
> libraries from OpenSUSE and OpenSUSE update repo. I have got following
> bug: Anytime I have tried to print a landscape from any application with
> the pdf driver chosen I received a portrait printed paper, it looks like
> printer has tried to prints a landscape on portrait orientated paper .
> If I chose any of the postscript drivers from printer dialog I get
> properly printed landscape on the paper. I tried with three different
> printers - the same result. So obviously there is some problem with the
> pdf driver. The pdf driver is by default printing driver and it prints
> far more quickly then the postscript ones. If anyone have idea how to
> fix the pdf landscape printing problem, please share. :
>
>
> –
> olegue
> ------------------------------------------------------------------------
> olegue’s Profile: http://forums.opensuse.org/member.php?userid=19551
> View this thread: http://forums.opensuse.org/showthread.php?t=475434

Try exporting to .pdf and print with your PDF reader
Works for me

The problem/bug is in the HP driver, HP already knows. Search for “HP linux driver PDF landscape” and you’ll find threads about it. The problem is visible in the printer properties, the driver does the output through pdf, instead of postscript. For now, I fixed the printer setttings in the default template for LO, but IMHO that’s just a workaround, that should be temporarily.

On 2012-05-20 20:56, Knurpht wrote:
> The
> problem is visible in the printer properties, the driver does the output
> through pdf, instead of postscript.

I wonder what is the advantage of using pdf for the driver. I have an HP
printer, and what it understand is postscript, not pdf.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

That’s what I’ve been wondering too. And, it’s not there for all HP printers, until now I’ve only seen it with Laserjets and Officejets. IMHO, if there’s an option, one should be able to set it in the driver options, but nothing found so far.

Assuming you are using KDE, I suspect the problem is nothing to do with the printer but with the KDE4 backend. I have never got PDF landscape printing to work properly in KDE4; but if you download KPDF (kdegraphics3-pdf) from software.opensuse.org, you will have no problems printing landscape PDFs on an HP printer.

This is not about being able to print PDF in landscape, it’s about printing in landscape anyway since the default driver setting is to use PDF as a printer language instead of postscript. I can print any doc the way I like on those printers, point is that this needs manual interference by setting the device driver to use postscript. Setting this in the a default applied template in LibreOffice works around it.

I must respectfully disagee. I can print in landscape in LibreOffice and in KPDF without any problems. The only problems I encounter come when asking KDE4 applications to print in landscape.

Actually the problem is same for a HP printer and a Samsung printer. That made me think that the issue is not with the printers themselves, perhaps some library all the printer use.

I also have tried with saving in pdf and printing then. I tried Okular, Adobe Acrobat, Cups-PDF - there is no difference, the problem is still on. Switching to postscript as a printing language everything is oki in any application.


Actually I am in Gnome, but the problem is general nevertheless where I log in KDE4 or Gnome. In previous OpenSuse 9.xx - 11.3 there were never such problem and I have printed hundred of times landscapes. As I remember in KDE3 there was a possibilities to make lots a setting for printing in Kcontrol, and to choose default printing language. But now there no such setting section in systemsettings for KDE4. Gnome printer setting also misses option for setting default printing language.

The problem with LibreOffice is https://bugs.freedesktop.org/show_bug.cgi?id=44664, and comments in that bug mention HP, Samsung, Brother, and Fuji printers.

The problem with Okular is 181290 – Landscape pdf prints with wrong orientation when choosing landscape in print dialog, tracked here as Access Denied. That was supposedly fixed in KDE 4.8 and the fix backported to 12.1, but not 11.4.

What I’m curious about in this thread is all the people reporting changing the default printer language to postscript as a solution for apps other than LibreOffice. On my system (oS 11.4, KDE 4.6), LibreOffice is the only app where I can see an option to select the printer language at all. I have an HP Laserjet P2035, and neither the HP Device Manager nor CUPS has any place that I can find that says anything about the default printer language. Where, exactly, are all of you changing this outside of LibreOffice?