PCSX2 Issues (32-bit Emulator on 64-bit Leap)

Hey. I’m in the process of seeing if I could migrate from Fedora to openSUSE. I have everything set up except PCSX2.

I have tried installing PCSX2 from the Packman repository, but it does not work. The description says “Use i586 version,” though there is no i586 version available for Leap. I’ve tried using the i586 version from openSUSE 13.2, which installs, but then doesn’t work because the version of wxWidgets that it was compiled with is slightly different than the one in Leap. Trying to install the 32-bit wxWidgets libraries from openSUSE 13.2 with “rpm -ivh” presents another issue, where it says the “x86_84” version is newer, thus doesn’t install, and also says that the files conflict as the 64-bit version installed the libraries where the 32-bit version wants to.

I have also tried any of the releases in the build service, such as the one in the home: X0F:branches:Emulators. There is no PCSX2-32bit package available for Leap, and the one form 13.2 presents the issue with a different version of wxWidgets as mentioned above.

I lastly have resorted to compiling the emulator, which is what I did on Fedora, but haven’t been able to locate the needed “devel” packages for the 32-bit libraries.

If anybody has had any luck getting PCSX2 to work on openSUSE Leap, please let me know, whether it is via building it or if they have an RPM. I’m also willing to learn how to get this to work if anyone has any suggestions! I will also be posting on the PCSX2 Linux forum, so I will update this thread if I get anything back from that.


So the latest git version isn’t building for 32bit anyway…

Best to raise a bug…

Or try this one;


You should install the corresponding libxxx-32bit packages, not the i586 libxxx packages.

I have no idea whether the 13.2 packages will work then though.

Sorry, I should have been for clear. The “libxxx-32bit” packages work fine for all of the libraries except libwx libraries. They have to be the same version that the program was compiled with, at least in the case of PCSX2, as that is the error I receive upon running PCSX2-32bit from X0F:branches:Emulators (not sure about ALL wx programs). Thanks for the reply!

So the latest git version isn’t building for 32bit anyway…

Best to raise a bug…

Or try this one;


Thanks you for the reply. I may try and raise a bug with Packman. Appreciate it. :slight_smile: Hope to be a future openSUSE user, it’s quite lovely.

Yes, but that should be the case if you install the 13.2 PCSX2 package and the 13.2 libwx*-32bit packages.

The 32bit libraries should not conflict with the 64bit ones.

Although as I wrote, using the 13.2 packages on Leap 42.1 might not work at all or might require some more 13.2 32bit packages.

My bad, I get what you’re saying! Didn’t think of that, will try and I’ll get back to you. Thank you :slight_smile:

Tried to edit my previous post, but I was a minute too late beating the ten minute edit period! lol

Went ahead and did what your suggested, but I’m still getting the same error as I received when I used the “libxxx-32bit” packages that are in Leap’s repos. I double checked that they are the versions from 13.2. Seems a little odd, unless I’m reading something incorrectly. The error:

[QUOTElinux-4vuk:/home/cameron/Downloads # PCSX2
Fatal Error: Mismatch between the program and library build versions detected.
The library used 2.8 (no debug,Unicode,compiler with C++ ABI 1002,STL containers,compatible with 2.6),
and your program used 2.8 (no debug,Unicode,compiler with C++ ABI 1009,STL containers,compatible with 2.6).

Maybe the person who built this rpm of PCSX2 for 13.2 (the build linked above) used their own version of libwx?

Regardless, I will try and raise a bug report! Thanks for the suggestion.