Pc speaker doesn't work anymore in 11.2

Hi, I’ve installed opensuse 11.2 recently and the pc speaker doesn’t seem to work since I can’t hear anything by typing the command “beep”.

I’ve also compiled and installed beep from here and compiled it with make.

The steps I did to install it were:

ivan@ivan-molina:~> tar -zxvf beep-1.2.2.tar.gz
ivan@ivan-molina:~> cd beep-1.2.2
ivan@ivan-molina:~> make
ivan@ivan-molina:~> sudo install -m 4755 beep /usr/bin/beeper

Then when I type “beeper” or “beep” no sound comes at all. I can’t hear any beep. Passing some parameter to it like “beeper -f 800 -l 200” doesn’t help either. :frowning:

Anyone known what file should I change to enable the pc speaker again? In 11.1 it worked flawlessly following those steps. :\

Any help would be appreaciated! :wink:

By the way, the device listed by lspci is this:

Audio device: VIA Technologies, Inc. VT1708/A [Azalia HDAC] (VIA High Definition Audio Controller) (rev 10)

the module used seems to be snd_hda_intel as shown by:

ivan-molina:~ # lsmod|grep snd
snd_pcm_oss 51616 0
snd_mixer_oss 19072 1 snd_pcm_oss
snd_seq 64752 0
snd_seq_device 8620 1 snd_seq
snd_hda_codec_realtek 233604 1
snd_hda_intel 31584 2
snd_hda_codec 94688 2 snd_hda_codec_realtek,snd_hda_intel
snd_hwdep 8708 1 snd_hda_codec
snd_pcm 96324 3 snd_pcm_oss,snd_hda_intel,snd_hda_codec
snd_timer 25960 2 snd_seq,snd_pcm
snd 75236 14 snd_pcm_oss,snd_mixer_oss,snd_seq,snd_seq_device,snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer
snd_page_alloc 10600 2 snd_hda_intel,snd_pcm
iv

A silly question , but did you make certain the “beep” setting in your mixer is not muted? I also note in some cases it does not work for a regular user but it DOES work if run with root permissions. The readme gives an explanation.

Just to clarify, I’ve never used this program before.

So I compiled it on my 64-bit openSUSE-11.1 KDE-3.5.10 (asus P6T deluxe V2 motherboard w/Intel Core i7 920 processor) and it worked only with root permissions, and only when “beep” setting in kmix was unmuted.

I then complied it on my new 32-bit openSUSE-11.2 KDE-4.3.2 install on my sandbox PC (athlon-1100 cpu on an old KT3 Ultra motherboard), and it once gain worked ONLY with root permissions, and only when “PC speaker” setting kmix was unmuted.

I’m using opensuse 11.2 with gnome. There’s no kde nor kmix installed. When i start alsamixer, only the master slider and the microphone slider appear. There are no controls to unmute the “beep”.

In 11.1 this used to work, as a matter of fact, I could run it with any user, because the suid flag is on as set by this command:

sudo install -m 4755 beep /usr/bin/beeper

Well, i’ll try in my home pc, because those results were from my job’s workstation. By the way, running it as root didn’t work either (no beeps)

Thanks for your help!

how about controls in amixer?

I assume amixer is also in 11.2.

With your PC connected to the internet what is the output of typing as a regular user in you /home/username directory:

amixer > amixer.txt && curl -F file=@amixer.txt nopaste.com/a

And post here the URL it gives. Does that show more mixer controls than what you just quoted as seeing in alsaxmixer?

I obtained a simple beep with:

su -c 'beep -f 200 -f 300'

ivan@ivan:~> amixer > amixer.txt && curl -F file=@amixer.txt nopaste.com/a
curl: (7) couldn’t connect to host

ivan@ivan:~> cat amixer.txt
Simple mixer control ‘Master’,0
Capabilities: pvolume pswitch pswitch-joined
Playback channels: Front Left - Front Right
Limits: Playback 0 - 65536
Mono:
Front Left: Playback 41350 [63%] [on]
Front Right: Playback 41350 [63%] [on]
Simple mixer control ‘Capture’,0
Capabilities: cvolume cswitch cswitch-joined
Capture channels: Front Left - Front Right
Limits: Capture 0 - 65536
Front Left: Capture 46396 [71%] [on]
Front Right: Capture 46396 [71%] [on]
ivan@ivan:~>

And I have connection to internet. (This post is the proof ;))

By the way, the command:
su -c ‘beep -f 200 -f 300’
throws a “command not found” message. The weird thing is that changing to root:
su -
and then typing:
beep
doesn’t throw that error.

Nopaste.com is down currently.

I can’t help you any further. It works on my PC. It does not on yours. I can not explain why.

I do think the output you pasted from amixer is WAY TOO LITTLE. Strange.

Well, thanks anyway. I know This is driving me nuts. The gnome terminal doesn’t beep either when I press backspace when I haven’t typed anything. I’ve enabled the beep bell in ~/.inputrc:

set bell-style audible

and enabled it in compiz-fusion options by enabling the audible beep in general options->general tab.

The weirdest thing is that the only time that the beep is actually heard is when pressing Ctrl+Alt+Backspace twice to restart X. :O. I know there must be some file to change so the beep sound comes back :\

If anyone is interested why I’m bothering with the pc speaker it’s because I’m building a sdlmame cabinet so when the pc is running the init scripts I put some beeps in those scripts to know how much is left for the cabinet to start the menu.

I guess I’ll have to stick with the front speakers and use aplay in the scripts (cups, rc.local and such) to know how much is left to show the menu. The question is at which script the sound module is active to play those sounds with aplay. (S07alsasound seems to be the candidate).

Thanks for all your patience ;). At least I can say proudly that all of you guys did an excellent job fixing sound issues, specially the ones related with choppy/cranky sound. Now the sound is clear and smooth in mame and in a program I made that uses sdl-mixer libs. the sound comes clear with no clicks

This is annoying me … like a scratch on the back of the head.

In terminal with regular user permissions, in the /home/user directory, please type:
amixer > amixer.txt
and then open amixer.txt and post the entire output here or put on a pastebin site such as pastebin - Type, paste, share. and post here the URL

I simply can NOT believe you obtained such a small amixer output.

same thing. With the difference that now i messed with the volume in the gnome volume applet and upped the master to 100%

ivan@ivan:~> amixer > amixer.txt
ivan@ivan:~> cat amixer.txt
Simple mixer control ‘Master’,0
Capabilities: pvolume pswitch pswitch-joined
Playback channels: Front Left - Front Right
Limits: Playback 0 - 65536
Mono:
Front Left: Playback 65536 [100%] [on]
Front Right: Playback 65536 [100%] [on]
Simple mixer control ‘Capture’,0
Capabilities: cvolume cswitch cswitch-joined
Capture channels: Front Left - Front Right
Limits: Capture 0 - 65536
Front Left: Capture 46396 [71%] [on]
Front Right: Capture 46396 [71%] [on]
ivan@ivan:~>

The same 13 lines.

I forgot to say that I’m using my home pc, and it has this sound card:

ivan:~ # lspci|grep -i audio
00:09.0 Audio device: nVidia Corporation MCP73 High Definition Audio (rev a1)

and this seems to be the sound module loaded:

ivan:~ # lsmod|grep force
**forcedeth 62092 0 **
i2c_nforce2 8356 0
i2c_core 32308 2 nvidia,i2c_nforce2

The mobo is an ECS GF7050VT-M v1.0

I wonder what could be the problem. I know that in some sound cards, the pc speaker sound doesn’t come from the pc speaker itself but from the front speakers instead (sort of a “simulated” pc speaker). That case happened to me with my job’s pc which had a VIA chipset (the one posted above). Well, in my home’s pc it’s not the case because I upped the volume of my speakers and there’s no beep coming through them when i type beep as root.

I noticed you did all the tests in Opensuse with KDE as the window manager. What could be the difference between that and gnome other than the presence of kmix?

Thanks! :slight_smile:

This still does NOT look right to me. … Was that the same mixer options you had in the previous openSUSE release with this PC ?

I’m wondering, could this be the first 11.2 audio problem that I have encountered ? :slight_smile: 11.2 is so good for hardware audio detection, that I’ve been feeling “out of work” as a volunteer for helping users with basic sound problems. :cry:

Please, could you humour me, while we check to ensure your hardware autoprobe was correctly done upon 11.2 boot ?

Please run the following script, with your pc connected to the internet, and also select the “share/upload” option when prompted, and then when the script is complete, please post here the URL that it provides.
/usr/sbin/alsa-info.sh

Please also provide the output of:
rpm -qa ‘alsa
rpm -qa ‘pluse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/50-sound.conf

http://www.alsa-project.org/db/?f=da9aa7dfcac4387767ec998addaead79922bfcd0

alsa-utils-1.0.21-3.1.i586
alsa-plugins-1.0.21-3.3.i586
alsa-1.0.21-3.2.i586
alsa-oss-1.0.17-25.2.i586
alsa-plugins-pulse-1.0.21-3.3.i586
alsa-devel-1.0.21-3.2.i586

You meant “rpm -qa ‘pulse’”?

libpulse-mainloop-glib0-0.9.19-2.3.i586
pulseaudio-module-lirc-0.9.19-2.3.i586
pulseaudio-0.9.19-2.3.i586
libpulse0-0.9.19-2.3.i586
alsa-plugins-pulse-1.0.21-3.3.i586
pulseaudio-module-bluetooth-0.9.19-2.3.i586
pulseaudio-module-gconf-0.9.19-2.3.i586
libpulse-browse0-0.9.19-2.3.i586
pulseaudio-module-x11-0.9.19-2.3.i586
pulseaudio-module-zeroconf-0.9.19-2.3.i586
pulseaudio-utils-0.9.19-2.3.i586

libasound2-1.0.21-3.2.i586

Linux ivan 2.6.31.5-0.1-default #1 SMP 2009-10-26 15:49:03 +0100 i686 i686 i386 GNU/Linux

options snd slots=snd-hda-intel

WL76.vaWu4qEoKF7:MCP73 High Definition Audio

alias snd-card-0 snd-hda-intel**

thankyou.

hmmm no alsa-firmware. Probably because its not needed.

Yes, thankyou.

Ok, this gives a MUCH better amixer output:

!!Amixer output
!!-------------

!!-------Mixer controls for card 0 [NVidia]

Card hw:0 'NVidia'/'HDA NVidia at 0xfebf8000 irq 22'
  Mixer name	: 'SigmaTel STAC9221 A2'
  Components	: 'HDA:83847682,10192813,00103601'
  Controls      : 20
  Simple ctrls  : 13
Simple mixer control 'Master',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 64
  Mono: Playback 64 [100%] [0.00dB] [on]
Simple mixer control 'Speaker',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 64
  Mono:
  Front Left: Playback 64 [100%] [0.00dB] [on]
  Front Right: Playback 64 [100%] [0.00dB] [on]
Simple mixer control 'PCM',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Mono:
  Front Left: Playback 255 [100%] [0.00dB]
  Front Right: Playback 255 [100%] [0.00dB]
Simple mixer control 'Front Mic Jack Mode',0
  Capabilities: enum
  Items: 'Mic In' 'Line In'
  Item0: 'Mic In'
Simple mixer control 'Mic Jack Mode',0
  Capabilities: enum
  Items: 'Mic In' 'Line In'
  Item0: 'Mic In'
Simple mixer control 'IEC958',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'IEC958 Default PCM',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 14
  Front Left: Capture 8 [57%] [12.00dB] [on]
  Front Right: Capture 8 [57%] [12.00dB] [on]
Simple mixer control 'Capture',1
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 14
  Front Left: Capture 0 [0%] [0.00dB] [off]
  Front Right: Capture 0 [0%] [0.00dB] [off]
Simple mixer control 'Input Source',0
  Capabilities: cenum
  Items: 'Mic' 'Front Mic' 'Line' 'CD'
  Item0: 'Mic'
Simple mixer control 'Input Source',1
  Capabilities: cenum
  Items: 'Mic' 'Front Mic' 'Line' 'CD'
  Item0: 'Mic'
Simple mixer control 'Mux',0
  Capabilities: cvolume
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 2
  Front Left: Capture 0 [0%] [0.00dB]
  Front Right: Capture 0 [0%] [0.00dB]
Simple mixer control 'Mux',1
  Capabilities: cvolume
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 4
  Front Left: Capture 0 [0%] [0.00dB]
  Front Right: Capture 0 [0%] [0.00dB]

I can not understand why amixer > amixer.txt did not give the same as the above. :\ Still, I see no reference above to a “pc speaker” nor to a “beep” control.

As you note:

Manufacturer:      ECS
Product Name:      GF7050VT-M

You could try to see if forcing your alsa to a different configuration at boot (other than that chosen by the auto probe) helps. Here is a list of the options for the stac9221 (which is what your ECS PC has) from 1.0.21 of alsa’s hd-audio-models.txt file:

STAC9220/9221
=============
  ref		Reference board
  3stack	D945 3stack
  5stack	D945 5stack + SPDIF
  intel-mac-v1	Intel Mac Type 1
  intel-mac-v2	Intel Mac Type 2
  intel-mac-v3	Intel Mac Type 3
  intel-mac-v4	Intel Mac Type 4
  intel-mac-v5	Intel Mac Type 5
  intel-mac-auto Intel Mac (detect type according to subsystem id)
  macmini	Intel Mac Mini (equivalent with type 3)
  macbook	Intel Mac Book (eq. type 5)
  macbook-pro-v1 Intel Mac Book Pro 1st generation (eq. type 3)
  macbook-pro	Intel Mac Book Pro 2nd generation (eq. type 3)
  imac-intel	Intel iMac (eq. type 2)
  imac-intel-20	Intel iMac (newer version) (eq. type 3)
  ecs202	ECS/PC chips
  dell-d81	Dell (unknown)
  dell-d82	Dell (unknown)
  dell-m81	Dell (unknown)
  dell-m82	Dell XPS M1210
  auto		BIOS setup (default)

Lets say you decided to try “ecs202” model option. Then to apply that you need to edit the /etc/modprobe.d/50-sound.conf file, adding a line to the start such that it reads:

options snd-hda-intel model=ecs202
options snd slots=snd-hda-intel
# WL76.vaWu4qEoKF7:MCP73 High Definition Audio
alias snd-card-0 snd-hda-intel

save the change, and then restart the alsa sound driver with su -c ‘rcalsasound restart’ and restart your mixer (kmix in kde and alsamixer in gnome) and test the audio, and check the mixer options.

Note you can only apply ONE model option at a time. So if you wished to try “3stack” you would need to replace “ecs202” in the /etc/modprobe.d/50-sound.conf file with “3stack”. And then restart alsa, restart mixer, and test.

But the odds are 11.2 correctly identifies your card and the above edits are not likely to help.

Hi, I’ve tried adding the line:
options snd-hda-intel model=3stack
to /etc/modprobe.d/50-sound.conf
and then restarting alsa sound driver (in a root shell)
rcalsasound restart
and it restarted correctly.

I’ve tried also with
options snd-hda-intel model=5stack
and
options snd-hda-intel model=ecs202

with no avail. The beep doesn’t come and it doesn’t appear in the controls of alsamixer.

Unfortunately, I didn’t write down all these setting when I was using 11.1 (where it DID work).

Is there an option to boot the opensuse 11.1 DVD as a live DVD? Because it would be such a pain in the *** to reinstall the whole opensuse 11.1 just to test that single feature.

Again, thanks for your patience.
I’m waiting your comments.

No there is not.

Hi, I’ve compiled the program again (beep1.2.2) and run it as root and now it worked :O. I’ve succesfully installed it with the command:
install -m 4755 beep /usr/bin/beeper
inside the beeper1.2.2 folder extracted with tar

I’ve tested the “beeper” command as a normal user and now it works. I’ve no explanation how this happened. Maybe something I messed with in the previous posts, like:

Now the beep comes just by typing “beeper” as a normal user. Finally! At last!!:smile:

Well, I’ll be glad to post details of any config file which may have made the difference.

Thanks for all of you for your patience! :wink: