Pc is frozen after reboot

Hi :wink:

I’m trying to help some friends that are far away, config is pentium D and nvidia 7300 , plus 1 gb of ram ;
ok they had an 11.2 opensuse version and installed 11.4 from a cd (or dvd) they bought in a shop , the pc is working ok, but upgrades are NOT , how come ? This looks stange to me :frowning:

  • in init 3 : zypper cc && zypper ref && zypper up does not work : after reboot using “shutdown -r now” the pc is frozen, with the green screen and white lizard (no access to keyboard, nor to grub options), ctrl+ alt+ f1 is ko for example.

  • in init 3 and only with 3 repos (oss, non-oss, and update of 11.4) a zypper dup works but a bug with mozilla firefox 4 brading opensuse which is ko .
    we continued , can one package break down a zypper dup ? ( same ko result : after reboot usinf shutdown -r now the pc is frozen with the green screen and white lizard (no access to keyboard, nor to grub options) )

What do you think can be the problem ?

Thanks ;=)

So, in general I do not personally recommend doing a “upgrade”, but suggest you do a clean install. Upgrades can create some very odd problems. If you maintained a separate /home area, do not format it, but mount it only. This requires an edit of the default partitioning setup. A clean install will make sure all installed programs work together while an existing /home area allows personnel settings to remain. When reading your message I was confused as to when the upgrade was occurring, from a store purchased DVD or from an online connection? Normally, I would use the DVD to perform a clean install and then using YaST, do an online update of existing software which is not the same as upgrading 11.2 to 11.4. Anyway, a slight clarification might be helpful to know what you were trying to do. And, I do wish you well in this endeavor.

Thank You,

No, YaST is clever enough to recognize an existing /home and will not format it by default - one should check that to make sure, though.

I agree that a jump from 11.2 to 11.4 has many potential traps, so one should do a fresh install.

on a machine like that i would NOT recommend opensuse

it dose tend to be a bit on the bloated side
i tried on a box a bit older that your pen D and 7300 card . A p4 gforce2 mx400 and 1 gig ram ( opensuse 11.2 gnome)
opining my home folder took 15 to 20 sec from the desktop - NEW install no files in home other that the OS. Other folders 30 sec and /usr/lib & /use/bin ??? 5 to 10 min.
and boot was about 5 min.

As to upgrading from 11.2 to 11.4 - not recommended .But already done and stuck
**you DID make back ups of important files ? right ? ** Before the upgrade was attempted .
if not do that NOW .
I would recommend a clean new install and reinstall personal data from back up .

but Arch or ScientificLinux6.1 or cent6.0 would work well on that computer
Arch probably the best .

It is a new install of 11.4 , with the dvd they bought in a shop.

Then in 11.4 zypper up and zypper dup seems ok, But pc is frozen after reboot , as described above :frowning:

ok so it is a clean install and also NOT a 100% freeze up the terminal (tty ) works
and you can text login
the boot log error would help
did you by chance install "midnight commander " dought it
ok then


cd /var/log 
ls
nano boot.log

the same for “Xorg.0.log” & " messages"

1st : the pc works.

2d : after zypper cc, zypper ref and zypper up from init 3 ( 4 repos : oss, non oss, update and packman ) i reboot the pc , and then it does not work at all : no access to keyboard at all, i thus can’t give you any log .

Reinstall makes it work again.

Another try with zypper dup and 3 repos from init 3 (oss, non oss, update ) produces the same result : after reboot the pc is frozen.
then it does not work at all : no access to keyboard at all, i thus can’t give you any log

So i have a running pc with 11.4 but each trial to update packages breaks it and makes it unusable :frowning:

Maybe you can. In some cases the last two log entries are kept. For example /var/log/messages has multiple boots in the log. It does not get cleaned every boot. And /var/log/Xorg.0.log.old has the previous boot.

Please post any logs to http://susepaste.org and post here the web site URL/address.

i’ll ask my friends, but they 're away now, so at the end of the month i hope .

hello ;=)

ok, here are the links for the logs asked above :

log messages - Pastebin.com

linux-i2zu:/home/gregory # cat /var/log/Xorg.0.log.old [ 24.724] X.Org X S - Pastebin.com

I note this in the /var/log/Xorg.0.log.old file:


    24.732] Current Operating System: Linux linux-i2zu 2.6.37.1-1.2-desktop #1 SMP PREEMPT 2011-02-21 10:34:10 +0100 i686
.........
    24.732] Kernel command line: root=/dev/disk/by-id/ata-ST3200827AS_4ND4DWBN-part5 resume=/dev/disk/by-id/ata-ST3200827AS_4ND4DWBN-part1 splash=silent quiet vga=0x31a
.........
    24.758] (II) LoadModule: "nvidia"
    24.765] (WW) Warning, couldn't open module nvidia
    24.765] (II) UnloadModule: "nvidia"
    24.765] (EE) Failed to load module "nvidia" (module does not exist, 0)
........
    24.795] (--) NOUVEAU(0): Chipset: "NVIDIA NV46"
..........

    25.229] (EE) ioctl EVIOCGNAME failed: Inappropriate ioctl for device
    25.235] (II) UnloadModule: "evdev"
    25.235] (EE) PreInit returned NULL for "ImPS/2 Generic Wheel Mouse"

ie they have not updated to the latest 2.6.37.6 kernel. The nouveau driver is loading. There was a failed attempt to load the nvidia driver. Why is that ? Did someone try unsuccessfully to install the nvidia driver and then forgot to clean up afterward when the attempt failed ?

What is a NVIDIA NV46? I saw one link suggesting it is a GeForce 6600 but then other surfing suggested it also a 7300. I saw others had a problem with the nouveau grahic driver and the NV46: Nouveau development (Reverse engineered NVIDIA driver for X) ()

and one user suggested if you use this boot code it should work with the nouveau driver:


nouveau.noaccel=1

Give that a try and let us know ! :slight_smile:

There are also a LOT of temperture related entries in the /var/log/messages file which could mean the CPU fan and heat sink need to be cleaned !

I also note a keyboard error at the end of the /var/log/Xorg.0.log.old file:


    25.229] (EE) ioctl EVIOCGNAME failed: Inappropriate ioctl for device
    25.235] (II) UnloadModule: "evdev"

and I don’t know the solution for that. Likely one may need to surf on it.

This is interesting, but how do i add the boot code for it to stay all the time ? ( nouveau.noaccel=1 )
Thanks :wink:

The boot code entries are stored in /boot/grub/menu.lst file. One must be PRECISE in where they make the entry, else one may break the computer’s capability to boot any OS. The problem with doing a hand edit to that file is the edit may be lost the next time there is a kernel update.

One can also add the boot code via YaST > System > Boot Loader > (select the openSUSE boot) > Edit … and add the boot code under ‘Optional Kernel Command Line parameters’ after the ‘showopts’ . That theoretically should survive a kernel update.

But DON’T add that boot code via YaST nor via a menu.lst file edit unless one knows for certain it will work.