pavucontrol is failing with symbol lookup error

I am using 13.2 on an x86_64 machine. I install updates each week. Since a week or so ago, I have lost sound from the headphone jack, though sound is working fine from the built-in speakers. When I attempt to run pavucontrol from the menu, it never starts up now. If I attempt to run it from the keyboard, it fails with the message:


 pavucontrol: symbol lookup error: /usr/lib64/libgtkmm-3.0.so.1: undefined symbol: gtk_stack_sidebar_get_type

When I run

zypper info pavucontrol

I get

Loading repository data...
Reading installed packages...


Information for package pavucontrol:
------------------------------------
Repository: openSUSE:Factory
Name: pavucontrol
Version: 3.0-1.1
Arch: x86_64
Vendor: openSUSE
Installed: Yes
Status: up-to-date
Installed Size: 416.4 KiB
Summary: PulseAudio Volume Control
Description: 
  PulseAudio Volume Control (pavucontrol) is a simple GTK based volume
  control tool ("mixer") for the PulseAudio sound server. In contrast to
  classic mixer tools this one allows you to control both the volume of
  hardware devices and of each playback stream separately.

I am using 13.2 on an x86_64 machine.

And why pavucontrol from factory?

Information for package pavucontrol:

Repository: openSUSE:Factory
Name: pavucontrol
Version: 3.0-1.1
Arch: x86_64

Post:

zypper lr -uP
# zypper lr -uP
#  | Alias                               | Name                                                   | Enabled | Refresh | Priority | URI                                                                       
---+-------------------------------------+--------------------------------------------------------+---------+---------+----------+---------------------------------------------------------------------------
 1 | editors                             | Text editors and hex editors for Linux (openSUSE_13.2) | Yes     | No      |   99     | http://download.opensuse.org/repositories/editors/openSUSE_13.2/          
 2 | http-download.opensuse.org-1878664e | Mono:Factory                                           | Yes     | Yes     |   99     | http://download.opensuse.org/repositories/Mono:/Factory/openSUSE_13.2/    
 3 | openSUSE-13.2-0                     | openSUSE-13.2-0                                        | No      | No      |   99     | cd:///?devices=/dev/disk/by-id/ata-TSSTcorp_CDDVDW_SU-208DB_R93W6YFD800V0J
 4 | openSUSE:Factory                    | openSUSE:Factory                                       | Yes     | Yes     |   99     | http://download.opensuse.org/factory/repo/oss/                            
 5 | packman-essentials                  | packman-essentials                                     | Yes     | Yes     |   99     | http://packman.inode.at/suse/openSUSE_13.2/Essentials/                    
 6 | packman-multimedia                  | packman-multimedia                                     | Yes     | Yes     |   99     | http://packman.inode.at/suse/openSUSE_13.2/Multimedia/                    
 7 | repo-debug                          | openSUSE-13.2-Debug                                    | No      | Yes     |   99     | http://download.opensuse.org/debug/distribution/13.2/repo/oss/            
 8 | repo-debug-update                   | openSUSE-13.2-Update-Debug                             | No      | Yes     |   99     | http://download.opensuse.org/debug/update/13.2/                           
 9 | repo-debug-update-non-oss           | openSUSE-13.2-Update-Debug-Non-Oss                     | No      | Yes     |   99     | http://download.opensuse.org/debug/update/13.2-non-oss/                   
10 | repo-non-oss                        | openSUSE-13.2-Non-Oss                                  | Yes     | Yes     |   99     | http://download.opensuse.org/distribution/13.2/repo/non-oss/              
11 | repo-oss                            | openSUSE-13.2-Oss                                      | Yes     | Yes     |   99     | http://download.opensuse.org/distribution/13.2/repo/oss/                  
12 | repo-source                         | openSUSE-13.2-Source                                   | No      | Yes     |   99     | http://download.opensuse.org/source/distribution/13.2/repo/oss/           
13 | repo-update                         | openSUSE-13.2-Update                                   | Yes     | Yes     |   99     | http://download.opensuse.org/update/13.2/                                 
14 | repo-update-non-oss                 | openSUSE-13.2-Update-Non-Oss                           | Yes     | Yes     |   99     | http://download.opensuse.org/update/13.2-non-oss/       

4 | openSUSE:Factory | openSUSE:Factory | Yes | Yes | 99 | http://download.opensuse.org/factory/repo/oss/

Delete this Repo as root with:

zypper rr openSUSE:Factory

And than

zypper dup

restart your PC.

Thanks for the advice. I successfully did the “zypper rr” command. I am having trouble with the “zypper dup” step. It downloaded 2569 packages and started installing them. It stopped at 569 (kernel-desktop <100%>) .
After waiting for several hours, I did a Control-C and terminated the task.

I checked disk usage and /dev/sda7 is sitting at 86%. I removed most files from /tmp. Then I issued another “zypper dup” but this time it only got as far as around 59 (grub2) before stopping.

I did another Control-C and killed the step.

I thought I would need to reboot to get past the problem but I cannot logout. I closed the root process where I was running zypper to see if that was preventing my logout, but it made no difference. Now when I issue a “su” command, it requests a password but does not give me a command prompt. I tried to run YaST but it also does not get past the root password prompt.

Should I force a hard reboot, or do you have any other advice on how to progress? I fear that a hard reboot might not come up at all. I am still successfully logged in as myself.

you have a total mess. It is doubtful that you will be able to reboot.

Mixing packages from factory is really really not a thing you want to do. You apparently go a lot from factory

Try logging out and back in that will restart some packages. Then try the zypper dup again. If still nothing you can try a reboot if that fails try a boot to the previous kernel in the advanced boot section.

With that many packages you may be out of space the default is to download them all then install them all so simply clearing temp does not really help since the RPMs are sitting in the machine waiting to be installed.

If it were me I’d reinstall (not reformatting home) and put a postit note on the monitor saying “never ever add the factory repo”

You can probably fix things but unless you have the knowledge you will have to ask for help here and that can take some time. Up to you we are happy to help but expect a good long time to get it back to correct working.

As you might have gathered, I am new to OpenSuSE. I have used Fedora for more than a decade, but when sound and external graphics and Suspend/Resume would not work on a new machine that I bought, and after waiting fruitlessly for 12 months for a response from their support team, I tried out OpenSuSE and found that everything works well on OpenSuSE. And when I did hit a few problems, people were able to help me quickly around the problem.

I really appreciate your help and advice. I will try to install afresh without reformatting home. That seems the simplest solution now.

I have re-installed 13.2 without loss of my data. However, I now have no sound at all. There must be something that I have missed in the installation. I swapped the two audio devices so that the analog one is number zero. I have pavucontrol working but it does not see the output device at all, just “Dummy Output”. There is no /proc/asound directory.

The /etc/modprobe.d/50-sound.conf file contains

options snd slots=snd-hda-intel,snd-hda-intel
# 5Dex.mtR84bFRyqF:FCH Azalia Controller
alias snd-card-0 snd-hda-intel
# mnDB.L2T9ICroiQ9:Trinity HDMI Audio Controller
alias snd-card-1 snd-hda-intel

Output from /usr/sbin/alsa-info.sh is

upload=true&script=true&cardinfo=
!!################################
!!ALSA Information Script v 0.4.64
!!################################

!!Script ran on: Sun Apr 19 07:18:22 UTC 2015


!!Linux Distribution
!!------------------

Welcome to openSUSE 13.2 "Harlequin" - Kernel \r (\l). openSUSE 13.2 (x86_64) # /etc/SuSE-release is deprecated and will be removed in the future, use /etc/os-release instead NAME=openSUSE PRETTY_NAME="openSUSE 13.2 (Harlequin) (x86_64)" ID=opensuse CPE_NAME="cpe:/o:opensuse:opensuse:13.2" BUG_REPORT_URL="https://bugs.opensuse.org" HOME_URL="https://opensuse.org/" ID_LIKE="suse"


!!DMI Information
!!---------------

Manufacturer:      TOSHIBA
Product Name:      Satellite S50D-A
Product Version:   PSKKWA-00M007
Firmware Version:  1.40


!!Kernel Information
!!------------------

Kernel release:    3.16.7-7-desktop
Operating System:  GNU/Linux
Architecture:      x86_64
Processor:         x86_64
SMP Enabled:       Yes


!!ALSA Version
!!------------

Driver version:     
Library version:    
Utilities version:  1.0.28


!!Loaded ALSA modules
!!-------------------



!!Sound Servers on this system
!!----------------------------

Pulseaudio:
      Installed - Yes (/usr/bin/pulseaudio)
      Running - Yes

ESound Daemon:
      Installed - Yes (/usr/bin/esd)
      Running - No


!!Soundcards recognised by ALSA
!!-----------------------------



!!PCI Soundcards installed in the system
!!--------------------------------------

00:01.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Trinity HDMI Audio Controller
00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD] FCH Azalia Controller (rev 01)


!!Advanced information - PCI Vendor/Device/Subsystem ID's
!!-------------------------------------------------------

00:01.1 0403: 1002:9902
    Subsystem: 1002:9902
--
00:14.2 0403: 1022:780d (rev 01)
    Subsystem: 1179:fa91


!!Loaded sound module options
!!---------------------------


!!ALSA Device nodes
!!-----------------

crw-rw----+ 1 root audio 116,  1 Apr 19 16:25 /dev/snd/seq
crw-rw----+ 1 root audio 116, 33 Apr 19 17:15 /dev/snd/timer


!!Aplay/Arecord output
!!--------------------

APLAY

aplay: device_list:268: no soundcards found...

ARECORD

arecord: device_list:268: no soundcards found...

!!Amixer output
!!-------------


!!Alsactl output
!!--------------

--startcollapse--
--endcollapse--


!!All Loaded Modules
!!------------------

Module
fuse
ctr
ccm
xt_pkttype
xt_LOG
xt_limit
af_packet
ip6t_REJECT
xt_tcpudp
nf_conntrack_ipv6
nf_defrag_ipv6
ip6table_raw
ipt_REJECT
iptable_raw
xt_CT
iptable_filter
ip6table_mangle
nf_conntrack_netbios_ns
nf_conntrack_broadcast
nf_conntrack_ipv4
nf_defrag_ipv4
ip_tables
xt_conntrack
nf_conntrack
ip6table_filter
ip6_tables
x_tables
nls_iso8859_1
nls_cp437
vfat
fat
arc4
xfs
libcrc32c
ecb
kvm_amd
uvcvideo
ath3k
videobuf2_vmalloc
videobuf2_memops
videobuf2_core
ath9k
ath9k_common
btusb
kvm
v4l2_common
videodev
crct10dif_pclmul
ath9k_hw
crc32_pclmul
ath
ghash_clmulni_intel
aesni_intel
aes_x86_64
lrw
bluetooth
mac80211
gf128mul
6lowpan_iphc
sparse_keymap
glue_helper
alx
cfg80211
mdio
acpi_cpufreq
i2c_piix4
rfkill
shpchp
k10temp
ablk_helper
thermal
cryptd
joydev
wmi
toshiba_bluetooth
processor
video
button
battery
fan
ac
pcspkr
serio_raw
ppp_mppe
ppp_generic
slhc
dm_mod
efivarfs
btrfs
xor
raid6_pq
crc32c_intel
keucr
uas
usb_storage
radeon
sr_mod
i2c_algo_bit
drm_kms_helper
ohci_pci
cdrom
ttm
xhci_hcd
drm
sg


!!ALSA/HDA dmesg
!!--------------

    8.164491] [drm] Connector 2:
    8.164493] [drm]   HDMI-A-1
    8.164494] [drm]   HPD3
--
   21.148474] Adding 2104316k swap on /dev/sda6.  Priority:-1 extents:1 across:2104316k FS
   21.189860] snd_hda_intel 0000:00:01.1: Force to non-snoop mode
   21.189917] snd_hda_intel 0000:00:01.1: irq 48 for MSI/MSI-X
   21.417714] SGI XFS with ACLs, security attributes, realtime, large block/inode numbers, no debug enabled
   21.430057] sound hdaudioC1D0: autoconfig: line_outs=1 (0xd/0x0/0x0/0x0/0x0) type:speaker
   21.430069] sound hdaudioC1D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
   21.430075] sound hdaudioC1D0:    hp_outs=1 (0xb/0x0/0x0/0x0/0x0)
   21.430080] sound hdaudioC1D0:    mono: mono_out=0x0
   21.430085] sound hdaudioC1D0:    inputs:
   21.430090] sound hdaudioC1D0:      Internal Mic=0x11
   21.430096] sound hdaudioC1D0:      Mic=0xa
   21.435560] input: HDA ATI HDMI HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:01.1/sound/card0/input17
   21.453632] input: HDA Digital PCBeep as /devices/pci0000:00/0000:00:14.2/sound/card1/hdaudioC1D0/input18
   21.455322] input: HD-Audio Generic Mic as /devices/pci0000:00/0000:00:14.2/sound/card1/input19
   21.455678] input: HD-Audio Generic Headphone as /devices/pci0000:00/0000:00:14.2/sound/card1/input20
   21.466427] XFS (sda8): Mounting V5 Filesystem
--
  116.269633] ll header: 00000000: ff ff ff ff ff ff e8 94 f6 5c b6 4a 08 00        .........\.J..
  654.417844] snd_hda_intel 0000:00:01.1: Force to non-snoop mode
  654.417901] snd_hda_intel 0000:00:01.1: irq 48 for MSI/MSI-X
  654.432788] input: HDA ATI HDMI HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:01.1/sound/card0/input21
  654.437360] sound hdaudioC1D0: autoconfig: line_outs=1 (0xd/0x0/0x0/0x0/0x0) type:speaker
  654.437377] sound hdaudioC1D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
  654.437383] sound hdaudioC1D0:    hp_outs=1 (0xb/0x0/0x0/0x0/0x0)
  654.437387] sound hdaudioC1D0:    mono: mono_out=0x0
  654.437390] sound hdaudioC1D0:    inputs:
  654.437394] sound hdaudioC1D0:      Internal Mic=0x11
  654.437398] sound hdaudioC1D0:      Mic=0xa
  654.460096] input: HDA Digital PCBeep as /devices/pci0000:00/0000:00:14.2/sound/card1/hdaudioC1D0/input22
  654.467535] input: HD-Audio Generic Mic as /devices/pci0000:00/0000:00:14.2/sound/card1/input23
  654.467724] input: HD-Audio Generic Headphone as /devices/pci0000:00/0000:00:14.2/sound/card1/input24
 2168.468675] snd_hda_intel 0000:00:01.1: Force to non-snoop mode
 2168.468736] snd_hda_intel 0000:00:01.1: irq 48 for MSI/MSI-X
 2168.478986] input: HDA ATI HDMI HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:01.1/sound/card0/input25
 2168.491440] sound hdaudioC1D0: autoconfig: line_outs=1 (0xd/0x0/0x0/0x0/0x0) type:speaker
 2168.491450] sound hdaudioC1D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
 2168.491455] sound hdaudioC1D0:    hp_outs=1 (0xb/0x0/0x0/0x0/0x0)
 2168.491460] sound hdaudioC1D0:    mono: mono_out=0x0
 2168.491463] sound hdaudioC1D0:    inputs:
 2168.491467] sound hdaudioC1D0:      Internal Mic=0x11
 2168.491471] sound hdaudioC1D0:      Mic=0xa
 2168.515117] input: HDA Digital PCBeep as /devices/pci0000:00/0000:00:14.2/sound/card1/hdaudioC1D0/input26
 2168.515606] input: HD-Audio Generic Mic as /devices/pci0000:00/0000:00:14.2/sound/card1/input27
 2168.518041] input: HD-Audio Generic Headphone as /devices/pci0000:00/0000:00:14.2/sound/card1/input28
 3049.900172] snd_hda_intel 0000:00:01.1: Force to non-snoop mode
 3049.900231] snd_hda_intel 0000:00:01.1: irq 48 for MSI/MSI-X
 3049.911432] input: HDA ATI HDMI HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:01.1/sound/card0/input29
 3049.917290] sound hdaudioC1D0: autoconfig: line_outs=1 (0xd/0x0/0x0/0x0/0x0) type:speaker
 3049.917300] sound hdaudioC1D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
 3049.917306] sound hdaudioC1D0:    hp_outs=1 (0xb/0x0/0x0/0x0/0x0)
 3049.917311] sound hdaudioC1D0:    mono: mono_out=0x0
 3049.917315] sound hdaudioC1D0:    inputs:
 3049.917320] sound hdaudioC1D0:      Internal Mic=0x11
 3049.917325] sound hdaudioC1D0:      Mic=0xa
 3049.940985] input: HDA Digital PCBeep as /devices/pci0000:00/0000:00:14.2/sound/card1/hdaudioC1D0/input30
 3049.941521] input: HD-Audio Generic Mic as /devices/pci0000:00/0000:00:14.2/sound/card1/input31
 3049.941707] input: HD-Audio Generic Headphone as /devices/pci0000:00/0000:00:14.2/sound/card1/input32

use yast to setup your audio, no need to tweak text files.

Note this from the script:


!!Aplay/Arecord output
!!--------------------

APLAY

aplay: device_list:268: no soundcards found...

ARECORD

arecord: device_list:268: no soundcards found...

This is an alsa setup problem and not a pulse problem.

Have your rebooted since this problem occured (to try reload alsa) ? Try a reboot (to reload alsa/pulse). If that does not cure this, then remove the old /etc/modprobe.d/50-sound.conf file, reboot, and then if necessary, go into yast and reconfigure your sound.

Yes, I had rebooted and I had tried to use YaST to set up the sound. I removed the /etc/modprobe.d/50-sound.conf file and tried YaST again but the new file was no different from the previous.

Following your advice that it is an ALSA problem, I have tried using this command to force the loading of the module identified by PA:

echo "options snd-hda-intel model=auto" > /etc/modprobe.d/snd-hda-intel.conf

and this has made a difference to the alsa-info.sh output. ALSA is now apparently starting, but I still have no sound.

upload=true&script=true&cardinfo=
!!################################
!!ALSA Information Script v 0.4.64
!!################################

!!Script ran on: Sun Apr 19 10:47:19 UTC 2015


!!Linux Distribution
!!------------------

Welcome to openSUSE 13.2 "Harlequin" - Kernel \r (\l). openSUSE 13.2 (x86_64) # /etc/SuSE-release is deprecated and will be removed in the future, use /etc/os-release instead NAME=openSUSE PRETTY_NAME="openSUSE 13.2 (Harlequin) (x86_64)" ID=opensuse CPE_NAME="cpe:/o:opensuse:opensuse:13.2" BUG_REPORT_URL="https://bugs.opensuse.org" HOME_URL="https://opensuse.org/" ID_LIKE="suse"


!!DMI Information
!!---------------

Manufacturer:      TOSHIBA
Product Name:      Satellite S50D-A
Product Version:   PSKKWA-00M007
Firmware Version:  1.40


!!Kernel Information
!!------------------

Kernel release:    3.16.7-7-desktop
Operating System:  GNU/Linux
Architecture:      x86_64
Processor:         x86_64
SMP Enabled:       Yes


!!ALSA Version
!!------------

Driver version:     k3.16.7-7-desktop
Library version:    
Utilities version:  1.0.28


!!Loaded ALSA modules
!!-------------------

snd_hda_intel
snd_hda_intel


!!Sound Servers on this system
!!----------------------------

Pulseaudio:
      Installed - Yes (/usr/bin/pulseaudio)
      Running - Yes

ESound Daemon:
      Installed - Yes (/usr/bin/esd)
      Running - No


!!Soundcards recognised by ALSA
!!-----------------------------

 0 [HDMI           ]: HDA-Intel - HDA ATI HDMI
                      HDA ATI HDMI at 0xf0344000 irq 48
 1 [Generic        ]: HDA-Intel - HD-Audio Generic
                      HD-Audio Generic at 0xf0340000 irq 16


!!PCI Soundcards installed in the system
!!--------------------------------------

00:01.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Trinity HDMI Audio Controller
00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD] FCH Azalia Controller (rev 01)


!!Advanced information - PCI Vendor/Device/Subsystem ID's
!!-------------------------------------------------------

00:01.1 0403: 1002:9902
    Subsystem: 1002:9902
--
00:14.2 0403: 1022:780d (rev 01)
    Subsystem: 1179:fa91


!!Modprobe options (Sound related)
!!--------------------------------

snd_hda_intel: model=auto


!!Loaded sound module options
!!---------------------------

!!Module: snd_hda_intel
    align_buffer_size : -1
    bdl_pos_adj : 32,32,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1
    beep_mode : Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y
    enable : Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y
    enable_msi : -1
    id : (null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null)
    index : -1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1
    jackpoll_ms : 0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0
    model : auto,(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null)
    patch : (null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null)
    position_fix : -1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1
    power_save : 0
    power_save_controller : Y
    probe_mask : -1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1
    probe_only : 0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0
    single_cmd : N
    snoop : Y

...

!!ALSA/HDA dmesg
!!--------------

    8.164817] [drm] Connector 2:
    8.164819] [drm]   HDMI-A-1
    8.164821] [drm]   HPD3
--
   19.275311] pci 0000:00:18.5: using default PCI settings
   19.476965] snd_hda_intel 0000:00:01.1: Force to non-snoop mode
   19.477063] snd_hda_intel 0000:00:01.1: irq 48 for MSI/MSI-X
   19.504717] cfg80211: Calling CRDA to update world regulatory domain
--
   19.534279] Bluetooth: SCO socket layer initialized
   19.620836] input: HDA ATI HDMI HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:01.1/sound/card0/input16
   19.763545] sound hdaudioC1D0: autoconfig: line_outs=1 (0xd/0x0/0x0/0x0/0x0) type:speaker
   19.763556] sound hdaudioC1D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
   19.763563] sound hdaudioC1D0:    hp_outs=1 (0xb/0x0/0x0/0x0/0x0)
   19.763568] sound hdaudioC1D0:    mono: mono_out=0x0
   19.763572] sound hdaudioC1D0:    inputs:
   19.763578] sound hdaudioC1D0:      Internal Mic=0x11
   19.763583] sound hdaudioC1D0:      Mic=0xa
   19.772848] uvcvideo: Found UVC 1.00 device TOSHIBA Web Camera - HD (04f2:b3b1)
--
   19.775208] USB Video Class driver (1.1.1)
   19.786658] input: HDA Digital PCBeep as /devices/pci0000:00/0000:00:14.2/sound/card1/hdaudioC1D0/input17
   19.787539] input: HD-Audio Generic Mic as /devices/pci0000:00/0000:00:14.2/sound/card1/input19
   19.788449] input: HD-Audio Generic Headphone as /devices/pci0000:00/0000:00:14.2/sound/card1/input20
   19.891129] ath: phy0: WB335 2-ANT card detected

Within pavucontrol, card 0 is the analog card, while in ALSA, card 0 is the HDMI. I don’t know if this is the problem. I don’t know how to change this.

I had previously had this problem and was able to get around it by issuing the commands:

  hda-verb /dev/snd/hwC0D0 0x01 SET_GPIO_MASK 0x10
  hda-verb /dev/snd/hwC0D0 0x01 SET_GPIO_DIR 0x10
  hda-verb /dev/snd/hwC0D0 0x01 SET_GPIO_DATA 0x10

These are no longer making any difference.

Did you erase the pulse caches I have seen the original error fixed by that. You can also try a different user. I think the pulse cache are now in ~/.pulse also may want to zap the pulse directory in ~/.config

Rather than pick and choose what you think ‘might’ be useful, could you please provide a link to the entire alsa-info.sh script output ? What I needed to look at was not all present in what was provided in your post.

Also, check out gogalthorp’s suggestion to see if it helps.

First I checked and there is no ~/.pulse file or directory. I moved the ~/.config/pulse to /tmp, rebooted, and tried to use sound. The folder was recreated with similar but not identical contents to the original, but there was still no sound.

I have re-run /usr/sbin/alsa-info.sh and the full output is located at http://www.alsa-project.org/db/?f=e91710ccecd237b393a8569b6a0ee13da29f47cc

Could you please remove the model=auto from your PC’s 50-sound.conf file, reboot, and run the diagnostic script again ? I want to ensure that setting does not mess up my setup. I’m currently a bit puzzled by the PCI info of your cards and need to ponder this …


!!Advanced information - PCI Vendor/Device/Subsystem ID's
!!-------------------------------------------------------

00:01.1 0403: 1002:9902
    Subsystem: 1002:9902
--
00:14.2 0403: 1022:780d (rev 01)
    Subsystem: 1179:fa91

I was not expecting 1002:9902 and 1022:780d (I was expecting the 1st four numbers to be the same in each) . Perhaps that does not matter. Ultimately i want to create an edit to the 50-sound.conf that forces the analog device to be card-0, and the HDMI to be card-1 (which I suspect YaST is failing to do). Once that is done I think you will have more success with your audio.

The /etc/modprobe.d/50-sound.conf file just contained

options snd slots=snd-hda-intel,snd-hda-intel
# 5Dex.mtR84bFRyqF:FCH Azalia Controller
alias snd-card-0 snd-hda-intel
# mnDB.L2T9ICroiQ9:Trinity HDMI Audio Controller
alias snd-card-1 snd-hda-intel

I removed the “model=auto” from the file I created /etc/modprobe.d/snd-hda-intel.conf so that the only line in it is now

options snd-hda-intel

This causes an error message when I login, but it successfully loads the module. The new output from /usr/sbin/alsa-info.sh is on http://www.alsa-project.org/db/?f=06fa6d4f520e137b9eceeb39659a7b40930eb3ce

What error message do you get ? Is it a desktop error ?

I note the following from the script :


!!Advanced information - PCI Vendor/Device/Subsystem ID's
!!-------------------------------------------------------

00:01.1 0403: **1002:9902**
    Subsystem: 1002:9902
--
00:14.2 0403: **1022:780d** (rev 01)
    Subsystem: 1179:fa91

and also the following:


!!HDA-Intel Codec information
!!---------------------------
--startcollapse--
Codec: ATI R6xx HDMI
...
Vendor Id: 0x**1002**aa01
...
...
Codec: IDT 92HD99BXX
...
Vendor Id: 0x111d76e5

From this I suspect (but not entirely certain) that 1002:9902 is the HDMI and 1022:780d is the 92HD99BXX Analog analog audio device. Currently the HDMI is card-0 and the Analog is Card-1.

Lets try to reverse those and make the HDMI card-1 and the Analog Card-0.

Replace the content of the /etc/modprobe.d/50-sound.conf file with the following :


options snd_hda_intel index=0 model=auto vid=1022 pid=780d
options snd_hda_intel index=1 model=auto vid=1002 pid=9902

Reboot and test, but do not test with YaST sound. YaST will re-write the 50-sound.conf file content.

Please also after the reboot, with that configuration in place, run again the /usr/sbin/alsa-info.sh script and share the output URL.

I am not convinced vid=1022 pid=780d is correct … but lets try it.

The error message I got said illegal first line in /etc/modprobe.d/snd-hda-intel.conf

I was able to confirm that you correctly picked the vid/pid by trying “lspci -vnn | grep -A 1 -i audio”

I added the two options lines to /etc/modprobe.d/50-sound.conf and commented out the first (and only) line in snd-hda-intel.conf

After rebooting, /usr/sbin/alsa-info.sh gives the content at http://www.alsa-project.org/db/?f=6c620629a8b62cd0d19932d195c7bee543f28040

There is still no sound.

The script confirms the cards order was successfully changed.



!!Aplay/Arecord output
!!--------------------

APLAY

**** List of PLAYBACK Hardware Devices ****
card 0: Generic [HD-Audio Generic], device 0: 92HD99BXX Analog [92HD99BXX Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

wrt still no sound - one clear reason is your PCs mixer is incorrectly configured. Look at your PC’s speaker configuration:


Simple mixer control 'Speaker',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 127
  Mono:
  Front Left: Playback 0 [0%] -95.25dB] [on]
  Front Right: Playback 0 [0%] -95.25dB] [on] 

0% playback volume produces no sound.

Its possible the only lines needed are those that I recommended be added, and possibly the remainder could be deleted. An exception would be if a special 50-sound.conf entry is needed for the Codec: IDT 92HD99BXX (ie your card-0).

Also, what app are you running for your speaker test ?

I recommend you try:


aplay -vv /usr/share/sounds/alsa/test.wav

or try:


aplay --device hw:0,0 -vv /usr/share/sounds/alsa/test.wav