Paused - "/usr/lib/cups/backend/hp failed"

openSUSE 12.2 x64 KDE.
HP printer
HIPLIP installed
No printing
Cups reports "
Worked in 12.1
After I did the zypper dup to 12.3 it was usable. Is now unusable with the above error.
I added the printing repo and have it and packman enabled.
I refreshed the installed software and libs after adding the printing repo.
No joy still getting that error and no printing.
How to proceed?

You claim to have upgraded to openSUSE 12.3, and simultaneously mention that openSUSE 12.2 is installed. Do you mind clarifying further here?

My main computer runs 12.2.
I have another computer that run 12.3. ( actually two of them )
The 12.3 system is not the system with a problem or a printer.
My problem is with 12.2 system.

Did your printer ever work (with this OS install)? That is, did you manage to configure successfully and print a test page?

Have you tried resuming the printer via the CUPS web interface?


Check status and try resuming via ‘Maintenance’ for your printer.

See if anything in this bug report applies to you:

The printer worked on this install I checked the log. I can’t print a test page from Cups now.

I do no get your meaning resume the printer from cups. I see no “resume” function in the cups interface under administration.

I do not understand that bug report.

Unplugging the usb cable and reinserting it the cued Cups test page was printed.
I now can print.
So resolved


that’s a pretty old version of hplip you are using - and why hpijs instead of hpcups?
with zypper dup how is it that you still have such an old verison? Do you have it locked?
Avoid the version of hplip in the 12.2 oss repo though as it has multiple issues. You are better off adding in the 12.2 printing repo.

Always worth checking the connections (and other simple things) first. Especially when you had a working printer. Thanks for the update.

I added that repo when looking for a solution. I don’t know it it pulled anything in though.
I also have packman but it has a higher priority than any of the openSUSE repos so stuff that I need working from packman doesn’t get broken by updates.

I use the version hplip package by openSUSE and it works normally. If newer stuff doesn’t get packaged there is not much I’ll do about it. I use precompiled binaries.

HPLIP 3.10.2rc1.9 pre-dates openSUSE 11.3 and is circa 2010.
I don’t believe you would have gotten an rc release from an openSUSE repo so it was most likely installed as a binary from the HP website - which would explain why it isn’t updated when you update your system.

You might find some of the quirkiness you experience improved with a much newer hplip and more functionality with hpcups instead of hpijs.

this is the description of hpijs in yast

HPIJS is HPLIP’s Ghostscript printer driver for HP printers. HPCUPS is HPLIP’s native CUPS printer driver for HP printers. This sub-package includes only what is needed for plain printing with the printer drivers in HPLIP for standard HP printers. It does neither provide device status information, nor support for scanning, nor support for faxing, nor support for memory card (mass storage) access, nor support for non-standard devices e.g. no support for devices which require an additional plugin from HP. This sub-package includes in particular: The hpijs binary and the libraries libhpip and libhpmud which are needed to run it. The HPCUPS driver (/usr/lib[64]/cups/filter/hpcups). The CUPS backend “hp”. All HPLIP PPD files (also for HP PostScript printers). For the full-featured HPLIP printing and scanning solution, the main-package package hplip must be installed. For full documentation and license see the main-package hplip.

The only hplip on here came from a openSUSE or packman repo. When it did was no telling as this machine in some form has been around for a very long time. I just keep changing drives, motherboards ,CPUs and memory out and updating the OS. I had 11.1 on it at one time so it could be that old but I doubt it would still be working.

I will look in the repos and see what can be done.

Now updated to 3.13.3
I had to remove the old install completely along with the associated files.
Then install as new.

that would be the version from the obs printing repo.
How did the install go - smoothly?
Everything running ok?

One thing I’d recommend about the obs repo is that has a new hplip added quite often - so if you update every time there is a possibility of a broken hplip.
If everything is working OK now, it could be an idea to remove the obs repo and lock what you have in place until the next os update.

Everything just works.
I haven’t scanned yet but it should just work.

I’ll disable the printing repo.