patterns-openSUSE-devel_***** packages

I might like to try some development.
In Yast->software management->view->patterns, I see some Meta package for pattern devel_*****
What are those meta packages? Are they what I need to install to start development work? e.g.
install 1st patterns-openSUSE-devel_basis,
then e.g. patterns-openSUSE-devel_ruby, if I like to try some ruby?

Am confused what to install with so many packages per category under View->patterns. Thanks.

These indeed are metapackages. They trigger (AFAIK by deps) the install of a set of related packages, f.e. KDE development. If you run the Softwaremanager from Yast, select View - Patterns, you’ll see the patterns in a list on the left. Each pattern has a checkbox. Once you check that, all packages in the pattern will be selected for install. Handy feature, isn’t it?