Patches Put on and boot fails

HI all:

I’ve been reading many posts and figured I should just start fresh with this because some stuff matches and other things do not. So I am not sure what is going on.

  1. Did the Yast2 stuff to pull in log4j and polkit (I can’t remember what it got renamed to) exploit patches. All of that installed and so I decided to reboot at that point because of a Kernel update that had taken place as well.
    This is an AMD Ryzen 5 2600 Six-core processor with 8GB RAM and a Radon 5000/6000/7350/8350 series adapter card.

  2. The reboot failed. It came up and I told it to take the Leap 15.3 kernel (forgot what the new numbered was was) and the monitors went black, then showed no signal, and the system is now in a coma state.

  3. Ok this is not going well, so I got a Knoppix DVD up and plugged in a USB back up drive and backed up /home

  4. Got the LEAP 15.3 install DVD and booted it and told it to do the update install accepting the new repositories, etc. and let it run.

  5. Same problem again as #2.

  6. Leap 15.3 and did an install, but told it to NOT format /home (RAID1) and had it pickup users from current system and had it format the UEFI partition. Then it came back and said this: Upgraded uses Legacy Bios, installation uses EFI!! And that this probably won’t boot (and it did not just as predicted).

No matter what I have tried, I can’t get this thing to do UEFI. And so I can’t get it to install. I read what someone else said, and I am considering finding my LEAP 15.2 (Network) install to try to recover this system. Any ideas before I get into more trouble? At least I can get her to her doc files and the like with Knoppix 9.1(?). .

One other thing, because it might be important against update times of repositories. This has been going on since before Sat 29JAN22 19:00 US Eastern when I took the backup of /home . I have forgotten when I did the upgrade, probably on Thursday evening.

Are you unable to boot selecting a rescue or failsafe option in the Grub menu? What is output from inxi -Gxx if you append nomodeset to the linu line by striking the E key at the grub menu before proceeding with boot, or by booting selecting a Grub rescue option? If unable to boot installed system, you can get the GPU’s device ID booting live media and running either inxi -Gxx or lspci -nnk | grep -A3 VGA. Ctrl-Alt-F2 after the YaST installer has started will reach a prompt from which you can run lspci.

It is too late for failsafe since the “old” or previous kernel is gone.

The " lspci | grep -A3 VGA" command returned: 0300 compat controller. – The unit returned the following in H/W Info using a different DVD (Knoppix): Radon HD 5000/6000/7350/8350 Series .

And the message from the boot after the “Edit” was: drm: Radon_init Error noUMS support in radeon Module!

Which is interesting. Now I am getting that wihile the LEAP 15.1 Net CD boots.

So I am now going to boot the Leap 15.2 CD to do an install. I have to get my wife’s desktop functional.

Thank you,

Leap 15.2 installed and solved the boot (legacy vs. UEFI) failure problem. Wonder how long it will be before 15.3 is fixed, or 15.4 is released.

The command was supposed to be lspci -nnk | grep -A3 VGA, whose output would have resembled the following:

# lspci **-nnk** | grep -A3 VGA
01:05.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Cedar [Radeon HD 5000/6000/7350/8350] **1002:*68f9***]
        Subsystem: Dell Device [1028:01e5]
        Kernel driver in use: radeon
        Kernel modules: radeon

From the output in bold can be found the specific model in order to learn whether it’s in the affected class of GPUs.

And the message from the boot after the “Edit” was: drm: Radon_init Error noUMS support in radeon Module!
This message indicates high likelihood that the wife’s GPU is within the affected class.

So I am now going to boot the Leap 15.2 CD to do an install.
What you could have done is an installation from the DVD image with the internet disconnected. That would install the working release kernel. Once 15.3 was installed, the kernel could be locked, and then the rest of the system updated, with kernel update to be applied when a replacement for the broken .59.43 is announced, or a kernel from SP3 pool installed now if you two are paranoid about kernel vulnerabilities. I’ve installed that kernel probably on 5 PCs so far.

Official kernel update should be mere days away. 15.4 alpha is available now, but the SP3 pool kernel would be a lot less trouble. 15.4 beta is due later this month, with final release announcement in May or June.

Thank you, but here is the reality of the situation. I’m not a Linux admin. It is tax season here. My wife can’t use her computer for 2 weeks? Something has to be done and done now. Leap 15.2 worked.


The fixed 15.3 kernel is now on the mirrors.