partitions are not being auto mounted on start up

hi to all.i reinstalled opensuse yesterday.when i turn on my system every time i need to enter my root password to mount my partitons.please see the following image.i want to automount all partitions on startup without giving root password(before reinstalling opensuse it didn’t ask root password to mount my partitions)](

Please post the output of the contents of “/etc/fstab” file and the following command :

/sbin/fdisk -l

The other option is to carefully read the documentation :slight_smile:
Chapter 3. Advanced Disk Setup

Best regards,

and also:

cat /etc/fstab

my output was

Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders, total 625142448 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xf7db3a0a

Device Boot Start End Blocks Id System
/dev/sda1 2048 206847 102400 7 HPFS/NTFS/exFAT
/dev/sda2 206848 126035967 62914560 7 HPFS/NTFS/exFAT
/dev/sda3 * 126035969 625137344 249550688 f W95 Ext’d (LBA)
/dev/sda5 126036032 230893567 52428768 6 FAT16
/dev/sda6 230902308 356723324 62910508+ 7 HPFS/NTFS/exFAT
/dev/sda7 356723388 461579579 52428096 7 HPFS/NTFS/exFAT
/dev/sda8 461579643 471909374 5164866 82 Linux swap / Solaris
/dev/sda9 471909438 576765629 52428096 7 HPFS/NTFS/exFAT
/dev/sda10 576765693 602068004 12651156 83 Linux
/dev/sda11 602068068 625137344 11534638+ 83 Linux

my output was

/dev/disk/by-id/ata-ST9320423AS_5VJ657SA-part8 swap swap defaults 0 0
/dev/disk/by-id/ata-ST9320423AS_5VJ657SA-part10 / ext4 acl,user_xattr 1 1
/dev/disk/by-id/ata-ST9320423AS_5VJ657SA-part11 /home ext4 acl,user_xattr 1 2
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0

Intermission! Please @vike4, when you post computer output put it between CODE tags. Else we can not read it : Posting in Code Tags - A Guide

oh sorry i will post outputs in code tags.

Ok in order to have a partition auto mounted You need to have and fstab entry for each partition You want to mount at boot. Here’s a quick tutorial on how to do that :
FSTAB - Editing Manually

After editing /etc/fstab You can test by issuing the following command as root :

mount -a

If the partition You want to mount on boot will mount after the mount -a command it means your fstab entries are fine and from now on at each boot the partitions will be mounted.

Best regards,

You can also use YaST > System > Partition manager to get those fiile systems mounted. But TAKE CARE. Do double check that “Do not Format” is checked there, else you will loose your data.

I guess that the following documentation may be of iinterest to you: SDB:Basics of partitions, filesystems, mount points - openSUSE.

vike4 just off hand why all the fat partitions (exFAT)
i have not seen that many since win 98 and have not seen a fat16 since ?? a long time

You might want to have the MS windows partitions need root access to write to
It might be possible to install a MS virus through Linux if the NORMAL account has read/write to the NTFS drives
I do not know of a virus or malware that dose this YET
But, better safe than sorry .

read – everyone
write – root only

sorry guys i can’t check your replies until 22.00(GMT +5.30)

Glistwan first step fails

see the following

linux-vd9i:/home/vicky # kdesu kwrite /etc/fstab
kdesu(2972): Session bus not found 
To circumvent this problem try the following command (with Linux and bash) 
export $(dbus-launch) 

KCrash: Application 'kdesu' crashing...
KCrash: Attempting to start /usr/lib/kde4/libexec/drkonqi from kdeinit
Warning: connect() failed: : No such file or directory
KCrash: Attempting to start /usr/lib/kde4/libexec/drkonqi directly
drkonqi(2973): Session bus not found 
To circumvent this problem try the following command (with Linux and bash) 
export $(dbus-launch) 

can i mount only one partition on boot?i have five partition i want to mount all(five) partitions on boot

You can enter as many file systems in your fstab as you need. Did you read the basic documentation a pointed to?

Did you go to YaST > System > Partinioner and didn’t you see al of your partitions there? It isn’t that difficult.

John all the five partitions are ntfs.

what are you trying to say?i can’t understand this.

Wait Henk now i am reading your guide.i can see all partitions but i don’t know what to do next?

Are you in YaST > System > Partiioning? Right click on one of the partitions you want to be mounted and choose Edit. Then, when you have questions on what to do there come back.

Henk i got a pop up window i clicked at fstab options following image i got](

what to do next?

Simple enough.

The upper part says “Do not format partition” and that is OK of course, formatting would overwrite all data and that is not what you want.

The lower part suggest you a mount point. It is a suggestion. When you have read the “Basics about …” you know that it is you who decides where to mount it. And you know what is on it and where you use it for. Thus e.g. when it contains your music, I would mount it on /home/vike4/mymusic (whenvike4 is your username on the system, else adapt). It is only you that can decide where all five file systems should go.
After you changed the mount point text to your liking, click finish. Then you come back to th main Partitioner screen where you also click Finish.

Then go to the mount point (e.g. with Dolphin and look if everything is there.

You can of course do the other four without every time doing the last Finish, but we do now one only for the first time to get the feeling.

After you have finished look in /etc/fstab to see what YaST did to it (you can post when you like). You could have done that by an editor also of course (this is suggested by others above), but using YaST as newcomer is also OK.

all okay Henk i replaced the mount points of the partitions to /home/username/xxx(here xxx is the name of the label of my desired partition).but after a restart all falls back to default.i think i should select device path in the fstab options in the following image isn’t it?](

Are You using KDE or GNOME or some other desktop environment ?
You can always become root “su -” and than use “vi /etc/fstab” but I’m not sure if You know how to operate vi (it can be tricky at first). Basicaly You can use any text editor with root privilages to edit /etc/fstab so choose your favourite one :slight_smile:

Best regards,