partitioning strategy and issue while closing / restart OpenSuse

Dear All,

recently i posted issue with Proton bridge i could not install. this has been solved thanks to members of the Forum.

now having some problems partitioning and freezing OS during restart or closure…

my strategy for partitioning was:
Both M2 drives as a stripping for root
120 GB SSD as swap disk, anyway sappiness set to 2, enough ram in the system
2 x 2TB as a mirror raid, mainly for pictures storage
1 x 900 GB SSD as a home (without pictures)

when i create above setup, computer freezes during closure or restarting.

and now the most interesting.

when i installed quickly OpenSuse and had automatic guiding partitioning on only one M2 drive, system works well, w/o issues during closure or restart.

question to You. what can be wrong?

2nd question, do you have any better strategy for below disk setup?

again, thanks in advance for any feedback.

some side comment, i would like to have SSD 900 for a steam games, got quite few of them.

info about hardware, which was initially build for Windows. but tired of the Privacy compromises…
2 x m2 500 GB
1 x 120 GB SSD
1 x 900 GB SSD
2 x 2TB HDD

Motherboard: MSI 570 Gaming plus
1 M2 is connected to AMD processor directly
1 M2 is connected to the chipset

rest to SATA ports.

KMMN0OOOKWMMXo. ; ;0MWk:. .:OMMk.OS: openSUSE Tumbleweed x86_64
** ;WMK;. .lKMMNM, :NMK, .OMW;Host: MS-7C37 2.0
** cMW; 'WMMMN ,XMK, oMM’Kernel: 5.16.5-1-default
**.MMc …;l. xMN: KM0
Uptime
: 11 mins
’MM. 'NMO oMM****Packages: 2273 (rpm)
.MM, .kMMl xMN****Shell: bash 5.1.16
** KM0 .kMM0. .dl:,… .WMd****Resolution
: 3440x1440
** .XM0. ,OMMK, OMMMK. .XMKDE**: Plasma 5.24.0
** oWMO:. .;xNMMk, NNNMKl. .xWMx
WM**: KWin
** :ONMMNXMMMKx; . ,xNMWKkxllox0NMWk,**Theme: [Plasma], Breeze [GTK2/3]
** … .:dOOXXKOxl,**Icons: [Plasma], breeze [GTK2/3]
Terminal: konsole
CPU: AMD Ryzen 7 5800X (16) @ 3.800GHz
GPU: AMD ATI Radeon RX 6600/6600 XT/6600M
Memory: 1840MiB / 32002MiB

Hi
Could be the nvme controller, what brand of device? I have to add the following to grub kernel option for a WDC nvme to get it recognized nvme_core.default_ps_max_latency_us=0

Hello,

thanks for the feedback, however i am not so experienced with Opensuse to follow your suggestion.

today i installed once again OS.
interesting is that i created LVM Volume group which consists of 2 x M2 and 900 GB SATA.
everything worked well, restarts, shuts, etc…

then i created the RAID out of 2 x 2TB and problems started again.

system can be restarted from the console w/o problem.
but from menu nothing works and system hangs, like shutdown, restart or even log out.
this computer worked with suse more than a year w/o any issue.
recent update changed something.

devices:/dev/nvme1n1 nvme-ADATA_SX8200PNP_2L0929QAQNWJ

/dev/nvme0n1 nvme-ADATA_SX8200PNP_2L0929QAQNWJ
/dev/sdd ata-HS-SSD-C100_960G_30025575965
/dev/sdc ata-ST2000DM008-2FR102_ZFL3QJ72
/dev/sdb ata-ST2000DM008-2FR102_ZFL3WK5Q
/dev/sda ata-OCZ-VERTEX4_OCZ-0053LQ4QTKL63H1F

edit:
looks Software RAID causes this issue.
i removed the RAID and created normal partitions and OS can be restarted or closed.
do you have any idea what to do now?

Dear All,

sorry for posting after myself.

i solved the issue with frozen restart or shutdown when RAID was in the system.

it had nothing to do with PC configuration.
i was looking for the RAID and shutdown. apparently there was few posts with Linux issues.
on one of the forum, there was a command:

cat /proc/mdstat

which shows status of the raid. Suse was not closing or restarting because it was building the RAID after system installation…


sebastian@desktop:~> cat /proc/mdstat
Personalities : [raid1] 
md127 : active raid1 sdb[0] sda[1]
      1953514432 blocks super 1.0 [2/2] [UU]
      bitmap: 0/15 pages [0KB], 65536KB chunk


when the raid was created system restarts or closes without any problem.