Partitioner fails during the installation process

I just tried, on two separate occasions having downloaded the iso two separate times (but not validating either), to install opensuse tumbleweed. The KDE live session runs nicely (I even tested the wayland session), but I can’t get through the install because it says that the init_disk_partitioner (or something like that) had failed. This happens when I try to set up partitions myself, and then if I continue with the installation, it tells me no partitioning proposal has been made.

This is another question, but if I could get it to work, is it straightforward to get full disk encryption and to use one partition for both root and home?

Welcome to the forum!

Do you try to install on a virtual machine?

Because if you do not try it, I advise you to do it to find out if its coming from the system or your machine.


I did NOT try to install in a VM. It’s a fairly new Intel Kaby Lake system (Lenovo Yoga 710 15") and I’ve had no trouble installing e.g. KDE Neon on it, which I’m using at the moment. Is there an alternative installer for tumbleweed, such as Calamares?

I did try installing it from a fairly non-standard USB stick, which is a USB 3.0 enclosure for an m.2 SSD. I’ll try it from a regular usb stick and see what happens. I’ll report back.

So it was the m.2 flash drive. I am now installing from a standard USB stick just fine. Weird!

The failure smells like what happened to me recently:

Few days ago I cannot install Tumbleweed from netinstall - usb stick. I tried several times but I gave up, I thought was my usb stick. After that I installed TW from DVD - usb stick and everytingh was fine.

I don’t use a single partition for home and root. I think is better to have a separate root partition which does not interfere with the others.