partition tool 11.4 can't read disk partitions


I’ve installed Windows 7 with MBR partition.

After that, I’ve tried to install opensuse 11.4

When the installation proccess try to read partition table, it shows an error message as follows:

“Partition tool parted can’t read /dev/sda disk partitions.”

I have only one disk (465 GB). Windows 7 was installed with two NTFS partitions, 100 GB each other (/dev/sda2 and /dev/sda3).

Though I can continue the installation proccess, at the end it shows me this error message:

“GRUB cannot mount selected partition.”

What’s the problem?

Is it possible to make a dual boot system (Linux + Win 7)?

Thanks in advanced.

Install openSUSE alongside Win7/Vista - A Guide

Get yourself a copy of Parted Magic too

On 10/13/2011 03:46 PM, fillerac wrote:
> Thanks in advanced.

sure, see if this helps:

and be sure to check the install disk’s image is correct with this prior to beginning the install…and, be sure
to boot from the install disk, not by running it in Win7

should work…if not (after the above) you need to maybe boot from a
Live CD and see if that runs ok for you…then tell us and we can guide
you more…

openSUSE®, the “German Automobiles” of operating systems

You also may want to check if you are using EFI or BIOS. EFI partitioning is different and is not supported buy Grub 0.9X

Thanks a lot for all suggestions!!

I created partition table again with Parted Magic Tool and then installation of Win 7 and OpenSuse has worked like a champ.:slight_smile:

Thank you very much again.


Thanks for letting us know