Partition Mistake on Installation

When installing, I used a hard drive that had a windows installation on it. In an attempt to have it format the whole drive and allow use of all the space on the hard drive, I may have made a mistake. In the end, there was only one partition which was “create volume for … /home with ext4.” There was no partion for swap volume or root volume. It prompted me if I was sure I wanted to do that… it said I can do it that way but… and then gave me some info which has since slipped my mind. What effect if any can I expect from having done that? The install went through perfectly and everything seems to be running ok. Thanks in advance.

You probably created a LVM volume. This in itself is ok but you do need more understanding to manage such a setup. If it were me I’d stick with th old partition methods since it is much easier to maintain. Since you just installed I’d re do it with a proper partitioning. In the long run you will be happier.

there was only one partition which was “create volume for … /home with ext4.”

That seems odd - by default the openSUSE-installer creates /, /home and a swap-partition, and any Linux will need a /-partition for sure.

Could you please post the outputs of

cat /etc/fstab
fdisk -l

It did… I deleted them in error and couldn’t get it to regenerate them again.

Forgive my ignorance but where would I type that in to give you the info you’re looking for?

Look for a terminal-application in your menu (for example Konsole, xterm or the GNOME terminal - the exact variation depends on your desktop environment).

You will have to run ‘fdisk -l’ as root (type ‘su -’, hit enter, then enter your root-password [which will give you no feedback such as stars or the like, type it “blind”]). .

disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders, total 156301488 sectors
units = sectors of 1 * 512=512 bytes
sector size (logical/physical): 512 bytes/512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
disk identifier: 0x0dea0dea

Device Boot Start End Blocks ID System
/dev/sda1 * 2048 156301311 78149632 83 Linux

I hope that’s what you needed.

Just to be sure, please also post the outputs of

cat /etc/fstab

It seems like you actually only have a /-partition (including /home, which usually should be an extra-partition), so I suggest a reinstall as well. This can be fixed, but only with some hassle - having seperate /- and /home-partition (and swap) is highly recommended.


This is the option you should select if you can’t configure it manually:
Go here:
follow the directions in that image and arrive here:
And select the First option