Partition Defaults seem strange

Hello. I recently upgraded my Linux OS from Tumbleweed to LEAP42.3. I had been running on an old 32-bit box, so I was stuck with Tumbleweed. I had more and more problems (unsupported hardware) as time passed, so I finally bit the bullet and gave my wife a new Windows 10 machine – a belated Christmas present. I converted her old box (DELL Vostro 220 – Intel Celeron 450 @2.20 GHz; 2 GiB RAM – 75 GiB Western Digital disk: WDC WD800JD-75MS) to native Linux mode. On the first go-around I installed 32-bit Tumbleweed, since I had an install DVD already, and I was anxious to make sure my data migration scheme would be successful. I got everything to work OK, although I did have major trouble with the “PIM Exporter” and KMail.

Anyway, I used the Tumbleweed system to burn an installation DVD for LEAP 42.3. Everything worked OK when I installed LEAP, except that I accepted the default suggestion for the partition setup: that provided 2 GiB for swap space, 10 GiB for Root, and 63 GiB in the Home partition. I wasn’t real happy with that – after the installation and the addition of a few extra pieces of software, my root partition was already 90% full – on day 1. So I ran the installation a second time and eventually managed to allocate 4 GiB swap space, 20 GiB Root, and 51 GiB Home (plus a small partition for GRUB – about 10 MiB). I’m happy with this setup. I’ve installed most of the software I want, and the root partition is only about 60% full.

Anyway, I have two questions. Why did the installation DVD stick me with a 10 GiB maximum partition size for the root partition in the basic partitioning dialog? I eventually got what I wanted by using the “expert partitioner” dialog, but that interface isn’t real intuitive – I had to monkey around quite a while before I understood how to build the desired partition table. Which leads to my second question: Why isn’t there a short help file associated with the “expert partitioner” dialog?

Thanks for any insight you might provide. I’m pretty happy with my “new” system, but wonder if the installation might be made a bit simpler / more flexible.

Normally the installer suggests 40Gb for a root partition when using Btrfs and 20GB when using ext4. I do not know why this wasn’t done in your case. The more because there is lack of information about what was the start situation which the installer found when doing it’s suggestion. Normally a listing of

fdisk -l

could reveal the situation right after installation and thus maybe give hints about the situation before the installation. But as you say you did some repartitioning afterwards, I am afraid you destroyed all evidence.

Nevertheless you could try to post the listing of the present situation and try to tell us what you think the start situation was.
Remind that you told that there was already a TW installation and that you used the 42.3 DVD for a new one. You say nothing about what you did with those TW partitions (removed them?), nor what you instructed the 42.3 installation to do with them (or with the disk at all).

The first time I installed LEAP I told the installer program to use the entire disk. I did specify EXT4 as the file system … I had some bad experiences with BTRFS in the past, and didn’t want to repeat them. I’m sorry, but I don’t remember exactly what the Tumbleweed configuration looked like – I think it was 2.0GiB Swap, 20.0 GiB Root, and 53.0 GiB Home. I do remember that Dolphin consistently showed about 46 GiB empty space in my Home partition, and 7.0 GiB empty in the Root (I had set up a 2 GiB swapfile to get extra swap space). When I first installed Tumbleweed I was overwriting a Windows XP system – the install program said it was impossible to preserve XP, and asked for permission to use the entire disk. I said sure, go ahead – I had already moved all my wife’s data to her new Windows 10 machine. I never did use fdisk to look at the Tumbleweed partitioning. Oh yeah – I specified EXT4 as the only file system in the Tumbleweed install.

The second time I installed LEAP I was more careful. I ran “gdisk” before commencing the install, and deleted all the partitions from the disk. I’m sorry – I don’t have a picture of that. The installer still told me that 10 GiB was the maximum size allowed for the Root partition, and that 2 GiB was the maximum Swap size.

This is what it looks like now.

linux-e1xb:~ # gdisk -l /dev/sda                                                                                                                                                                                                                                               
GPT fdisk (gdisk) version 0.8.8                                                                                                                                                                                                                                                
Partition table scan:                                                                                                                                                                                                                                                          
  MBR: protective                                                                                                                                                                                                                                                              
  BSD: not present                                                                                                                                                                                                                                                             
  APM: not present                                                                                                                                                                                                                                                             
  GPT: present                                                                                                                                                                                                                                                                 
Found valid GPT with protective MBR; using GPT.                                                                                                                                                                                                                                
Disk /dev/sda: 156250000 sectors, 74.5 GiB                                                                                                                                                                                                                                     
Logical sector size: 512 bytes                                                                                                                                                                                                                                                 
Disk identifier (GUID): A2BF9EA3-EA44-4A9B-8EF8-EA67830AD2E3                                                                                                                                                                                                                   
Partition table holds up to 128 entries                                                                                                                                                                                                                                        
First usable sector is 34, last usable sector is 156249966                                                                                                                                                                                                                     
Partitions will be aligned on 2048-sector boundaries
Total free space is 3917 sectors (1.9 MiB)

Number  Start (sector)    End (sector)  Size       Code  Name
   1            2048         8386559   4.0 GiB     0700  primary
   2         8386560         8402943   8.0 MiB     EF02  primary
   3         8402944        50348031   20.0 GiB    0700  primary
   4        50348032       156248063   50.5 GiB    0700  primary

I’m willing to accept that I should have kept better records of exactly what I did. I was more focused on being sure that I didn’t lose any of the data I was moving from my old machine to the new one. I can’t really lose the software – that’s in a repository. But I have to back up my own data.

The main question I have is why not put a simple explanation of “expert partitioning” on the install disk? I finally figured it out – by right-clicking on an entry in the list of proposed partitions, I could edit the size and the file system associated with that one. Once I figured that out I was home free. A little help file might have saved a few anxious moments. Thanks!

It still sounds strange to me, but as we have no real information a bout the partition table as it was when you started the installation, it is rather useless to try to investigate that further IMHO.

And when you really removed all partitions before the installation (something you can not prove anymore), it should offer you a 40Gb for / using Btrs (which you then can change using expert to Ext4 and smaller).

Same would happen IMHO when you after the proposal clicked a bit around and used “use the whole disk” (or similar). It would then do away with all existing partitions and propose the same as above.

If I remember correctly, you can in the expert partitioner screen either right click on a partition and get a context menu (rather normal in a GUI as far as I know), or click and thus select a partition and then use buttons below like Remove or Edit. And I vaguely remember that even a “double click” (a rather MS Windows way of doing things) on a partition opens it for editing.

There’s actually a redesign of the partitioner under way. It will come with Leap 15.0 (the next Leap version). I am seeing it when testing the alpha release. Whether it is better or worse, time will tell.

With the new redesign, when you click on “Expert partitioner” you are given the choice – either keep the proposed partitioning as the starting point, or go back to what was originally on the disk as your starting point. I think that might reduce the confusion.

If I were to hazard a wild guess,
It’s that you have only 2GB physical RAM which triggered “small system” defaults, starting with the 2GB swap.
The thing is with swap, a common sizing recommendation is for it to match the size of your physical RAM, to support larger sizes like how you eventually modified enlarges “total available RAM” but at a cost that more real memory addresses are needed to map the additional swap memory… So bottom line is that enabling more total memory comes at a cost of less real physical (fast) memory.

The above is pretty much certain, and how that might affect the size of your root partition is less clear but if somehow your installation was categorized “small” then that could affect the root partition size recommendation.

In any case,
As you’ve discovered, a recommendation is only a starting point and cannot even closely be expected to be a “one size fits all.”

Glad to hear you were able to figure out the partitioner sufficiently to set your desired settings.
Is the main reason why I’d recommend that Users only “Edit Proposal Settings” instead of opening “Expert Partitioner” – That way, you start with a basic layout and then only have to re-size the individual partitions (As hcvv describes, there many ways to display the individual Edit… for each partition). If there is a re-design, maybe it’ll help… IMO I remember my general impressions when I first opened Expert Partitioner many openSUSE versions ago, and found the problem was more all the information that was thrown at me and not whether something was immediately accessible. In other words, I’d suggest maybe taking a look at what makes gparted live more intuitive by emphasizing tasks and hiding all the ways you can spell C-A-T(You only need one way that works).

Anyway, that’s IMO,

Not a bad idea I think.

While you can of course always remove all partitions in both situations and start from scratch, the total amount of work may decrease and the insight increase by using one of those as a starting point.

But still, it will help enormous when the “expert partitioner” is used by someone that has a rather good knowledge of what partitioning is and where paartitions can be used for. Not a real expert, but also not a real noob.

That is what I’d expect for only a 75 gig HD and ext4. Unless you are doing something special like SQL databases, or VMs or plan to load every program you see and such in root 20 gig ext4 should be ok. I have 20 gig free on a 30 gig root

That does sound better. What I found frustrating about the experience was that the “proposed” dialog kept enforcing maximum sizes on me (2.0 GiB for swap, 10.0 GiB for root). I knew what I wanted to do – the installer just wouldn’t let me do it.

For those who are interested, just published:

I wanted to set up 20 GiB as root. I do add some extra stuff beyond the basic install … the Kile editor for LaTex, mainly. My problem was that the basic installation dialog wouldn’t let me allocate 20 GiB. It keep insisting that root could have at most 10 GiB. So I sort of had to do somersaults to partition the disk the way I wanted.

Just use the expert mode it allows setting exactly what you want. Not sure why you think that is hard. You do have to have some idea what you want but any time you install any OS you must have a clue of what you want and the basics of file systems partition layout, mounting and formatting but the process is not at all hard.

Excellent. So it will soon be on Tumbleweed. And note that it is already on Leap 15.0 Alpha (download site HERE).