Partial libkde4-devel?

Hi!
I’m trying to compile KGet from source but compiler complains that KDE/KParts/HtmlExtension not present.
libkde4-devel installed (v. 4.4.4-3.1.1) and /usr/include/KDE/KParts/ is not empty but no HtmlExtension within.
Where should I search for the missing file?

The problem stays open. Deep searches throughout filesystem (find / -name HtmlExtension) or dvd image repository (for i in * ; do rpm -q --filesbypkg $i | grep HtmlExtension; done) did nothing…

I found the explanation of the nuisance. SVN version of KGet requires SVN versions of KDE libraries.
Getting headers from KDE SVN done good but building kdelibs failed: the process needs Qt 4.7.0 at the least. Official OpenSuSe 11.3 repositories suggest only 4.6.3
Let OpenSuSe team refressh Qt, I meanwile meditate over a morsel of a sausage…

sunders wrote:

>
> I found the explanation of the nuisance. SVN version of KGet requires
> SVN versions of KDE libraries.
> Getting headers from KDE SVN done good but building kdelibs failed: the
> process needs Qt 4.7.0 at the least. Official OpenSuSe 11.3 repositories
> suggest only 4.6.3
> Let OpenSuSe team refressh Qt, I meanwile meditate over a morsel of a
> sausage…
>
>
For qt 4.7 you can add this repository
http://download.opensuse.org/repositories/KDE:/Qt/openSUSE_11.3/
but please double and tripple check that you do not break something else
using it.


openSUSE 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.5 | GeForce
9600 GT | 4GB Ram
openSUSE 11.3 64 bit | Intel Core2 Duo T9300@2.50GHz | KDE 4.5 | Quadro FX
3600M | 4GB Ram

Thanks, I would better wait.