Parted - Incompatible Feature

Hey,
I`ve been trying to resize my home folder and give some of the space back to root, and the resizing of home went fine, but now root is still sort of stuck in between two other partitions so I cannot make it bigger yet. I tried to use parted to move the home partition to the end of the disk, but it gave me an error:

Error: File system has an incompatible feature enabled.

I looked around, and someone suggested using the partitioner that comes with SUSE, but no luck - as far as I can tell, it can resize, but not move.
How should I go about moving it or how can I make parted work?
Thanks, hope I made sense :wink:
-Stephen

su terminal and do:

fdisk -l

If it will produce anything reliable now?

Produces this:

ld620:~ # fdisk -l

Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xd0f4738c

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1           7       56196   de  Dell Utility
/dev/sda2   *           8        6935    55649160    7  HPFS/NTFS
/dev/sda3            6936        9729    22442805    f  W95 Ext'd (LBA)
/dev/sda5            6936        7128     1550241   82  Linux swap / Solaris
/dev/sda6            7129        8203     8634906   83  Linux
/dev/sda7            8204        8948     5976180   83  Linux

As you can see, 6 and 7 are practically identical, yet parted does not like 7 :frowning:

use a utility disk called Parted Magic and try with that.

I would backup important files though.
http://wiki.partedmagic.com/index.php/Downloads

Thanks for the link - that worked, but I also found another util called gparted, which I liked better. Anyway, thanks again, although I’m still not sure why parted didn’t work :\

Maybe because you had an old version of parted which doesn’t support some of the additional features added to the filesystem (probably ext3). If you do a man tune2fs and scroll down to the -O flag, you will see a whole bunch of filesystem features.