parrallel port problem in open sue10.2 X86 arch

I have a custum built desktop pc. Intel PentiumIII 1 GHz coppermine processor;512MB RAM; seagate 40GB hard disk, 1 for windows 98SE and other for open suse 10.2; HP DESKJET 640C desk jet printer; Creative labs’ sound blaster live!value card; Matrox millenium G450 display card; Samsung CD ROM; Sony cd writer. I have a problem with hp skjet 640C printer in open suse 10.2 linux. The printer is working fine windows 98SE. In opensuse 10.2 the printer does not work. It is getting detected, but does not print the test page in Yast. I get the message: Problem with lp port. The printer is connected to /dev/lp0. I have even entered the I/O address(ox378). But somehow the problem persists. 2/3 days back I reinstalled the whole O.S(open suse10.2). The printer worked for some time and after that the same old problem with the printer: Problem with lp port. The printer is used for local printing only ( I have only one machine). I would like get some light on this problem.
With thanks and best regards to all

I had the opposite problem, my Deskjet 720C never worked. I can’t find the messages, but they were something along the lines of “your parallel port doesn’t appear to exist”

I was messing around in KDE trying to sort out my font size when I fell over:
From the KDE menu enter Settings–>Peripherals–>Printers
Now select driver from the panel on the left and click on change. There are two 640 drivers listed on my system, you may have to try both. Now click next and click on the Test page button.

You will have to enter the root id and password.

Once I’d gone through this stuff, my printer started working, everywhere.