Panda mini wifi N USB (ralink 3070) adapter and opensuse 13.2 not working

I have purchased a Panda Mini Wifi N USB adapter to use with an old laptop where I have a fresh install of OpenSuSE 13.2. When I plug in the USB adapter, it is seen ok. But when I issue an “ifup wlp0s29f7u7” command for it, I receive this error in the syslog.

wicked[1843]: device wlp0s29f7u7 failed: call to org.opensuse.Network.Wireless.changeDevice() failed: General failure

I have a different laptop here that has openSuSE 13.1 installed on it. I plugged the adapter into that laptop and it worked successfully with no issues on the same wireless LAN. So I know the adapter is good.

Having read a sticky or two, here is my attempt to give the diagnostic info of interest.

  • This page indicates that this chipset works ok, and that is my experience with openSuSE 13.1, too.

  • Laptop is a Dell Inspiron 6000 (32-bit processor). Yes, this motherboard has a built-in wireless B/G NIC, but the built-in NIC has a h.w. issue (confirmed with with old win/xp system that was on it before I wiped the drive and put openSuSE 13.2 on the system).

  • Network Manager is disabled and not running. (I never use it.)

  • I ran yast online update and rebooted to assure all available service as of this morning was installed.

GaryDelllaptop:~ # cat /etc/os-release 
VERSION="13.2 (Harlequin)"
PRETTY_NAME="openSUSE 13.2 (Harlequin) (i586)"
GaryDelllaptop:~ #

GaryDelllaptop:~ # lsusb
Bus 001 Device 002: ID 148f:3070 Ralink Technology, Corp. RT2870/RT3070 Wireless Adapter
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
GaryDelllaptop:~ # 
GaryDelllaptop:~ # hwinfo --wlan

(info about integrated NIC on the motherboard snipped. The integrated wireless NIC is not configured in yast. The following is for the usb wireless NIC.)

23: USB 00.0: 0282 WLAN controller
  [Created at usb.122]
  Unique ID: zFuK.i+8+cNT5FUE
  Parent ID: k4bc.9T1GDCLyFd9
  SysFS ID: /devices/pci0000:00/0000:00:1d.7/usb1/1-8/1-8:1.0
  SysFS BusID: 1-8:1.0
  Hardware Class: network
  Model: "Ralink 802.11 n WLAN"
  Hotplug: USB
  Vendor: usb 0x148f "Ralink Technology, Corp."
  Device: usb 0x3070 "802.11 n WLAN"
  Revision: "1.01"
  Serial ID: "1.0"
  Driver: "rt2800usb"
  Driver Modules: "rt2800usb"
  Device File: wlp0s29f7u7
  Features: WLAN
  Speed: 480 Mbps
  HW Address: 7c:dd:90:60:f9:19
  Link detected: no
  WLAN channels: 1 2 3 4 5 6 7 8 9 10 11 12 13 14
  WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.457 2.462 2.467 2.472 2.484
  WLAN encryption modes: WEP40 WEP104 TKIP CCMP
  WLAN authentication modes: open sharedkey wpa-psk wpa-eap
  Module Alias: "usb:v148Fp3070d0101dc00dsc00dp00icFFiscFFipFFin00"
  Driver Info #0:
    Driver Status: rt2800usb is active
    Driver Activation Cmd: "modprobe rt2800usb"
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #22 (Hub)
GaryDelllaptop:~ # 
GaryDelllaptop:~ # rpm -qa | grep kernel-firmware
GaryDelllaptop:~ # uname -a
Linux GaryDelllaptop 3.16.7-7-desktop #1 SMP PREEMPT Wed Dec 17 18:00:44 UTC 2014 (762f27a) i686 i686 i386 GNU/Linux
GaryDelllaptop:~ # 
 dmesg | tail -n 11
  175.952202] usb 1-8: new high-speed USB device number 2 using ehci-pci
  176.085631] usb 1-8: New USB device found, idVendor=148f, idProduct=3070
  176.085644] usb 1-8: New USB device strings: Mfr=1, Product=2, SerialNumber=3
  176.085651] usb 1-8: Product: 802.11 n WLAN
  176.085658] usb 1-8: Manufacturer: Ralink
  176.085664] usb 1-8: SerialNumber: 1.0
  177.809199] usb 1-8: reset high-speed USB device number 2 using ehci-pci
  177.935868] ieee80211 phy1: rt2x00_set_rt: Info - RT chipset 3070, rev 0201 detected
  177.966856] ieee80211 phy1: rt2x00_set_rf: Info - RF chipset 0005 detected
  178.022843] ieee80211 phy1: Selected rate control algorithm 'minstrel_ht'
  178.026961] usbcore: registered new interface driver rt2800usb
GaryDelllaptop:~ # 
GaryDelllaptop:~ # lsmod | grep rt
rt2800usb              26712  0 
rt2x00usb              20041  1 rt2800usb
rt2800lib              83150  1 rt2800usb
rt2x00lib              52982  3 rt2x00usb,rt2800lib,rt2800usb
mac80211              606410  3 rt2x00lib,rt2x00usb,rt2800lib
crc_ccitt              12627  1 rt2800lib
iTCO_vendor_support    13502  1 iTCO_wdt
cfg80211              475693  4 mac80211,rt2x00lib,libipw,ipw2200
GaryDelllaptop:~ # 

GaryDelllaptop:~ # ifup wlp0s29f7u7
wicked: device wlp0s29f7u7 failed: call to org.opensuse.Network.Wireless.changeDevice() failed: General failure
wlp0s29f7u7     device-not-running
GaryDelllaptop:~ #

Hopefully I have not forgotten any info that someone might want.

A bug report describing similar. You might try updating wicked, as there have been a number of bug fixes and improvements AFAIU. (Also mentioned in a thread today.)

Thanks for the suggestion. I updated the wick rpms from the repository pointed at in the thread. Rebooted. No change in symptoms from that which I described in my initial post above.

GaryDelllaptop:~ # rpm -qa | grep wicked
GaryDelllaptop:~ # rpm -qa | grep sysconfig
GaryDelllaptop:~ # 

Then I suggest that you add to the bug report, explaining with the necessary information.

A DELL 6000? I have some old DELL’s, a D630 in my junk box, what model wireless card does your system have and can check and see if have a suitable replacement (for free) for you if you pay for the shipping?