Palimpsest crashes

Ok - I found this very nice utility - “gnome-disk-utility”, aka palimpsest. I had it working, it reported one of my hdd going bad. I replaced the hdd, reinstalled openSUSE 11.2, and now palimpsest won’t run.

From the menu it fails silently.
In a terminal, gnomesu palimpsest gets me this:

symbol lookup error: palimpsest: undefined symbol: gdu_pool_new_for_address

So, I retry the menu, and I check /var/messages from Yast:

Apr 22 11:14:19 suse-linux gnomesu-pam-backend: The gnome keyring socket is not owned with the same credentials as the user login: /tmp/keyring-AL5WCU/socket
Apr 22 11:14:19 suse-linux gnomesu-pam-backend: gkr-pam: couldn't unlock 'login' keyring: 255

My guess is that there is a settings file in /home from my last installation that is borking running this now. But what is it? Could it be
And, if it is, what do I do about it?
In the error mssg, the /tmp/keyring/socket? I don’t know anything about that. What is it?

There is a similar, and unsolved post here gnome keyring socket problem in new install of 11.2 - openSUSE Forums

There is a bug report in Ubuntu-space that might be meaningful, but it’s over my head, and palimpsest in 11.2 was working last time I installed it.


btw - I’m getting a similar message when I try to run gparted. Running it from the gnome menu gets me a warning that only root can run it. Using gnomesu gets me a pw dialog box, then a silent fail, with a similar message in /var/messages.

You asked me to look into this. As I am a KDE user and this seems to be a purely Gnome tool I even had to look up this in Google and Wikipedia. I found some documentation of no value at all.

In any case looking at it from a very general point, as this is a tool to be run as root, I do fail to see the connection with something in the home directory of an end-user (by incident being the end-user that does call the gnomesu command). But you could test this by using another user. One created anew for the purpose of the test could hardly be poisened (and also easily be deleted afterwards).

The pam backend points to PAM which is one of the possible ways to do user identification and authoratation. When you have it also at other ‘su to root’ programs is more likely that it is something there then in palimpsest.
Do you have problems doing

su -

in a terminal? I know you hate the CLI, but that is the most simple test I can think of to test if ‘becoming root’ is working.

If it’s from the previous install I would guess that you need to remove
it and re create your keyrings as they request it. Just move it for the

mv ~/.gnome2/keyrings/login.keyring .

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 7 days 6:50, 4 users, load average: 0.77, 0.72, 0.40
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 195.36.15

I did - and thank you for doing so.

Good point - and I should try it while logged in as root, too.

Henk - lol! - naw, I don’t hate the CLI at all. I DO hate being forced to use it for tasks that seem to me as something that the computer should be taking care of. One of these is having to look up configuration edits that I will use, at most, once a year, in a worst-case scenario. If I had this all to do all over again - my strongest advice to myself would be to pay for SLED. I might still do that.
O - and btw, I can become root just fine w/ su-, no problems there, mate!

You know what I love tho? I love it when a gui helps me take care of things, but also helps me drill down and learn - while keeping the system running. The first couple of versions of Access (sorry to mention MS in a good light) were just like this to me. They gave me a gui to make things happen, but I could look under the hood to see how things actually worked! What resulted was that I could make things work, while at the same time learning how to do it better using more technical approaches. I don’t want to seem dogmatic or rigid, but I don’t have time to learn everything in the world that I am capable of learning. I need to focus on spending my learning time on learning what I love. In my case, this is not OS underpinnings.

I would liken the current state of computers, our current era if you will, to a century ago in the automobile world. Back then you needed to learn how to drive, AND how to be a mechanic, AND how to mechanic your particular auto (since they were all so vastly different). Today we learn how to drive, and our mechanics take care of the rest. If we are really adamant, we CAN fix our cars ourselves, but it takes significant learning. The kind of learning MOST drivers have no interest in.

With My Best Regards;

I will give it a shot!

As indicated, not being a Gnome nor a PAM user myself (that is why I did not look into this problem before you asked me, it’s title indicating it is none of my business), I guessed a few things. malcolmlewis’ post indicates that it probably was not to wild a guess. I hope with his help you will get this settled.

And about the driver and the mecahnic. That is correct, but the end-user is the driver and the administrator (root) is the mechanic. The problem being that PC users (whatever OS they use) often think that when they can drive, they are also perfect mechanics. And specialy in MS Windows, where the drivers have unrestricted access to the moving parts this proves to be disastrous. But also with Unix/Linux, mechanics still require knowledge beyond what the end-users needs. Now the boundary is shifting and GUIs are a real help here. But, as I said in the other thread, a GUI should attack a complete, logical belonging together, problem not the individual edits of config files.

And for the status the system has now, I have a backup of all in /etc plus an extra, easy to consulte web site with important system hardware and software data.

A quick followup for those who come along later - maybe even me, after I’ve forgotten what I did. No resolution to date.


  • Deleting the keyring didn’t make a difference.
  • There was a similar error message: “undefined symbol: gdu_pool_new_for_address” on a bug report in Ubuntu about 2008. That bug report was closed. There is another bug report from Ubuntu-space, reported in the link in the first post in this thread. It isn’t quite identical, but the functionality problem described is identical.
  • I get the same problem when trying to invoke gparted from the command line. However, starting gparted as su works, and palimpsest doesn’t. Palimpsest seems not to like being run as root, tho.

I’ve given up on this for now - my workaround is to use the cli toolset “smartmontools”. The smartctl command works, and gives me the required data, although I had to learn how to interpret it. See TocDoc

Actually, fyi, there is another program to partially replace palimpsest - gsmartcontrol.

Palimpsest, aka gnome-disk-utility, is a gui front end for partitioning and other stuff, including SMART data. “gsmartcontrol” does the SMART data part, different author, with a slightly “rawer” gui. But it works, and it is available via one-click install from OpenSUSE build service.

Aah, gee, sometimes. . . I don’t know why I didn’t think of this before - but this worked. What worked? I reinstalled. Actually, I reinstalled an earlier version of Palimpsest - and it works again. When I last installed it, I got version 2.30. I reinstalled, but with version 2.28 - and voila, I have the pretty interface again!

When I was researching the last two updates on this thread, I looked up gnome-disk-utility on the Build Service, just for giggles. And what did I see there, but three (!) versions of Palimpsest available for 11.2. So I picked the middle one.

Partial resolution. Gnome-disk-utility (Palimpsest) working.