pacpl - need help with an perl error message

On starting “pacpl” I am getting handsful of errors such as:
String found where operator expected at /usr/bin/pacpl line 1924, near “case ‘FREQ’” (Do you need to predeclare case?)
FREQ and the line number changes, the basic error is always the same.

I used pacpl under Suse 11.4/Gnome and it always worked fine.

What has changed:
Suse 12.1/LXDE
pacpl as offered by Yast
( as this did not work, I switched back to older version and an installation compiled from source.
No weird messages during installation, no differences in the error message.)

My best guess is, something of PERL is missing/can not be found where it was installed.
At the first start I had this problem with which was well hidden for pacpl but could be corrected with an symbolic link.

I am not at all familiar with PERL. Could someone please advice me how to approach this issue?

Are all of the requires installed (they should be pulled automatically)?

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.1 (x86_64) Kernel 3.1.0-1.2-desktop
up 14:36, 5 users, load average: 0.33, 0.14, 0.08
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

Hi Malcom,

thank you for the feedback. It helps to have all the requires printed, though I doubt that this is the problem.
After all I ran 3 or 4 different installations which can not all be bad. Well, I will make sure all requires are installed and I saw some other items on the list to look after - but this will take time.

What I am really worried about is, a file might be badly placed and pacpl does not see it as it was with The directory tree of 12.1 might be different from 11.4.
Further in this list there is a lot of window manager stuff which would suggest my switch form Gnome to LXDE could be a problem. I ruled this out because I run pacpl from command line.

The really bad point is that this error message does not give any hint such as file not found.

I will come back after verification of the require list…


This is a good news bad news end to the thread.

Good: pacpl works as expected. Bad: I do not know why.

Checked* requires* - OK
Checked build requires: all but one OK - installed missing perl-switch - after that the program worked as expected.

Question remaining: switch was on my system before and pacpl had recognized it, - and I did not build pacpl this time.

So what???

A really puzzled penguin

So it looks like I need to add perl-Switch to the requires as well so
it’s installed.

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.1 (x86_64) Kernel 3.1.0-1.2-desktop
up 1 day 12:04, 5 users, load average: 0.01, 0.03, 0.05
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU


Hi Malcolm

perl-Switch seems to be a pretty frequently used module and, as such, will probably be present at 99% of the usual installations.
However it sure helps the remaining 1% (me!) to have it in the requires.