Pacman segmentation fault?

I just got pacman from this repository: Index of /repositories/games/openSUSE_11.2/i586
But when I try to run it, it does not start and when I tried it in a terminal, it said: pacman
Segmentation fault

What does this mean? Yast didn’t say that anything was missing when it installed it.

The correct URL would be

Index of /repositories/games/openSUSE_11.2

Were you installing manually?
or did you add the repo?

It means Segmentation fault - Wikipedia, the free encyclopedia. But you don’t need to understand that to do the correct thing… the game must start, if it doesn’t it’s a bug, report it at It’s so simple.
If you go to you will see a bug icon. Clicking on it will send you directly to a page in to report the problem to Pavol Rusnak. Who would fix the problem.

I updated and fixed it. Now you will install it, will see how hobby-time 1995 X games were, and uninstall it :wink:

RedDwarf: Thanks for the reply.

The link you gave,…&project=games did not work for some reason. All I got was the “Welcome to the openSUSE Build Service” page so I never saw a bug icon.

I did reinstall it from the one you fixed. It’s cute but it’s so small and there was no sound. I guess that’s what you mean. Anyway, I’m keeping it. :smiley:

I had tried out pacman-arena too but when I installed, it, Yast told me I needed another package. When I found and installed that one, I was told I needed still another package for that one to work. Isn’t there some way to tell what other packages are needed first (like what does)? I got pacman-arena from the same place as the pacman you fixed.

If you add the games repo, the games should install and run OK.

I tried both versions and don’t like them.
If you are addicted to the original version, try downloading the flash .swf file from Neave Games // Pac-Man …play the classic Pac-Man arcade game (you can figure out what to d/load from the code.
It doesn’t store the high scores, but it works.
Older redhat/fedora had the same game compiled for linux, but I haven’t been able to find the source to compile for later opensuse versions.

Click on my link, don’t copy & paste it.

You don’t download the RPMs manually. You should add the games repository (SDB:Add package repositories - openSUSE), and then select the game from YaST. This way dependent packages are installed automatically.

The link worked today. (Maybe it was down that day, I don’t know. I was clicking on it yesterday.)
I got pacman-arena now and its fun to play. Thanks! :smiley: